I have installed Windows 10 in an old server (specs follow) and I put it to sleep. I then was unable to wake it! I tried switching on or off several times, even removing power for a few minutes, nothing! I could hear the fan working, both the green LED (power) and red (HDD) where on and it would not boot! I even tried to remove the battery to reset BIOS, nothing! The solution was to remove one of the four memory modules, let it load Windows 10, shutdown and then install the fourth module again!

It seems there is some incompatibility with the sleep function in the old server system. Could it be drivers? Settings? BIOS settings? I don't know, I'll just never put it to sleep again! So everyone else having an old hardware, avoid putting it to sleep! Leave it running or completely shutdown!

Here are the server's specs:

Computer: Custom-build server system
Motherboard: Supermicro PDSG4 (Intel socket 775)
Chipset: Intel Glenwood 955X (supports up to Pentium D dual-core CPU socket 775, not newer models)
CPU: Intel Pentium D 945 3.40GHz dual-core socket 775
RAM: 4GB DDR2 667MHz (4x 1GB modules in dual channel mode)
Graphics: XFX GeForce 7300GS
SATA Controller: Intel ICH7R with RAID support
SCSI Controllers: Adaptec 7901 Single channel Ultra 320 SCSI & Adaptec SCSI RAID 20105/Supermicro AOC-LPZCR supported
LAN: Intel 82573V PCI-E Gigabit Ethernet Controller
Audio: Realtek AC'97 audio high quality 6-channel sound