Page 1 of 2 12 LastLast
  1.    04 Nov 2015 #1
    Join Date : Aug 2015
    Posts : 11
    Windows 10

    Unable to assign drive letters after Win10 Upgrade


    Hey everyone,

    This seems like a cool place with a lot of people that might be able to help me out.

    I tried the Windows 10 upgrade when it first came out and immediately went back to 8.1 when I couldn't get a single one of my internal SATA hard drives to mount.. I have 5 of them, and I just wasn't about to mess with that when 8.1 had no problems at all. Now I have tried it again and the same problem is happening. I want to see if I can figure it out this time. I am using the latest SATA and Chipset drivers for Win10 64 bit from Gigabyte's Website (I am using a Gigabyte Z77X-UD5H Rev. 1.1.

    I am "testing" Win10 using a bootable clone of my main SSD (that still has 8.1 on it) and I upgraded it to 10 just to mess with so I can figure out this ridiculous problem.

    My problem is that all of my internal SATA hard drives (with the exception of the system drive) cannot be assigned a drive letter in Disk Management. They show as healthy NTFS partitions but I get 1 of 2 different errors when I click on "Change Drive letters and Paths":

    1. "Virtual Disk Manager: The System cannot find the file specified."

    2 "Disk Management: The operation filed to complete because the Disk Management Console view is not up-to date. Refresh the view by using the refresh task. If the problem persists close the Disk Management console, then restart disk management or restart the computer" Hint: none of the recommended fixes in the error message change anything.

    I HAVE been able to assign the partitions a letter and mount them using a third party disk manager called "MiniTool Partition Wizard". It lets me mount the partitions and it works! ..However, if I restart the computer, I am back to square one and have to manually assign each drive letter for each partition every time.

    This is easily the worst experience I have ever had upgrading an OS, and one of the most mind boggling issues I have had with Windows in general. I really like Windows 10 and want to keep using it but half of my hard drives being un-mountable is a complete deal breaker right now.
      My ComputerSystem Spec
  2.    05 Nov 2015 #2
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,052
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    Please post a screen shot of Disk Management and also the result of diskpart below.
    Open Admin command prompt and type:
    1. diskpart
    2. list disk
      My ComputerSystem Spec
  3.    05 Nov 2015 #3
    Join Date : Aug 2015
    Posts : 11
    Windows 10
    Thread Starter

    Here are the pictures. The drive that has no partition is one that I messed up while tinkering and trying to figure this out. Good thing its backed up.. haha.

    Also here is the link to the 3rd party software I was able to get the drives to mount temporarily (until restart)
    MiniTool Partition Wizard | Best partition magic alternative for Windows PC and Server
    Attached Thumbnails Attached Thumbnails 2015-11-05 00.08.11.jpg   2015-11-05 00.08.17.jpg   2015-11-05 00.08.21.jpg   2015-11-05 00.08.26.jpg  
      My ComputerSystem Spec
  4.    05 Nov 2015 #4
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,052
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    I saw disk 1 and 4 are the same. Did you clone them ? Also noticed that you have efi system partition on disk 0, 1, 3 & 4. I assume disk 0 is your Windows 10 OS disk, am i correct ?

    Yes, I also have Mini tool and familiar with it.
      My ComputerSystem Spec
  5.    05 Nov 2015 #5
    Join Date : Aug 2015
    Posts : 11
    Windows 10
    Thread Starter

    Disk 0 is indeed the OS drive.

    1 and 4 are the same make/model/size of drive, but they are totally different partitions. 1 has sample libraries on it for virtual instruments, and the other has a bunch of my older Pro Tools sessions on it. The more drives, the merrier for Pro Audio work.

    I have often wondered why I need the EFI system partition on all of my data drives that don't have a boot loader for an OS or anything important... Can they be deleted? Could that be part of the problem? I much prefer alot of the 3rd party partition management software to the stock windows one, but I think most of these drives were likely formatted with the windows one. It also seems that the Windows one is "ground zero" for everything regarding assigning permanent drive letters. I have been working on getting all of my drives converted to GPT rather than MBR too.

    There are actually a few drives that aren't even plugged in right now.. (2 SSDs one with Mac OSX that I don't use much anymore and my main one with Win 8.1 aren't even hooked up while I mess with Win 10)

    Any ideas what might be causing so many issues with Windows Disk Management?

    - Sam
      My ComputerSystem Spec
  6.    05 Nov 2015 #6
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,052
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    Let's work on disk 1 first. Did you make a backup on this disk ? If yes, can we wipe it out and re-initialize it ?
    FYI, with disk < 2GB in capacity, there's no need to convert it to GPT.
      My ComputerSystem Spec
  7.    05 Nov 2015 #7
    Join Date : Aug 2015
    Posts : 11
    Windows 10
    Thread Starter

    I would rather not wipe any of the disks that are in the screenshots. I have some other drives laying around that I could try and format to see if they can be assigned a permanent drive letter though. That is a good idea. It would at least rule out whether it is a SATA or Chipset driver issue.
      My ComputerSystem Spec
  8.    05 Nov 2015 #8
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,052
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    OK. That's fine. If there's no OS on those disk then the EFI System partition should not be there. Yes, you can delete it, then assign a letter for partition 2.Open Admin command prompt, type:
    1. diskpart
    2. select disk 1
    3. select partition 1
    4. delete partition override
    5. select partition 2
    6. assign letter=Z
    7. exit


    If it works, do the same for other disks.
      My ComputerSystem Spec
  9.    05 Nov 2015 #9
    Join Date : Aug 2015
    Posts : 11
    Windows 10
    Thread Starter

    I tried the instructions you sent. Its the same error that was popping up in the GUI Disk Management.

    Both of the letters I tried were free/open letters to give a disk.

    The weirdness continues. I feel like I should install Windows 10 from scratch, but I don't have a DVD, or ISO to put on a USB flash drive for it.
    Attached Thumbnails Attached Thumbnails 2015-11-05 02.11.30.jpg  
      My ComputerSystem Spec
  10.    05 Nov 2015 #10
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,052
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    On disk 1. Since you deleted the EFI System partition and now if you go back and list the partition, there's should be only 1 partition.
    Try:
    1. diskpart
    2. select disk 1
    3. list partition ====> you will now have only one partition on disk 1
    4. select partition 1
    5. set id=07 override ====> To set the partition as basic data disk.
    6. assign letter=H ====> or any available letter.
    7. exit
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved Drive Letters
When I plug a USB stick in any USB port the laptop allocates the next available letter to this drive - "E" - this applies to any USB stick I normally use. EXCEPT for one particular USB stcik which always shows up as "G" even though "E" and "F"...
Drivers and Hardware
CD/DVD writable drive not recognized by OS after Win10 upgrade.
I have a SATA-1 TSSTcorp TS-H653 (not sure whether it is an F, G, H etc.) CD/DVD writable drive in an Inspirion 537s. I recently upgraded to Windows 10 Pro from Windows 7 Ultimate, but the drive is not recognized by the OS. However, the drive does...
Drivers and Hardware
Cannot mount network drives - drive letters not available
Hi I have a strange problem. I have some harddrives on a "server" computer in my homenetwork running win 7. From my "client" running windows 10 I am mounting these drives using psexec \\server -u username -p password -d net share F=F:\...
Network and Sharing
Cannot assign a drive letter
Hi folk. I have an external drive where the electronics of the case has failed. I have switched the drive into my pc so that I can use it as an internal drive. The drive is still operational but I cannot see it listed in my drives. Opening up disk...
Drivers and Hardware
Clean Installation Created Partitions with Drive Letters?!
Greetings All, I clean installed Win 10 RTM version on my laptop a few weeks ago. I have a basic GPT setup. Installation went fine, however the installer created a 'Recovery' drive (D:) with a size of 600 MB (262 MB free) & a 'Local Disk'...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:20.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums