1.    27 Oct 2015 #1
    Join Date : Oct 2015
    Exeter, UK
    Posts : 7
    Windows 10 Professional x64

    Pluralinput Mouse driver 0.8.6 frequently stops working


    I 'upgraded' from Win8.1 to 10 some two weeks ago, and am experiencing an increasingly frequent and disruptive problem, in that my Cirque Smart Cat touchpad stops working, and does not become operational again without a reboot - simply unplugging it and replugging it in (USB) doesn't restore any function.

    Until today I'd assumed that the culprit was the Glidepoint driver for the touchpad, and searched for a more recent version, but it turns out that I have the latest version, so no change there. Then I explored more and found in Device Manager, that no fault was shown for the Glidepoint driver when the touchpad stopped working, but a fault was showing for the Pluralinput Mouse 0.8.6 driver. Previously, in Win8 / 8.1, I was aware that the mouse driver was controlling some of the touchpad pointer movements, as well as the Glidepoint driver doing so - which I doubt to be a healthy arrangement.

    Fortunately I'd kept a couple of (different) USB mice in reserve, though I wouldn't use a mouse generally nowadays because of the RSI that I was getting from mouse use, and so I tried plugging in one and then the other of those when the touchpad had stopped working. In fact neither mouse would work then - which of course is unsurprising because it was the mouse driver that had fallen over.

    The trouble arises particularly when I have cause to do a little plugging in and especially unplugging and then plugging in USB devices (external HDDs). However, it also occurs quite often completely out of the blue while I'm in the middle of working in either Word or BlueGriffon, or indeed doing other things on the desktop. The pointer disappears, and that's it - I have to reboot. Very, very tiresome.

    Today, when I'd had this trouble resulting from connecting / disconnecting a succession of HDDs for backup purposes, I checked in Device Manager what the driver problem was purporting to be, and it said (i.e., for Pluralinput Mouse), that the driver had been unable to load because there was already an instance in memory - which to me looks to be rubbish.

    Anyway, I could find no more recent version of this driver, and I must say that I'm a bit appalled that Win10 comes out with a v. 0.8 beta mouse driver at all.

    So, please, what I want to establish is what alternative driver would be safe to use, because that one is clearly unfit for purpose - and I'm not going without my Smart Cat! I'd most appreciate some properly informed advice on this! -- Many thanks.

    Later addition:
    Forgot to mention - the driver error reported in Device Manager is given as Code 38, which appears to be fairly notorious, though with no relevant solutions that I could find online. Sweet little M$ Support happily suggests to sufferers from that error that all they need to do is reboot - which is really quite insulting. My problem is that indeed I do have to keep rebooting because of this issue, and b---- well shouldn't have to!
    Last edited by Philip Goddard; 28 Oct 2015 at 04:59.
      My ComputerSystem Spec
  2.    27 Oct 2015 #2
    Join Date : Oct 2015
    Exeter, UK
    Posts : 7
    Windows 10 Professional x64
    Thread Starter

    Slightly later note:

    Just tried uninstalling the mouse driver. That lost me the pointer for the touchpad, so the mouse driver is definitely required for that. Interestingly, with that driver uninstalled, Device Manager was showing the same error as I'd reported above - that the driver couldn't load because another instance was in memory. It sounds as though that particular error message is being given indiscriminately for occasions when the driver isn't functioning and even isn't present at all! At least the driver automatically reinstalled upon reboot, so I was spared hassle over that - but I still need to find an alternative driver.
      My ComputerSystem Spec
  3.    29 Oct 2015 #3
    Join Date : Oct 2015
    Exeter, UK
    Posts : 7
    Windows 10 Professional x64
    Thread Starter

    Really! Nobody in the Windows 10 Forum has any idea about this one? - Pull the other one, Cedric!

    In fact I myself finally solved / fixed this issue last thing yesterday, following yet another failure of that confounded Pluralinput Mouse driver. Further online searching revealed a report by one individual who'd had a non-functioning touchpad (not the same as mine), and his solution had been to go into the Mouse applet in Control Panel (that was pre-Win10), and look at what drivers were available within Windows for his pointing device(s). He found there was an alternative, which he switched to, and that had fixed his problem, with no need to search around online for a recommended alternative.

    Although his Windows version and mouse drivers were different, I actually found the same situation: I went to the Mouse applet in Control Panel and found that as well as the default Pluralinput Mouse, also 'HID compatible mouse' was listed. With bated breath I switched to that, and then -

    Well, er, then when I set out to challenge it not to do the Pluralinput Mouse's failures, i.e., by plugging in USB HDDs, the mouse driver continued okay but the HDDs failed to mount, and Device Manager showed that for each of those USB HDDs there was a failed Mass Storage Device. - Ouch! And it was with the same error code (38) and message as with the Pluralinput Mouse failures!

    I reasoned that as the Pluralinput driver evidently had some sort of untoward functional connection with ALL connected USB devices, probably it was the removal of Pluralinput that had upset the USB driver(s), rather than the use of the HID-Compliant Mouse driver. This was borne out by my regaining proper function of everything once I'd rebooted. Then and again this morning I tried out the various pluggings-in and unpluggings of USB devices that had caused the Pluralinput driver to fall over every time, and had absolutely no glitches this time.

    So, shame upon shame on M$ for putting an only partly developed and not properly tested v.0.8 mouse driver into their supposed flagship OS as its default! Whether the at least reasonably stable HID-compliant mouse driver was part of the Win10 installation, or whether it had carried over from my previous Win8.1 setup I have no means of knowing.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Graphics Card Driver Randomly Stops Responding
As of recently my graphics card driver has stopped responding at times and eventually recovers with windows coming with the usual pop up something along the lines of: "Your Graphics Card Driver Stopped Unexpectedly and has now recovered" This...
Graphic Cards
Mouse scroll setting frequently resets
Hi all, I'm experience some annoying problem with my Win7 to Win10 upgrade. _While using_ the computer the mouse scroll settings reset to 1. This can happen a couple of times during the day even though the computer never has been in sleep mode...
Drivers and Hardware
Win 10 Stops Working
I have 2 desktops. I downloaded win 10 preview on no 1 After a few minutes of log on time it just quits. The Drive light flickers but the scree goes to SAMNSUNG the Logo for the monitor MFG. I figured it was something wrong on my hardware. I took...
General Support
Waking From Sleep: Display Driver Stops Working, Recovers
Every time I put my computer to sleep for more than a few minutes, the display driver (nvidia gtx 770, 355.60 driver) crashes and recovers immediately. The gpu is not overclocked. Any ideas?
Graphic Cards
Solved MS Keyboard and Mouse driver not working for left handed mouse
I use left handed mouse, and swapping left / buttons works OK. I also set the wheel button to be "double click". But the wheel button brings up the context menu instead of double click. If I change to right hand mouse, the wheel button gives double...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:19.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums