Driver Creative Sound Blaster Audigy 4 Pro. for Windows 10

Page 2 of 2 FirstFirst 12
  1. spapakons's Avatar
    Posts : 2,891
    Windows 10 Pro 64-bit 202H (Nov 2020 build 19042.867)
       #11

    Try downloading the driver and all utilities directly from Creative. It doesn't need to be for Windows 10. Windows Vista, 7 and 8 will do (the later the better). Then be careful at each installation. Right-click the installer and run always as Administrator to make sure the installer has full access to required resources and won't fail because of that. Then if applicable choose custom mode and select all components. Standard installation frequently installs only some of the components, not everything. I always go for the custom. If any installer needs it, you can also set compatibility for an earlier Windows version. After installing all utilities in custom mode making sure you include all components and subcomponents, then the remote should work.
      My Computer


  2. Posts : 1
    Ubuntu + Windows 10
       #12

    I thought I should leave my 10 cents here because I was able to fix the SB Audigy 4 Pro to work perfectly fine on Windows 10. Yes I know this is an old thread, but I thought as seen as this is the first result for the search term "Windows 10 SB Audigy 4 Pro not working", I thought I should leave a solution that worked for me.

    I had to install the unsigned driver from here and then my SB Audigy 4 Line-in 1 through to 3 started working and I could use headphones too.
    NOTE: Before this I had tried to install the Creative Driver (from 2010) but that resulted in no audio at all, and so I installed the daniel_k Support Pack 7.0; however, that does not support the SB Audigy 4 pro and the microphone did not work, only headphone audio (the advantage of his driver pack was the fact i could get the Remote Working; however, no microphone support made me just give up on it).

    So to install I simply restarted into unsigned-driver mode and installed `kxdrv3553-full-unsigned.exe`, and it works perfectly (once i had set my Headphones to 2.1 speaker mode instead of 7.1). I set my Playback Device to "Master Mixer (kX 10k2 Audio (3553) - Generic)" and my Input Device to "Wave in HQ".

    Hope this helps other SB Audigy 4 Pro users,
    Jim
      My Computer


 
Page 2 of 2 FirstFirst 12

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:48.
Find Us




Windows 10 Forums