Page 3 of 3 FirstFirst 123
  1.    11 Jul 2017 #21
    Join Date : Jul 2017
    Posts : 1
    Windows 10 Home

    Same thing with Asus lately


    [QUOTE=XavierLH;591814] ... I've been running it successfully on an older HP laptop. I almost returned the Lenovo laptop until my research led me here and I understood that the issue was not with Lenovo but with the "spat" between Microsoft and Intel over who's responsible for ensuring that device drivers actually work.

    ^^^
    I received the same answer from Microsoft regarding Asus drivers and who's fault it was.
    (Asmedia usb 3 drivers are broken and occasionally glitchy on asus boards that came out last year)
      My ComputerSystem Spec
  2.    13 Jul 2017 #22

    I've had equally good results from using the modded intel drivers from Fernando at Win-RAID.com. See Forum - USB 3.0/3.1 Drivers (original and modded) for details, downloads and installation instructions.
    HTH,
    --Ed--
      My ComputersSystem Spec
  3.    1 Week Ago #23
    Join Date : Jan 2018
    Posts : 1
    Windows 10

    Thank you!


    Quote Originally Posted by Der Hund View Post
    Troubleshooting failing USB ports

    I had the same/similar USB port loss-problem with my HP Pavilion 11-n010dx x360 laptop with Windows 8.1, and I didn’t have the aforementioned problem-Windows Update (or its ‘child’ updates) to begin with. I also found that I would lose my USB ports- yet inconsistently so -when either other Windows Updates had been installed or I simply placed a certain microSD plug- w/ its USB adapter -into one of the USB ports (I guess the system couldn’t handle the shock of an 8GB microSD?). I believe I have reason to really suspect that the USB drivers (and the reluctance of the manufacturer to advance them for the 8.1 OS…) are really at the root of the problem but, anyway, here’s how I remedied this:

    Workaround/Remedy: Manually reinstall the driver.

    1. Open Control Panel, Device Manager to check for your USB device(s) listed as 'Unknown' under "Other" devices, and take note of the spec's. i.e.:

    Properties: Intel(R) USB 3.0 eXtensible Host Controller - 0100 (Microsoft)
    Status: The drivers for this device are not installed. (Code 28)
    Driver version: 6.3.9600.17797
    Event info. (the earliest dated *.inf file): 7/23/15 "Device configured (usbhub3.inf)"

    1. Search your system to find the usbhub3.inf file location –I found it within C:\Windows\WinSxS subfolders.
    2. Right-click the 'Unknown' (USB) item and choose the "Update Driver Software…" option,
    3. Choose "Browse my computer for driver software", as it won’t be found on-line, and "Browse..." then navigate to the ‘parent’ folder for your *.inf files (it was the C:\Windows\WinSxS for me) and check the “Include subfolders” box then “Next” to install the driver(s) and fix the USB problem.


    Notes:

    1. There will be MANY sub-folders to the WinSxS folder -I believe the ones you are most interested in for the USB ports have folder names similar to beginning with “amd64_usb” and include versioning like “6.3.9300” plus either “17238”, “17731”, and/or “18088” for actually up to 3 different ‘Unknown’ or missing USB devices.
    2. I determined that my system had two (2) of these “amd64_usb” sub-folders for each of three (3) ‘Unknown’/missing USB devices, and so I copied these (6) subfolders into my “C:\Downloads\HP Drivers\USB\USB_3.0_eXtensible_Host_Controller_Driver” folder to isolate them for any future possible necessary use. (And I actually updated-fixed my laptop from only them –not from C:\Windows\WinSxS).
    3. I’m not yet sure that this is a permanent solution, but I got my USB ports back real fast a couple days ago and it’s been good since.
    4. This issue still prompted me to resize down my drive in preparation to configure this laptop as a dual-boot system with a good Linux distro (probably Zorin for its Windows look-alike elements) -for the day Microsoft really advances their OSs to be incompatible w/ this little laptop.
    After two months my new laptop lost its USB ports. HP Support said the only answer was a reset, which I was not happy about as I'd already customised it quite a bit. Thanks to you I have them working again - kudos!
      My ComputerSystem Spec

 
Page 3 of 3 FirstFirst 123


Similar Threads
Thread Forum
Solved JMB38X SD/MMC Host Controller - Win 10 driver needed
Hi Successfully completed a clean reinstall with no problems, this time it picked up my Nvidia 310M graphics card (will update my other thread) and installed the latest driver for it. Only one remaining issue and that is a driver for the...
Drivers and Hardware
Usb xHCI Compliant host controller Driver Error
I have a gigabyte GA-Z77X-UD3H which uses the via chipset for USB (VIA VL800 chip) I have an error in system device for Usb xHCI Compliant host controller I am just wondering what drivers I can use for this? Also I didn't load any other...
Drivers and Hardware
UBS2 and UBS3 Host controller code48 after first reboot.
Okay, I upgraded from Windows 7 64Bit to windows 10 Home 64bit. Everything ran smooth and fine. I first get into windows (after the "Hi" screen and setting up apps screen) and I see my desktop. I install the latest video drivers first thing. I go...
Drivers and Hardware
Intel USB 3.0 extensible host controller preventing PC from sleeping
Hi everyone! Since I've upgraded to windows 10 I've been experiencing some sporadic problems where my PC will not go into sleep mode. I ran powercfg lastwake in command prompt and it came up with Intel (R) USB 3.0 extensible Host Controller. I then...
Performance & Maintenance
Solved Asmedia Sata Host Controller driver for Asus MOB
I have a Aśus Maximus V Gene mob that has two Sata mob inputs not controlled by the Intel Sata driver. I am having difficulty installing the latest Asmedia driver downloaded from the Aśus support site. With Win 7 there isn't a problem, but win 10 TP...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 08:21.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums