Windows 10: Intel® USB 3.0 eXtensible Host Controller driver

Page 2 of 2 FirstFirst 12

  1. Posts : 2,239
    Windows 10 Pro 64-bit 1607 (AE build 14393.1198)
       09 Mar 2016 #11

    Visit manufacturer's site and download latest USB 3.0 driver. If there is no driver for Windows 10, use that of 7 or 8. Install it just in case Windows Update has replaced it with a generic Microsoft driver. Then use the show/hide tool to hide any relevant update so it won't be replaced again. If it is an Intel USB 3.0 controller, you could also try the latest driver directly from Intel's support site.
      My ComputerSystem Spec

  2.    15 Mar 2016 #12

    Intel USB 3.0 eXtensible Host Controller


    Based on my latest testing, it appears the issue has to do with Intel USB chip set. I have been able to reproduce the issue on a machine of the different brand (at this time both reproduced on Lenovo and Asus laptop). The issue doesn't appear to be related to Windows 10 as I was able to perform the transfer on a computer running Windows 10 but using a different USB chipset.

    I have forwarded this information to Intel support as at this point the ball seems to be in their court. In the meantime, I stopped trying to find a solution on my Lenovo, and am doing my transfers with my older Win7 machine. Though this may not last long as Microsoft seems to be forcing more and more people over to Win10. These two companies (MS and Intel) need to talk and get their act together...

    If you have a Win10 machine using the Intel eXtensible USB chipset, I would be interested in hearing whether you can perform the same transfer: 200Gb or more between two USB connected hardware drives. Notes:
    • I don't have a drive (other than flash) greater than 32Gb
    • Transfers work well using Win7 on older machines (several)
    • I can transfer 200Gb between the internal SSD and an external USB drive without trouble
    • I can transfer 200Gb between an external USB drive and the internal SSD


    I don't have the hardware or lad to perform any further tests. Intel needs to step up.
      My ComputerSystem Spec


  3. Posts : 2,239
    Windows 10 Pro 64-bit 1607 (AE build 14393.1198)
       16 Mar 2016 #13

    Don't worry about the Windows 10 upgrade. The deadline to do it for free is until middle June 2016. After that it would be possible to do it, but you'll have to pay for the license. You have about 3 months to try and resolve your issues. In the meantime hopefully Intel will have released better working drivers.
      My ComputerSystem Spec

  4.    16 Mar 2016 #14

    I have purchased a Lenovo Thinkpad E560 and have the same problem -

    When copying a large file over a GB, they drop the speed down to 0 bytes - and comes back up the speed several seconds later - but drops again..

    I was trying to see what went wrong, but the same external drive fails on Lenovo works on Acer laptop.

    Contacted Lenovo for this issue - waiting for the answer from them.

    +Added:
    forgot to mention, Acer laptop is also using Intel USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)
    Last edited by hughkim; 16 Mar 2016 at 22:05. Reason: Adding
      My ComputerSystem Spec


  5. Posts : 2,239
    Windows 10 Pro 64-bit 1607 (AE build 14393.1198)
       17 Mar 2016 #15

    If the two USB 3.0 ports are on the same line, power and bandwidth is divided between the two connected hard disks. That's explains the drops, because there are some bottlenecks during the transfer when the buffer is full. USB cannot guarantee the transfer rate as firewire could. The solution is to use two USB 3.0 ports of a different line, which in a laptop is not possible. Or use a USB 3.0 port and a USB 2.0 port, but then you limit the maximum transfer rate to 480 Mbit/sec.

    However, if you are using the same Windows 7 driver in Windows 10, it should work the same. So the bottlenecks are not due to the driver. I guess they are due to the different bandwidth management Windows 10 do on the transfer than that of Windows 7. I am not sure, but you could change that from Device Manager. Connect both USB devices. Then go to Device Manager, right-click on one and select Properties. Select the Policy tab. Change from "Quick Removal" to "Best performance". Click OK to apply. Do that again for the second device. Now start the transfer again and see if the problem is solved. Let us know to do the same (when I got my hands on a computer with USB 3.0 ports, that is).
      My ComputerSystem Spec

  6.    03 Jun 2016 #16

    lx07 said: View Post
    You can't just install the Windows 7 driver in compatibility mode - you get a message "Your system does not meet minimum system requirements"

    Based on this thread you must edit the iusb3hub.inf and iusb3xhc.inf files to accept Windows 10 (delete lines with NTAMD.64.6.2 and change NTAMD64.6.1 to NTAMD64.10.0). Then you can install as described here
    Hello,

    Just to give my thanks, this seems to have made USB3 devices usable on Windows 10 using Asus z97-ar motherboard. Microsoft supplied driver caused rapid disconnecting/connecting and declining write speeds to the point of 0b/s when the device happened to stay connected.

    After installing Win7 drivers from Intel's website this way, write speed is USB3 level and no more rapid disconnects.
      My ComputerSystem Spec

  7.    03 Jun 2016 #17

    Carsomyr said: View Post
    For all of you in this thread, make sure your windows power plan is set to max power. USB 3.0 ports require it to function properly.
    Do you have a link to explain this? I've never had an issue using my USB 3.0 ports on different power plans.


    I've had to edit the USB 3.0 drivers to get Intel ports working under Windows 8.1, but on every system I've used Windows 10 on, the ports worked perfectly fine with built-in drivers. I was under the assumption this was fixed in 10.
      My ComputerSystem Spec

  8.    3 Weeks Ago #18

    Der Hund said: View Post
    Troubleshooting failing USB ports

    Workaround/Remedy: Manually reinstall the driver.

    1. Open Control Panel, Device Manager to check for your USB device(s) listed as 'Unknown' under "Other" devices, and take note of the spec's. i.e.:

    Properties: Intel(R) USB 3.0 eXtensible Host Controller - 0100 (Microsoft)
    Status: The drivers for this device are not installed. (Code 28)
    Driver version: 6.3.9600.17797
    Event info. (the earliest dated *.inf file): 7/23/15 "Device configured (usbhub3.inf)"

    1. Search your system to find the usbhub3.inf file location –I found it within C:\Windows\WinSxS subfolders.
    2. Right-click the 'Unknown' (USB) item and choose the "Update Driver Software…" option,
    3. Choose "Browse my computer for driver software", as it won’t be found on-line, and "Browse..." then navigate to the ‘parent’ folder for your *.inf files (it was the C:\Windows\WinSxS for me) and check the “Include subfolders” box then “Next” to install the driver(s) and fix the USB problem.


    Notes:

    1. There will be MANY sub-folders to the WinSxS folder -I believe the ones you are most interested in for the USB ports have folder names similar to beginning with “amd64_usb” and include versioning like “6.3.9300” plus either “17238”, “17731”, and/or “18088” for actually up to 3 different ‘Unknown’ or missing USB devices.
    2. I determined that my system had two (2) of these “amd64_usb” sub-folders for each of three (3) ‘Unknown’/missing USB devices, and so I copied these (6) subfolders into my “C:\Downloads\HP Drivers\USB\USB_3.0_eXtensible_Host_Controller_Driver” folder to isolate them for any future possible necessary use. (And I actually updated-fixed my laptop from only them –not from C:\Windows\WinSxS).
    3. I’m not yet sure that this is a permanent solution, but I got my USB ports back real fast a couple days ago and it’s been good since.
    4. This issue still prompted me to resize down my drive in preparation to configure this laptop as a dual-boot system with a good Linux distro (probably Zorin for its Windows look-alike elements) -for the day Microsoft really advances their OSs to be incompatible w/ this little laptop.
    Thanks, mate!! You saved me from reinstalling!!!
      My ComputerSystem Spec

  9.    1 Week Ago #19

    on EUFI bios.
    can choose UEFI USB in boot menu , and then install of windows 10.
    you got 2 options for your USB stick in the boot menu , so choose the one with UEFI USB.
    this will create extra partitions , and boot faster, and you can now use legacy devices and older drivers.

    for USB older devices , choose legacy USB.
    then i believe you won't need the older drivers , but you can use the microsoft xHCi host controller driver.
    and Microsoft 3.0 HUB driver.

    the INTEL and Etron install without a problem on creators update , but fail to start my external 3.0 HDD .

    the Microsoft default works fine if you set legacy enabled.

    if legacy is OFF or auto , it might make USB disconnect/connect noises over and over.

    install the Intel or motherboard manufacturer chipset drivers too.


    the error (heads up) in log is normal i believe.
    because for USB stick and external drive it is swapping drivers on boot.
    in Bios it uses a different driver then the driver on windows.

    you will see that the drive started later in another log file.
    just not reported as error.
      My ComputerSystem Spec

  10.    3 Days Ago #20

    Or maybe that diver swap had something to do with fastboot.
    i dunno for sure.

    on build 16199 with fastboot enabled , i don't get warning messages anymore
    and no color profiles bug.
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
Hi Successfully completed a clean reinstall with no problems, this time it picked up my Nvidia 310M graphics card (will update my other thread) and installed the latest driver for it. Only one remaining issue and that is a driver for the...
I have a gigabyte GA-Z77X-UD3H which uses the via chipset for USB (VIA VL800 chip) I have an error in system device for Usb xHCI Compliant host controller I am just wondering what drivers I can use for this? Also I didn't load any other...
Okay, I upgraded from Windows 7 64Bit to windows 10 Home 64bit. Everything ran smooth and fine. I first get into windows (after the "Hi" screen and setting up apps screen) and I see my desktop. I install the latest video drivers first thing. I go...
Hi everyone! Since I've upgraded to windows 10 I've been experiencing some sporadic problems where my PC will not go into sleep mode. I ran powercfg lastwake in command prompt and it came up with Intel (R) USB 3.0 extensible Host Controller. I then...
I have a Aśus Maximus V Gene mob that has two Sata mob inputs not controlled by the Intel Sata driver. I am having difficulty installing the latest Asmedia driver downloaded from the Aśus support site. With Win 7 there isn't a problem, but win 10 TP...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:05.
Find Us