Windows 10: epson printer driver wont install

Page 3 of 3 FirstFirst 123

  1. Posts : 3,033
    Windows 10 Pro 64 bit
       15 Oct 2015 #21

    spapakons said: View Post
    Just remembered a Windows XP case that an HP multifunctional would not complete detection. The user has mixed various drivers for the same printer and while at device detection it always took too much time and eventually failed. I discovered that Windows would automatically pick a driver that wasn't the same version that HP software expected and hence could not verify that the hardware was detected in order to proceed to the next stage. To remedy that, I opened Device Manager during detection stage and manually replaced each printer/scanner driver with the one in the installation folder. After doing that detection completed successfully and installation went to the next stage. So after trying my suggestions in my previous post and you still have an issue, try manually installing the relevant drivers. You never know...
    True to fact if there is anything in there in Device manager under those areas pertaining to a printer remove them, if you look under Print Queues notice other items there to and printer not going to show since he was unable to install it yet. Not sure if that will work extracting off CD to put into Device Manager if it is not being detected from USB. Just first need to get a response from thread starter more.
      My ComputerSystem Spec


  2. Posts : 2,250
    Windows 10 Pro 64-bit 1607 (AE build 14393.1358)
       15 Oct 2015 #22

    I had once this experience, that is due to many drivers present, Windows would just pick one it thought suited the device best. If this wasn't the version expected from HP Setup, detection would take too much time and eventually fail. I was able to make it work by manually replacing all drivers with those in installation media. This may well be the OP's case as well, so I wanted him to know the solution.
    Last edited by spapakons; 15 Oct 2015 at 17:00.
      My ComputerSystem Spec

  3.    16 Oct 2015 #23

    Thanks very much for the advice guys didn't have access to my pc yesterday but will have a look at all this tonight and see what happens. Will let you know.
      My ComputerSystem Spec

  4.    16 Oct 2015 #24

    ok i've followed your advice and went into device manager where i removed the trace of the epson sx235 printer that was in there. i then went to printers and devices and noticed that epson sx235 was in there too (it wasnt showing in there past few days and when i've tried to print or download drivers etc). why its showing there now and not when i started this thread i have absolutely no idea!
    anyway i tried to print and it's now working and printing fine. i've no idea why this is tho but its working ok.
      My ComputerSystem Spec


  5. Posts : 2,250
    Windows 10 Pro 64-bit 1607 (AE build 14393.1358)
       16 Oct 2015 #25

    Glad to hear you found a solution.
      My ComputerSystem Spec

  6.    16 Oct 2015 #26

    Thanks a lot for your help mate.
      My ComputerSystem Spec


  7. Posts : 3,033
    Windows 10 Pro 64 bit
       16 Oct 2015 #27

    That means the drivers were in there all the time while you were trying to install them. Setup Guide says to install printer first then the drivers, could of been the cause as some printers can be different to way to install them as have to go by each printers guide. Glad you fixed.
      My ComputerSystem Spec


 
Page 3 of 3 FirstFirst 123

Related Threads
Epson Perfection Scanner 2480 driver in Drivers and Hardware
Hope this may be of help to someone.:) The following file/driver enabled me to run a 2480 scanner in windows 10 64bit Epson Perfection 24803.0u It is Version 3.0u Make sure you remove all previous drivers for the scanner, then...
The Stylus Pro 7600 is now a really old printer, the last supported driver was for XP but it worked in Windows 7 and I believe to some extent in 8 although I never did try it. It s a really good reliable large format printer though and very...
Have got an EPSON Stylus Office BX300F. I can still print but the Scanner part has stopped since I upgraded to Windows 10. I have been on the Epson site and got new Drivers for Printer ok. Nothing for the scanner. This is an all in one...
cannot uninstall Epson Printer in Drivers and Hardware
Following upgrade to 10 I need to uninstall Epson Printer and reinstall. have initiated uninstall but it will not complete the process. Anyone any ideas how to achieve this please?
hi I have recently took the free upgrade to windows 10 from windows 8 how ever now my Epson dx8400 all in one printer will not be recognized by 10 worked fine on 8 just plugged usb in and set up automatically 10 wont pick up at all ive downloaded...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:06.
Find Us