Creative X-FI Soundcards


  1. Posts : 53
    Windows 10 Pro
       #1

    Creative X-FI Soundcards


    Has anyone been successful in getting their X-FI soundcards to work under Windows 10. Mine worked perfectly under Win 7 and when I did the upgrade to WIndows 10, it stopped giving me sound. I just finished over the last couple of days upgrading to the new Creative Drivers and still no sound. I even went as far as to do the update for all the Creative Software and still no joy. Thanks...

    Mike
      My Computer

  2. BugMeister's Avatar
    Posts : 3,954
    64-bit Win10 Pro Insider Build 19569
       #2

    check your BIOS..
    there may be an option to switch to the onboard HD Audio device during boot-up..
      My Computers

  3. topgundcp's Avatar
    Posts : 2,766
    MintMate19x64 Win10Prox64
       #3

    Yes, It's a little glitch with Creative X-Fi. Open Device Manager->Sound, video and game controllers, right click on Creative SB X-Fi, disable it then re-enable.
      My Computer

  4. spapakons's Avatar
    Posts : 2,891
    Windows 10 Pro 64-bit 202H (Nov 2020 build 19042.867)
       #4

    Right-click on the volume icon and select Playback Devices. Click on Speakers - SB ... and make it default. Click Configure and then Test. You should hear sound now. Restart your computer to see if sound is working properly. Don't forget to also install Alchemy to enable EAX support in games.
      My Computer


  5. Posts : 53
    Windows 10 Pro
    Thread Starter
       #5

    topgundcp said:
    Yes, It's a little glitch with Creative X-Fi. Open Device Manager->Sound, video and game controllers, right click on Creative SB X-Fi, disable it then re-enable.
    That was the trick that solved the problem. I did a google search on the problem and that is what I found. I had been using the onboard Audio, but wanted to get the XFI working. All is well. Thanks
      My Computer


  6. Posts : 53
    Windows 10 Pro
    Thread Starter
       #6

    BugMeister said:
    check your BIOS..
    there may be an option to switch to the onboard HD Audio device during boot-up..
    I had been using the onboard audio, but wanted to get my SB working. Problem has been solved. Thanks.
      My Computer

  7. kpo6969's Avatar
    Posts : 16
    Win 10 Pro x64
       #7
      My Computer


  8. Posts : 3
    Windows 10
       #8

    Thanks that worked!


    topgundcp said:
    Yes, It's a little glitch with Creative X-Fi. Open Device Manager->Sound, video and game controllers, right click on Creative SB X-Fi, disable it then re-enable.
    Tried all sorts; your simple trick works :)
      My Computer

  9. spapakons's Avatar
    Posts : 2,891
    Windows 10 Pro 64-bit 202H (Nov 2020 build 19042.867)
       #9

    This is because Windows 10 had not configured the device resources properly for some reason. Disabling the driver releases the resources and re-enabling it assigns them again, this time properly and the card works OK.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 03:07.
Find Us




Windows 10 Forums