Windows 10: SSD USB 3.0 is not accessible

  1.    07 Oct 2015 #1

    SSD USB 3.0 is not accessible


    I have been using this SSD for almost 2 years now and I couldn't be happier until a couple of days ago, when my computer did not read it when I connected. (I use a Qosmio X70, win 10)
    Here's what's happening. When I connect it shows up on the task bar as it's manufacturer's name rather than the name i assigned to it, does not show up in My computer, shows up at "USB mass storage device" in device manager, but does not show up in disk manager and finally it shows up (in it's manufacturer's name again) in "printers and hardware".
    If I try to eject it from the task bar, nothing happens, when I remove the cable a message pop's up saying the device was in use by a program.
    Furthermore when I try to uninstall it from "device manager" the app freezes and is not responsive.

    Is there a way to fix it, I'd rather not lose the files in the SSD, but if it's a must it would be fine; I;d settle for just formatting it and getting it back as it was.

    PS I tried to access the SSD on my windows 7, doesn't show up in any way there. Also changed the cable, nothind happened.
      My ComputerSystem Spec

  2.    08 Oct 2015 #2

    Sounds like USB adapter problem otherwise it would show up in disk manager, at least as "Raw".
    You can try another adapter or to take it out of enclosure and try connect using SATA cables on a desktop computer to make sure it's not due to drive itself.
      My ComputersSystem Spec


  3. Posts : 2,303
    Windows 10 Pro 64-bit 1706 (CU build 15063.608)
       08 Oct 2015 #3

    Right suggestion! I've seen that in a number of cases. Due to some power surge while connecting or disconnecting the cable, the adapter is damaged. Try the disk on another computer or with another SATA-to-USB adapter. If the disk is OK (99% chance) then you can buy a new USB enclosure and put it there. The USB 3.0 version used to be a bit expensive, but prices have dropped.
      My ComputerSystem Spec

  4.    08 Oct 2015 #4

    An update, I opened up the external and connected it it directly to my mother board.
    The computer froze at the Toshiba logo, had to force shut down. Then connected it to the motherboard with the laptop on, and nothing. As if it's not there, didn't show up in device manager, disk manager or anywhere else...
    What do I do now?

    PS I tried connecting via USB with another wire, same thing happened as described in the original post
      My ComputerSystem Spec


  5. Posts : 2,303
    Windows 10 Pro 64-bit 1706 (CU build 15063.608)
       08 Oct 2015 #5

    Sorry to bring you the bad news, but in this case the disk is faulty. If it contains valuable data, you can try finding the same model (see part number on label) and preferably manufactured around the same date. Then the two disks will match and an experienced technician can take the working circuit board from the new disk (this will void warranty!) and place it on your original disk. It will bring disk to life where you can either continue using it as it is, or if it has further damage you can at least backup it. In the second case you can backup all your data to a third disk. When ready, the technician puts the working circuit board back on the new disk and you can restore your backup on the new disk. The third disk necessary can be the technician's temporary storage. You don't need to buy two disks!
      My ComputerSystem Spec

  6.    08 Oct 2015 #6

    Well, I'm taking it to a professional tomorrow. Let's see what he will say.
    Good thing the files in it are not THAT important.
      My ComputerSystem Spec


 

Related Threads
I have two VMs in a VirtualBox Win7 Host. One is an upgrade of a Win7 machine and the other is a conversion of a IP install to the ISO download. I am having a problem accessing my NAS (an old Netgear ReadyNAS) from these machines. I read in...
Hi there, I was wondering if anyone could help with any suggestions. After upgrading to Windows 10 any usb stick shows up in file explorer but when I try to open it - it says drive not accessible / access denied. Any help is greatly...
Hiyas, for some applications I can't expand/see/modify Quick access category. It onlly shows in left pane collapsed. If I click on random folder in file browser part and choose rightclick menu Pin to Quick access, I get error message Incorect...
All drivers not accessible except "C" in Drivers and Hardware
I upgraded my PC from windows 7 to windows 10 Home yesterday. Unfortunately i am not able to access all the partitions except C. Earlier i set permission to the non-Admin users to avoid using these drives, but now from admin user also i can't access...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:43.
Find Us