Windows 10: AutoPlay non-functional in Win 10 Pro

Page 5 of 5 FirstFirst ... 345
  1. spapakons's Avatar
    Posts : 2,483
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
       11 May 2016 #41

    dalchina said: View Post
    Seriously bad idea. Registry cleaners attempt to look for leftovers, inconsistencies.. might find and 'clean' 100s of things- that really don't matter- and may well do damage not discovered until a lot later. There was a long thread on this until quite recently.

    What we'd like to find is specific, focussed, and almost certainly not the sort of thing one of those would detect.

    Could be change in value, a deletion, an addition... we just don't know.
    If we knew roughly where to look, it would be possible to compare a user's entries where autoplay worked with one where it didn't.
    Or, noting what is installed, progressively install those programs and test autoplay each time and discover which had that effect, then try uninstalling it and see what the effect was.

    Very time consuming!
    In that case, assuming we have a computer with working Autoplay and we extract any autoplay Registry entries in a REG backup file. Is there any utility that can compare the file with the Registry and highlight any differences? Then one could examine them and make out a solution.
      My ComputerSystem Spec

  2.    11 May 2016 #42

    Regshot can compare registries - it's designed to take one snapshot, then you do sthg, then another snapshot, and it gives the differences- additions, changes, deletions.

    However getting useful sources of comparison might be tricky. You'd really need a case where autoplay was working, snapshot, then you break it, snapshot, and compare. However, there may well be too many changes between a & b to make the comparison useful.

    The snapshots would have to be from the same PC of course, and the same user.

    Personally if I were to try to identify this, I'd start with this sequence until I got (maybe) autoplay working again (No guarantees of that!).
    a. create a disk image of a non-working case (where USB flash drives and optical media were ignored)
    b. progressively uninstall anything that supported mounting a disk (checking autoplay)
    c. progressively uninstall anything related to burning disks (checking autoplay).
    d. progressively uninstall any players or anything that could play media (checking autoplay).
    e. progressively uninstall some other category I can't think of right now (checking autoplay).
    f. Uninstall Virtualbox (if present).

    Finally having identified a culprit, restore my image, check, uninstall the culprit, check autoplay.

    Repeat if more than one culprit.

    The converse would be like, namely this: start with a clean functional system, and install things until autoplay breaks.

    Tedious... but once you have a simple case where you can go from autoplay working to not working by eg installing one program (assuming that's what happens) then you can use Regshot and compare snapshots.

    Of course, it may also be to do with setting defaults for programs....
      My ComputerSystem Spec

  3. spapakons's Avatar
    Posts : 2,483
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
       11 May 2016 #43

    I suspect the last (setting defaults for programs) is the culprit. In this case it would be easy to check. Create a new user account and check autoplay. If it works, then examine carefully the settings in any CD/DVD and media player application. Compare with the settings in your default user account. Change them to match and the problem could fix. Yes, it takes time, but it could be a solution.
      My ComputerSystem Spec

Page 5 of 5 FirstFirst ... 345

Related Threads
In Windows 7 we could right click the available wireless networks and access their Status, Properties etc. as shown below. But in Windows 8, Microsoft has taken a step backwards and either removed this convenient feature or could this be a bug? I...
I've tried everything I know how to do within my skill-set(so very little, tbh). I'm getting Error code: 0xC004F012 when I try to Activate through the System menu, I'm getting "remote procedure call failed" when I attempt to do dism /online...
The Win 10 'Start Button' has become semi functional. Running win 10 Home 4 Gigs Ram on a laptop with 2 Users. The 'Left' click function no longer works on just 1 of the Users. However, the 'Right' click function still is operational.
Windows 10 Upgrade only partially functional in Windows Updates and Activation
I just finished trying to upgrade my HP Pavillion to Windows 10 from Windows 7 Home Premium SP1. The upgrade completed, but my taskbar is unresponsive (currently only the Windows icon, search and task view buttons are on it, and none respond to...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 05:22.
Find Us