Windows 10: Really Bad Mouse Lag Solved

Page 6 of 6 FirstFirst ... 456
  1.    06 Feb 2016 #51

    You can search for that easily.

    Clean boot = no extra progs, no extra services.
    Safe mode = minimal drivers, services, no extra progs (approximately).

    Sorry there's no magical fairy to wave a wand; sometimes you have to do some diagnosis.

    (I'm no IT guy- just what I've learnt in years of having a PC and solving all my problems without asking someone to do it for me. Sometimes forums have been very helpful)
      My ComputerSystem Spec

  2.    06 Feb 2016 #52

    Thanks Dalchina. Never knew that clean boot existed! I always thought safe mode was the only option. And I have been futzing for decades myself. Had my own IT guy, so only learned enough to be dangerous...
      My ComputerSystem Spec

  3.    06 Feb 2016 #53

    How to perform a Clean boot in Windows 10 - TechNet Articles - United States (English) - TechNet Wiki

    MS has made it a bit more awkward to do in Win 10 than previously.
    I'm always astonished there's not an easier way to set it up.
    Far too many clicks.

    You could set a restore point before configuring for a clean boot, then recover from it by doing a system restore rather than undoing all the clicks manually.
      My ComputerSystem Spec

  4.    15 Feb 2016 #54

    i finally solved my mouse lag!


    hope it works for you.

    i downloaded driver packs, ran it, and turns out most of my chipset drivers were version 2006 (yes, i had installed all the original motherboard 2015 drivers)

    after restart, my lag was gone!

    hope it works for you,

    p.s. if you download the .iso image, windows 10 has the option to "mount it" so dont burn it to disk.
      My ComputerSystem Spec

  5.    18 Jul 2016 #55

    I just updated to Windows 10 from 8.1 a few days ago -- much smoother experience than the last time I tried (sometimes it does not pay to be an early adapter). Today was mouse lag day -- it was miserable trying to do ANYTHING. Found this lovely forum and thread, and tried several of the suggestions. Most important ones that worked included opening Control Panel and expanding USB drivers, then adjusting Power Management options to not allow the computer to control them. Second thing that worked was updating all drivers -- that was more painstaking, but I found several that were not up to date -- kind of surprising to me, given I am running a Lenovo Yoga. Long story short, everything is working really well now.

    Thanks so much for this thread and this forum. I created a log-in so I could share my experiences as well.
      My ComputerSystem Spec

  6.    21 Oct 2016 #56

    i think this solved it for me


    I had bad mouse lag or sticking and pausing. I read there was a connect button and remembered I had one. But I didn't think I had to press it because it was technically connected already. But I tried turning the mouse on and off with the switch and then pressing the recessed connect button using a pen and it was smooth after that.

    I have 3 wifi devices and a USB keyboard dongle and a my mouse dongle all going at once. I think the connect button actually switches channels that's what fixed my problem. I think I noticed a small lag one time when I first started to move it but I kinda expect that it's kinda sleeping till I start using it and it wakes up fast. But now after it wakes up there's zero lag/pausing. Love it. Thought I'd share the info.
      My ComputerSystem Spec

  7.    11 Jan 2017 #57

    Suddenly and without warning, now my Sculpt Mouse is not lagging but hesitating when scrolling. I put the Logitech MX Revolution on the shelf for this problem and for months, the Sculpt Mouse worked flawlessly. Now for whatever reason, it's hesitating like the Logitech. Anyone with an idea as to how to overcome this? I've tried the various compatibility modes but that's doing nothing.
      My ComputerSystem Spec

  8.    24 Jan 2017 #58

    Oh wait. Wait a minute. Wait, oh my, now the Sculpt Mouse is not lagging. I'm ecstatic. It's not lagging. The reason I am posting this is because of all the responses I've received since my posting one week ago. All those postings can be seen just prior to this one and after my last on. Thank you all so much for your great help. Just great!
    Last edited by Maggidon; 06 Jun 2017 at 01:13.
      My ComputerSystem Spec


 
Page 6 of 6 FirstFirst ... 456

Related Threads
Mouse Cursor Looks Funky in General Support
I just noticed a few days ago that my mouse selection cursor looks funky. I dunno why it started to look this way, but it's really annoying. (It's really big and unintuitive) Not only that, but it also looks funky when it's in "hand" state....
Mobile Using a mouse with Windows 10 mobile in Windows 10 News
Read more: http://www.neowin.net/news/using-a-mouse-with-windows-10-mobile
Logitech Mouse M705 in Drivers and Hardware
I have this mouse with a Logitech K750 keyboard. Windows 10 recogises the Keyboard & installs the solar update but the mouse itself isn't fully functional as left/right scrolling with the wheel doesn't function. Have tried installing the...
Hi there "Back to the future". Bog standard Ms USB mouse doesn't work properly in W10 build 9879 VM after latest Windows updates applied (Ok on earlier releases). VMware tools etc all installed -- no difference. The Toolbar only works when the...
Solved MS-DOS Mouse & Keyboard not working in Drivers and Hardware
I have old PC and new keyboard and mouse, they don't work on my old PC, I want to install MS-DOS 7.10, what should I do? Thanks.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:36.
Find Us