Page 1 of 2 12 LastLast

  1. Joined : Sep 2015
    Posts : 9
    Windows 10
       27 Sep 2015 #1

    Realtek Ethernet not showing in adapter settings. And more.


    Hi, people.

    Edit: In post #16, you'll find that the solution is to do a re-install of Windows. Feel free to try all the other methods we've tried. Best of luck.

    TL;DR Messed around with the drivers, now the ethernet device doesn't show up in the network adapter settings, although it shows up in the Device Manager. It is also apparently in sleep mode.

    So after formatting and installing Windows 10 x64 on my Dell Inspiron 3542, I decided to update/re-install the drivers from the official Dell download page. Windows Update had taken care of the hardware but the versions were outdated, so I set to work. After successfully installing almost all the drivers, I ran the Ethernet Controller Driver and after installing it, the ethernet device was disabled. BTW, the device shows up as "Realtek PCIe FE Family Controller".

    I enabled it but it still remained disabled. In the Properties dialog box it gave me the option to disable it, which means that it thinks that the device is enabled, which it is not. It is visible in the Device Manager, so it is being recognized. After restarting to come to the same result, I deleted the driver from Device Manager and re-installed it, which didn't work. (I don't remember if I attempted a roll-back, although if I did then it obviously didn't work either.)

    Then I went to the Realtek official website and downloaded the Win10 Auto-installation Program. It asked me to remove the previous installation from Dell, and near the end, it gave me the error, "The Realtek Network Controller was not found. If Deep Sleep Mode is enabled, Please Plug the Cable". And after this, or after deleting and re-installing the Dell driver (I unfortunately don't remember when), the ethernet device disappeared from the adapter settings. Now there's only Wi-fi there.
    Click image for larger version. 

Name:	netadapter.PNG 
Views:	3 
Size:	11.2 KB 
ID:	39753
    I searched online for the problem, and the solution seems to be in the Power Management tab of the device's Properties. Unfortunately, mine doesn't have that.
    Click image for larger version. 

Name:	realtek.PNG 
Views:	59 
Size:	17.2 KB 
ID:	39754

    I really want my ethernet back, even though I have wi-fi to connect to the internet. The only solutions I can see are to either get the Dell driver working or to remove the device from sleep mode. I'm sure you guys can come with a better solution, which is why I came here. I hope this info is enough, although if not, feel free to ask for more.

    Thanks in advance.
    Last edited by theholydemon; 24 Nov 2015 at 23:34. Reason: Adding Solution
      My System SpecsSystem Spec


  2. Joined : Oct 2013
    Texas
    Posts : 7,544
    Windows 10 Pro X64
       27 Sep 2015 #2

    Your screen shot looks like you went to adapter properties from the network and sharing center. Go to control panel, device manager, choose your nic, right click and choose properties. It should show there. It should have the tab where you went but this is worth a try.

    Click image for larger version. 

Name:	allow sleep for nic.PNG 
Views:	4 
Size:	66.8 KB 
ID:	39759
      My System SpecsSystem Spec


  3. Joined : Sep 2015
    Posts : 9
    Windows 10
       27 Sep 2015 #3

    Believe me, tried and tested that option. Thanks for replying so soon!
    Click image for larger version. 

Name:	realtek.PNG 
Views:	2 
Size:	46.2 KB 
ID:	39767
      My System SpecsSystem Spec


  4. Joined : Oct 2013
    Texas
    Posts : 7,544
    Windows 10 Pro X64
       27 Sep 2015 #4

    Did you try a manual install, instead of running the driver? Like shown here

      My System SpecsSystem Spec


  5. Joined : Sep 2015
    Posts : 9
    Windows 10
       28 Sep 2015 #5

    Thanks for the video, but I had already tried that option. For the sake of our sanity, I'll try it again.

    I uninstalled whatever driver was there in the first place (did not delete it). Then I pointed DM to the inf file of the Dell drivers.
    Click image for larger version. 

Name:	Qhke3Vm.png 
Views:	2 
Size:	44.0 KB 
ID:	39904
    In an instant, this window appeared.
    Click image for larger version. 

Name:	U6OUZzX.png 
Views:	1 
Size:	38.8 KB 
ID:	39905
    After restarting, the situation remained the same.
    Click image for larger version. 

Name:	CmrIIdy.png 
Views:	1 
Size:	12.6 KB 
ID:	39906
    I then tried the drivers from Realtek's website.
    Click image for larger version. 

Name:	wRfO3rQ.png 
Views:	1 
Size:	43.7 KB 
ID:	39907
    Literally the same things happened again. The situation remains the same.

    One thing I noted, was that the version of the driver did not change in DM, no matter which one I installed. The Dell drivers are ver. 10.1.505.2015 with release date 2015/7/30, and the one from Realtek is ver. 10.003 with release date 2015/8/24. But the drivers installed...
    Click image for larger version. 

Name:	ZUZmyBI.png 
Views:	1 
Size:	54.5 KB 
ID:	39908
    I thought that was noteworthy.

    I also tried a system restore before initiating this thread, but any of those ended with 0x80070057 errors. So I gave up on that.

    Thanks again for the vid.
      My System SpecsSystem Spec


  6. Joined : Oct 2013
    Texas
    Posts : 7,544
    Windows 10 Pro X64
       28 Sep 2015 #6

    Okay, a few more things to check. Make sure you are signed in as an administrator. Also look in your bios settings for power management settings. Maybe also look for a BIOS update.
      My System SpecsSystem Spec


  7. Joined : Sep 2015
    Posts : 9
    Windows 10
       29 Sep 2015 #7

    I'm definitely administrator. I updated the BIOS a few hours after I ran into this problem first. In the BIOS, there aren't many options available, this being a laptop and all. There was an option to disable Integrated NIC. I tried disabling and enabling that with reboots but that did not help.

    I also tried to delete the driver from my system. I ended up with an earlier version of the driver, but nothing else had changed. Then I tried "Search automatically...", manual install of Dell driver and a manual install of Realtek driver. All yielded nothing but this:
    Click image for larger version. 

Name:	X6qRzTV.png 
Views:	3 
Size:	53.5 KB 
ID:	40159

    BTW, here are the options present under Advanced tab. Thought they might be useful:
    Click image for larger version. 

Name:	gxuWxlR.png 
Views:	44 
Size:	18.0 KB 
ID:	40164 Click image for larger version. 

Name:	9haaP0d.png 
Views:	44 
Size:	17.7 KB 
ID:	40165

    Personally, I still think that the sleep mode is the only thing we need to fix. How, is what I'm not able to answer. I'll try to contact the Dell and Realtek Support Centers tomorrow. I also apologize for these late replies. Hope they don't discourage you. Thanks for the help!

    Edit: BTW, the LAN light on the router/modem turns on when connected. (The laptop doesn't have any lights on the exterior except for charging light.) I'll also try to find a live CD or pendrive to boot from to check if this problem persists elsewhere too.
      My System SpecsSystem Spec


  8. Joined : Oct 2013
    Texas
    Posts : 7,544
    Windows 10 Pro X64
       29 Sep 2015 #8

    It does seem as sleep mode is a problem, but the driver removal is an issue too. I'm going to look around. There is a tool to boot in safe mode and remove drivers but I'm having a brain cramp and don't remember it right now.

    Going to call for help on this.
      My System SpecsSystem Spec


  9. Joined : Sep 2015
    Posts : 9
    Windows 10
       30 Sep 2015 #9

    More help is better, thanks. I'm gonna try draining the battery completely of power and leaving it like that for a few hours to suffocate the motherboard. Heard it could reset the NIC, but I don't know for sure. Will report back.
      My System SpecsSystem Spec

  10.    30 Sep 2015 #10

    I'm reaching out to a friend at Dell (I live in Round Rock, and know lots of people there) who has worked in 3rd level tech support, special focus on networking, for 7 years or so. If I can get any insight from him on this problem, I'll report back later...
    --Ed--
      My System SpecsSystem Spec


 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
IP configuration not valid - interference from ethernet adapter?
Hi guys, I have a self built desktop that I only connect to the internet with using WiFi. But lately the connection on this PC is very intermittent and this is the only device in my house with this problem (so it's not the modem/router?). My PC has...
Network and Sharing
Windows 10 Pro Ethernet Adapter Does Not Retain DHCP Settings
The laptop computer is attached to a corporate domain. The DNS servers are providing DHCP settings. After logging onto the network, there is NO IPV4 address assigned despite DHCP enabled. Using ipconfig command, the setting is an obscure IP...
Network and Sharing
Solved Realtek issues Windows10 LAN/Ethernet driver..
33365 - available from Realtek downloads: Realtek
Drivers and Hardware
Solved Ethernet Adapter Speed variating
Hi guys, this is a standalone addition to another post i have. Anyways, this is weird. Windows 10 seems to have ****ed up my Network Intel driver. So on Windows 8.1, my adapter took in 1GBps, now on Windows 10 (with the correct driver!), it only...
Network and Sharing
Realtek Ethernet Problems
I have tried to set up Win 10 on my desktop,however, Win 10 conflicts with my Realtek Ethernet, I can not make the program to connect with the net, however, my lap top coneects (via WiFi) with no problems. Should I remove Win 8.1 frommy desktop and...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:45.
Find Us
Twitter Facebook Google+



Windows 10 Forums