Windows 10: DVD RW not seen in device manager or This PC. It does show in bios. Solved

  1.    24 Sep 2015 #1

    DVD RW not seen in device manager or This PC. It does show in bios.

    Upgrade from win 7 pro 64 to 10 pro 64. All hardware and software was new, name brand and authorized at time of original build. The bios shows the drive as sata 3.
    I checked the windows advisor and the drive is rated as acceptable. It's an Asus sata dvd-+rw.
    I used every windows repair and diagnostic tool I could find to no avail. The only update for the dvd player was firmware which I installed. I tried switching the bios to auto play but it did nothing.
    I did have problems with the upgrade. I could not get the upgrade icon although I had all the required files and had auto upgrades set, so I downloaded 10 to a dvd and did the upgrade. That's the last time the dvd player was recognized. It is working. Asus loads a mini os on it's mother boards called Speed Gate. I can use Speed Gate to to read file on a dvd but it wont execute.
    I tried making a recovery usb but it fails. I then tried reset but it disconnects the key board and mouse so I have to do a hard restart so reset fails too. I tried restarting with the win 10 dvd in the drive but it wasn't recognized. To update the bios the instructions say use the install disc. I tried using Speed Gate but could only see the list of files. It does give the option of using the asus update utility which should be in programs (apps in 10) but it isn't there.
    I think I'm going to try going back to 7, updating the bios and then trying again. I'm going to wait for any advise or suggestions first though.
      My ComputerSystem Spec

  2.    24 Sep 2015 #2

    Ok, you say that the drive is recognized in the BIOS, but not in Windows.

    You have previously updated the firmware of that drive, correct? Did the drive work correctly after you have done the firmware update? Or has it been broken, you then tried the firmware upgrade and it is still broken?
      My ComputerSystem Spec

  3.    24 Sep 2015 #3

    [FIX] Optical Drives (CD/DVD) Icon Not Showing in My Computer Window - AskVG

    It's a no rhyme or reason problem but follow that and it should get the optical drive back up.

    I had the same problem it was seen in bios and was used to install win disk but in device manager/this pc it was unseen after everthing was installed.
      My ComputerSystem Spec

  4. Posts : 36
    Windows 10 Home 64 bit
       25 Sep 2015 #4

    I had this problem when upgrading also on a friend's machine that had an AMD chipset. In the Device Manager there was no DVD drive listed, but it was there as an "unknown device." If I tried to update its drivers it wouldn't let me, it said they were most up to date (though no drivers were loaded). If I manually pointed it toward the driver on the machine it would then "recognize" it as a DVD drive but it did not work. When I used the manufacturer's software to analyze the drive it said it could not detect the drive, and so forth. The drive, however, would spin with no problem and although I did not try it I am sure it would have booted or run outside of the Windows environment, no fault in the drive.

    The advice in the link above did not work for me. If you search around you will find at least a few other pieces of advice, a few having to do with different registry tweaks, and none of them worked for me.

    Here is what *did* work for me. (Note, I am not sitting in front of that machine right now so I will be as precise as I can, as I remember the steps, but not all of the specifics. If someone wants more precise info I can borrow my friend's machine and try to be more detailed).

    1) Since it was an AMD chipset, I downloaded the newest AMD chipset drivers for that model (which come wrapped up in an AMD Catalyst program), you can find them on the AMD website.
    2) I then went into the "Programs and Features" and uninstalled anything that had to do with the optical drive, as well as a lot of the stock software that was not needed and running in the background and potentially messing with various settings.
    3) I went into the Device Manager and uninstalled the "Unknown Device" that was the DVD drive. (If prompted, choose to delete).
    4) I installed the new AMD chipset drivers / Catalyst software
    5) Back in Device Manager, I uninstalled and deleted the drivers for the ATA controller. At this point the machine requested / required a reboot.
    6) Upon reboot I went back into the Device Manager and told it to update the ATA controller drivers and I chose C:/AMD (I think) as the location. From there it then loaded the newer drivers for the ATA device, and possibly I did another restart (maybe not, don't remember). However, there after, the DVD drive was properly recognized and listed and worked without any problem.

    Good luck!
      My ComputerSystem Spec

  5.    25 Sep 2015 #5

    Thanks everyone

    Joergi, I updated the firmware for the DVDRW when I couldn't find it after the upgrade.
    Upcoast, thanks I'll try that link next. Are you saying you can run your dvd drive from BIOS? how?
    Lekden, I checked for unknown devices but none are shown. I don't know what programs might relate to the DVDRW other than maybe Realplayer and Divxplayer. I tried to update the various AMD drivers but read warnings not to try an update without Asus updater, which was apparently removed from my programs during the upgrade to 10. I can't use the Asus disc of course. (AMD says to update through the motherboard company) I had the same problem when I tried to update my BIOS. I'm afraid that the wrong update could do more harm than good.
    If Upcoast's link doesn't work I think I'll go back to 7, do a through cleanup of old files and unnecessary programs and try again.
      My ComputerSystem Spec

  6.    25 Sep 2015 #6


    Brilliant Upcoast! Your link worked and it was so easy. I used the 4th option. Thank you
      My ComputerSystem Spec

  7.    25 Sep 2015 #7

    Great to hear that the drive is back again!

    For guys coming after us:

    The method 4, which solved the problem, just means that you have to run this .reg file, which will modify one value in the Windows Registry:

    Windows Registry Editor Version 5.00

      My ComputerSystem Spec


Related Threads
Hi, So I have a dual-monitor setup hooked up to my port replicator for my Dell E7240. I have my main monitor hooked up with a DVI cable and my second monitor hooked up with a DisplayPort (from the port replicator) to HDMI (on the monitor) cable....
Hello, i was playing with disc partitions and i accidentally deleted something... The problem is, that when i start my computer, Windows boot manager error appears (with no options, nothing, just some text about how should i reinstall / repair...),...
Migrated OS 8.1 from HDD to SSD . Migration software installed command line in bios "Boot Manager on Disk 1". If I do a format of SSD will bios revert to original without the reference to disk 1. I intend on doing a clean install of Windows 10...
I've just added a 2nd HD to my Dell system with Win 10. It shows in the BIOS and Seagate tools finds it. It does not show up in Device manager or Computer Management/Storage - Disc Management or anywhere. Not sure if this si Won 10 specific. Anyone...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:48.
Find Us