CANON LIDE 210 - problem with WIA/TWAIN

Page 3 of 3 FirstFirst 123

  1. Posts : 4
    Windows 10 Pro version 1511 Build 10586.589
       18 Sep 2016 #21

    Tony62 said: View Post
    I had exactly the same problem with my Lide 210 scanner. I upgraded from Windows 8.1 to Windows 10 and started to get USB communications errors during scans.

    My motherboard is an ASUS Sabertooth Z97 Mark 2. The USB 3 drivers are from AsMedia.

    I upgraded the USB drivers from a third-party site, as I couldn't find any newer drivers on the Asus support site, but it did not help, I still had the errors.

    I contacted Canon and (after some persuasion) they tried to help, but they couldn't find the problem. They said nobody else has reported problems with the scanner on Windows 10 (ha, ha, ha, I don't believe them). They eventually said that the problem is due to my copy of Windows 10 because they accessed the Windows Error Logs and found errors there. Actually, almost every Windows PC will have errors in its Error Log so that's not the problem, because the errors in there were not related to scanning.

    So I did what was suggested in the answers to this post. I entered the BIOS settings, selected Advanced, then USB settings and set the 'xHCI mode' to 'disabled'. This sets all of the USB ports to be 2.0 rather than 3.0. The scanner then worked without errors.

    Although the scanner now works, I'm not happy with this solution because I don't want all my USB ports to be USB 2.0
    I recently upgraded to this motherboard to have the latest hardware, not legacy hardware.

    If anyone finds a better solution (such as driver updates) I would be very interested.

    Not sure if you found it, but canon now has an updated driver at LiDE 210 Scanner Driver Ver.17.0.5 (Windows) and it works perfectly :) after uninstalling the my old Windows 7 drivers which behaved the same way as discussed above.... Canon seem generally to be a bit slow getting their drivers updated for the windows 10 platform compared to other brands... that's according to my somewhat limited observation!
      My ComputerSystem Spec

  2.    03 Oct 2016 #22

    Canon Lide 210 Problems

    I have had similar issues with upgrading to Windows 10 and my Canon Lide 210 Scanner not working, and here is how I solved the problem.

    My computer is an HP Pavillion, with an AMD 4 core, 64 bit processor, 8 MB of memory.

    First thing, remove all the old software from your system, and, disconnect the USB cable from your scanner, and, then
    visit the Canon Scanner website.

    Next, turn off your anti-virus program as it may, (and did mine), corrupt the download.

    Download the new software, and the new instructions, MP Navigator, etc. Follow the instructions, and then when it instructs you to plug in your scanner, go ahead and connect it, and if you are connected directly to a USB port, your scanner will work.

    Mine didn't - - consequently, I purchased a Powered USB Hub, installed it, and, voila!! It Works again!!

    Hope this helps anyone out there who is having difficulty getting their scanner back on line.


      My ComputerSystem Spec

Page 3 of 3 FirstFirst 123

Related Threads
Someone seems to have left Canon out of the dev loop for Win 10 drivers. Does anyone know of a workaround, or should I just set up a corporate account with Kinko's? I currently cannot print to paper, and sometimes I need to. Also, please check...
Canon Pixma Pro9000 in Drivers and Hardware
I can't get Win10 build 10049 to install my Canon Pro9000 Inkjet printer. It is connected by USB and when I turn it on, an icon appears in the taskbar briefly and then disappears. Devices show Inkjet printer but no drivers available. I downloaded...
double Canon printer trouble in Drivers and Hardware
One of my pc's runs W7ult64, W10pro64 upgrade and W10pro64 build10532. It is connected to a Canon MG5550 all in one printer. W7 is running printer drivers loaded from the cd and up till now, I havn't bothered to try printing from either W10. Neither...
Canon PIXMA iP2500 in Drivers and Hardware
HI all, I have checking on the Cannon website and it does not currently have driver for the Canon PIXMA iP2500 Printer Is there any drivers I can use for this? Many thanks
Canon printer drivers in Drivers and Hardware
I am currently on Win10 build 10158 and none of the Canon drivers for my Pixma ip8750 two year old printer work correctly. There seems to be a break in communication between the app being used for printing and the OS handling the printer driver...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:48.
Find Us