Page 1 of 2 12 LastLast
  1.    07 Sep 2015 #1
    Join Date : Dec 2013
    Sydney, Nova Scotia, Canada
    Posts : 10,260
    Windows 10 IoT

    Pressing eject button on laptop DVD drive locks up Windows 10 Ent


    When I press the physical eject button on my laptops DVD drive Windows 10 completely locks up. Tray doesn't open either. Frozen cursor, ctrl alt del does nothing. I have to force a shutdown by holding the power button down. Going to My PC, right clicking the drive and selecting eject does work though. ASUS K65DE running Windows 10 Enterprise, clean install several months ago. Almost never use the optical drive so only just noticed this recently. Other than this Windows runs normally and the drive is usable. Device manager shows nothing out of the ordinary. Worked fine in Windows 8.1. Stock Windows supplied drivers used on all hardware. I haven't got a clue what to look at or where to go with this issue? I debated whether to post it here or in the software section.
      My ComputerSystem Spec
  2.    07 Sep 2015 #2
    Join Date : Apr 2015
    California
    Posts : 362
    Windows 10 Pro x64

    Sounds like a driver issue or maybe needs a firmware upgrade for the dvd drive. Get the DVD model number from Device Manager and go to the drive mfg web site and look for a firmware upgrade.
      My ComputerSystem Spec
  3.    07 Sep 2015 #3
    Join Date : Dec 2013
    Sydney, Nova Scotia, Canada
    Posts : 10,260
    Windows 10 IoT
    Thread Starter

    I'm on it, Google is just throwing up those garbage driver finder program sites though. It's a Matshita dvd-ram uj8c0 according to Device Manager. I'll keep looking though.
      My ComputerSystem Spec
  4.    07 Sep 2015 #4
    Join Date : Apr 2015
    California
    Posts : 362
    Windows 10 Pro x64

    Another alternative, if you don't really use the dvd drive, there are hard drive caddies available that fit in the laptop dvd slot and allow you to install a 2nd hard drive in the laptop.
      My ComputerSystem Spec
  5.    07 Sep 2015 #5
    Join Date : Dec 2013
    Sydney, Nova Scotia, Canada
    Posts : 10,260
    Windows 10 IoT
    Thread Starter

    It has dual drive bays, 17.3 inch screen. I already have 2 SSD drives in it. The DVD drive is usable, I just have to remember not to press the eject button. I hardly ever use it to be honest. I'd still like to sort it out if possible though.
      My ComputerSystem Spec
  6.    07 Sep 2015 #6
    Join Date : Apr 2015
    California
    Posts : 362
    Windows 10 Pro x64

    I would also check and make sure the laptop has the latest bios from the mfg.
      My ComputerSystem Spec
  7.    07 Sep 2015 #7
    Join Date : Dec 2013
    Sydney, Nova Scotia, Canada
    Posts : 10,260
    Windows 10 IoT
    Thread Starter

    Just did that and flashed to newest BIOS via BIOS easy flash utility. It updated and verified. Laptop won't boot up now and I can't get into the BIOS. I've gone from bad to worse now. I've flashed it this way before with no issues. Time to contact ASUS tech support, not looking forward to that. All I get now is the ASUS logo flashing up over and over. I have to hold the power button down to get out of it. It's out of warranty now so looks like I bricked it.
      My ComputerSystem Spec
  8.    07 Sep 2015 #8
    Join Date : Dec 2013
    Sydney, Nova Scotia, Canada
    Posts : 10,260
    Windows 10 IoT
    Thread Starter

    I think I have it working again? It would not boot with my second SSD drive plugged in for some reason? I removed it, reinstalled (clean install)10 Pro on the first drive. Laptop booted Ok. Plugged the second drive in and no go, it just flashed the ASUS logo over and over. Took the drive back out and did a clean on it from my desktop PC. Plugged it back in and laptop booted up. I just formatted it and am coping my Data back to it from my external drive. Then I'll reboot and cross my fingers. Maybe the lockups, and forced shutdowns from the eject button messed things up? Time will tell. Right now I need a drink, as in alcoholic beverage.
      My ComputerSystem Spec
  9.    07 Sep 2015 #9
    Join Date : Dec 2013
    Sydney, Nova Scotia, Canada
    Posts : 10,260
    Windows 10 IoT
    Thread Starter

    Everything seems to be back to normal now, except the eject button, still locks up Windows when I press it. I'm now running 10 Pro clean install. It looks like Matshita was taken over by Toshiba. I didn't get anywhere on the Toshiba site. At a dead end for now. Just have to remember not to press the eject button.
      My ComputerSystem Spec
  10.    07 Sep 2015 #10
    Join Date : Jul 2015
    Poole Dorset UK
    Posts : 2,557
    Windows 10 x64 Home Version(1709) Build16299.19

    Try the free version of Auslogics Driver Updated I have the paid version but recommended the Free Version to some one today and it cured their driver problem they had
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Cortana not opening/not working when pressing the mic button
I have a problem with Cortana not opening after pressing the mic button on the taskbar and "Hey Cortana" does not work also. This is a clean install of windows 10 on a Lenovo laptop, I had no problems with Cortana before. If someone can help me...
Software and Apps
Windows 10 laptop won't shut down properly, needs power button to be p
Hi, I'm running Windows 10 Home on an ASUS Q551LN 2-in-1 laptop which originally came with Windows 8.1. When I shut down/restart/sleep the machine, it does not shut down - the Hark Disk activity light is still blinking and the normal power...
Drivers and Hardware
How do I make an image of my drive on laptop to get SSD?
Thinking of purchasing a new hard drive for my i7 laptop. It's an HP system that is a couple of years old. It has a toshiba hard drive 500GB. I am thinking that is what is causing to be "slow" compared to even my old laptop. Things just aren't that...
Performance & Maintenance
Windows Start Button Issues And Missing Edge Button
All of a sudden the Windows Start Button turns brown (not blue) and when I left click on it something is said about having to sign out and a critical error. Clicking that button, which you have to do to get rid of the dialogue box, restarts the OS...
Windows Updates and Activation
Search applications when pressing Windows key?
In Windows 7/8/8.1 I would press the Start/Windows button and start typing the name of a program (ie: Firefox, Word, etc) and it would pop up, learn, and as I did the same thing in the future.....I would just press Windows key, type wor, and Word...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:52.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums