Windows 10: HDMI sound from PVR is missing

Page 1 of 2 12 LastLast
  1.    05 Sep 2015 #1

    HDMI sound from PVR is missing


    After upgrade to w10 the sound via the HDMI port went missing. On this machine you press a button to switch from PC Mode to Game Mode, which activates the HDMI port where the PVR is plugged in. When viewing a PVR program (TV show), the video is perfect but there is no sound. I have updated drivers, rolled back drivers, & tried everything I can think of. What am I missing ??
    (besides the PVR audio)
    I have an HP Omni 27 1055 Desktop PC.
      My ComputerSystem Spec


  2. Posts : 3,438
    EL Capitan
       06 Sep 2015 #2

    Try updating the Audio driver and GPU Driver.
      My ComputerSystem Spec

  3.    06 Sep 2015 #3

    bro67 said: View Post
    Try updating the Audio driver and GPU Driver.
    I have updated the Audio Driver (IDT High Def Audio Codec) - no solution there - then I rolled it back to a previous driver, & ... no solution there. Windows 10 does not yield anything on a search for GPU (graphics processor unit) - that seems to be NVIDIA term, & W10 does not know it, perhaps because there is not an NVIDIA graphics card in this machine. The display card seems to be an INTEL(R) HD Graphics, & I have used the INTEL Driver Update Utility to see if anything helps there ... nope ... nothing helpful has happened yet. I am stumped ...
      My ComputerSystem Spec


  4. Posts : 558
    Windows 10 Pro/Windows 7 Ultimate
       06 Sep 2015 #4

    I have been having problems with NVidia drivers from 341.81 up. Ironically, not on Windows 10 but on Windows 8. It's because the video cards in both of my machines have reached eol (end of life). Check the Nvidia Driver page, there is a link for old/legacy drivers, you may have to choose one of those. Usually if it worked in Windows 7 or 8 it will work for 10, you might have to choose a 7 or 8 install package. If the installer fails, you can choose the driver from the extracted files in the C:\Nvidia folder. I had to do this and the drivers I needed went right in.

    Oh yes, the Intel drivers might be equally problematic, you will have to search for your Motherboard Chipset, look for a Windows 7 or 8 driver package for your Chipset, which should include your Graphics Drivers. You can use a free program like AIDA64 to identify which MB chipset is in your machine, if you don't know it already.
      My ComputerSystem Spec


  5. Posts : 705
    Windows 10 Pro x64
       06 Sep 2015 #5

    skins88 said: View Post
    The display card seems to be an INTEL(R) HD Graphics, & I have used the INTEL Driver Update Utility to see if anything helps there ... nope ... nothing helpful has happened yet. I am stumped ...
    So you are saying the Intel Graphics and not a third-party PCIe graphics card?
    If it is the former, then the Intel Graphics is the HD 2000.
    The latest driver is version 15.28.24.64.4229
    What driver are you using please?

    Also are you watching video through a tv, external monitor or the Omni monitor?
    Are you using built-in speakers or external speakers?
      My ComputerSystem Spec

  6.    06 Sep 2015 #6

    WhyMe said: View Post
    So you are saying the Intel Graphics and not a third-party PCIe graphics card?
    If it is the former, then the Intel Graphics is the HD 2000.
    The latest driver is version 15.28.24.64.4229
    What driver are you using please?

    Also are you watching video through a tv, external monitor or the Omni monitor?
    Are you using built-in speakers or external speakers?
    I checked in Device Manager & it says I have this version (9.17.10.4229) of Intel(R) HD Graphics. For the sound Driver it says that I have the IDT High Definition Codec, version (6.10.6504.0)

    What I have is a PVR plugged into the computers HDMI port. I use a button on the side of the computer to switch the computer from PC MODE to GAME MODE. What used to happen is that the computer display (the OMNI monitor) becomes the TV screen, with HD video & good sound. I use only the internal speakers - there are no externals hooked up. Now what happens is that I still get the HD video on the screen (OMNI monitor), but no sound, so I can watch everything from the PVR ... in silence. The PVR is fed via a modem that delivers internet & TV to our house. The PVR beside the computer is the main unit, with the hard drive. There are 2 other TV's in the house that have set top boxes that communicate with this main PVR unit. I can watch tv in silence - sometimes that is actually better, but technically, that is not how it is supposed to work. It all worked great last week ... running Windows 7 - before the upgrade to Windows 10.
      My ComputerSystem Spec


  7. Posts : 705
    Windows 10 Pro x64
       06 Sep 2015 #7

    @skins88

    That is the correct driver you have installed (15.28.24.64.4229 = 9.17.10.4229)

    Please advise on the following:
    • Is there sound coming out of the headphones when you have video running via the PVR?
    • When you open your playback devices dialog, are any of the devices showing activity when you have the video running via the pvr?


    NB - When checking the above, please use a music video or similar to test with. This will ensure that a silent moment during a film does not cause a 'false positive'
      My ComputerSystem Spec

  8.    06 Sep 2015 #8

    WhyMe said: View Post
    That is the correct driver you have installed (15.28.24.64.4229 = 9.17.10.4229)

    Please advise on the following:
    • Is there sound coming out of the headphones when you have video running via the PVR?
    • When you open your playback devices dialog, are any of the devices showing activity when you have the video running via the pvr?
    I have not tried headphones, but will in a while.
    I don't know how to watch device activity when the PVR is running as the OMNI display will be in PC MODE or GAME MODE, but can't do both at once. I will try running the PVR & watching device activity, but can't be sure the PVR is doing anything when the OMNI display is in PC MODE ... I can watch PVR video on the Omni display or I can have PC on the Omni display - just can't have both at once.
      My ComputerSystem Spec


  9. Posts : 705
    Windows 10 Pro x64
       06 Sep 2015 #9

    Cool. Please try the headphones in both sockets. (I think your Omni should have two headphone jacks. One on the left below the USB and another on the back above the tv coax input).

    Edit: Sorry. This probably should have been very first question I asked. Have you tested your HDMI cable on a different device to confirm the audio/video functionality is working correctly on that cable
      My ComputerSystem Spec

  10.    06 Sep 2015 #10

    WhyMe said: View Post
    Cool. Please try the headphones in both sockets. (I think your Omni should have two headphone jacks. One on the left below the USB and another on the back above the tv coax input).
    Tried both Headphone jacks while the PVR was running a tv show, with the omni display showing it ... but no sound anywhere.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Hi, i've got hooked to my television my computer trough HDMI in my Asus radeon R9 280x The problem is the following.. when i was under Windows 7 everything was working just fine and now .. I've got 2 screens plugged into my computer: 1:...
Missing sound schemes? in Customization
I have no alternative sound schemes on my win 10 installation. Is this normal at this stage? There are folders there for cityscape, delta and others but nothing in the folders. It's a clean install after upgrade. Thanks if anybody can enlighten...
Hi everyone, I just updated my PC to windows 10 and now I'm not getting any sound from my HDMI connected TV. Picture is working fine and have tried as many solutions as i could find. I've restarted, tried a new HDMI cable and used different...
Start-up sound missing in General Support
Start up sound has been restored via Windows Update KB3081424.
Solved HDMI sound missing in Drivers and Hardware
So far I've managed to screw the HDMI sound option from the volume menu and the sound control panel. I was trying to switch between to the motherboard sound option from the GPU card HDMI sound option and clicked on disable on the mixer panel from...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:00.
Find Us