Windows 10: USB Storage Devices

Page 1 of 2 12 LastLast
  1.    04 Sep 2015 #1

    USB Storage Devices


    I've been using Win10 since the general release. This was an update install on a Win7 laptop.
    Apart from a few issues (waking from sleep on scheduled tasks, lack of control on updates) I have a problem with external devices.
    If I use several USB flash drives/harddrive I'm able to eject one or two but then I can't eject any others. When this happens I don't get the menu option to eject/safely remove the device through "explorer" and the drive doesn't appear in the "safely remove" icon on the task bar. I can still access the drive without issue just don't have any way to eject except to shutdown the laptop. If I reboot the laptop but leave the device attached the eject option reappears.
    The laptop is fully patched and I can't work out what is happening and google hasn't revealed any similar problems except the normal "device is in use" message.
    Any ideas?
      My ComputerSystem Spec

  2.    04 Sep 2015 #2

    Do the flash drives show up on "This PC". Since you can access them I suspect they do. Have you tried right clicking on their icon and using the eject option?
      My ComputerSystem Spec

  3.    04 Sep 2015 #3

    The problem is that when this occurs the drives appear in "This PC" and I can still read/write to them BUT there is no "eject" option until I reboot.
      My ComputerSystem Spec

  4.    04 Sep 2015 #4

    If you right click on the icons of the flash drives, and open properties, what do they show up as under the hardware tab.
      My ComputerSystem Spec

  5.    05 Sep 2015 #5

    OK - just been using an external drive, via powered usb hub, without issue - eject option showing. Plugged in a second drive - again eject option showing and accessed without issue. Plugged in a third drive and able to access it with eject option still showing. Ejected this third drive - no errors reported. Went to eject the other two and eject option doesn't show via "My PC" - safely remove hardware on task bar also isn't responding. Clicking on any of the drives that are showing (internal, CD and two external) and then hardware shows all four with the three hard drives showing correctly. Clicking on each of these drives shows them as USB and working correctly.
      My ComputerSystem Spec

  6.    05 Sep 2015 #6

    Quick update - just checked and 45 minutes after I posted the reply above the Eject function has returned for both of the two external drives that were attached. Safely ejected one and then the eject function disappeared for the other drive. This time after a couple of minutes the eject function returned for the final external drive. Can't see anything specific in event viewer to indicate what is happening. I have a feeling it is going to be difficult to identify/sort - didn't have this problem in Win7
      My ComputerSystem Spec

  7.    05 Sep 2015 #7

    This is a longshot, but try hitting the refresh button when you open This PC.
      My ComputerSystem Spec


  8. Posts : 705
    Windows 10 Pro x64
       05 Sep 2015 #8

    @Anotherusername

    Since you are using a large number of usb ports at the same time, it is possible they do not all use the same chip. Manufacturers often add their own second chip (in addition to the standard chipset) to increase the number of available ports for improved connectivity.

    • How many USB chips does your motherboard have?
    • Is it always the same ports that do not offer the 'eject' option?
    • Are those ports running off a second chip?
    • If so, have you tried installing the applicable driver?
    • What exact laptop model are using?
      My ComputerSystem Spec

  9.    05 Sep 2015 #9

    I'm using a Belkin powered 7 port USB hub to connect the drives to my eMachines E525 laptop via one of its two USB ports. The drives are main brand only, i.e. western digital, maxtor. The issue occurs irrespective of which ports I use on the hub or which drives are connected - so no obvious pattern.
      My ComputerSystem Spec


  10. Posts : 705
    Windows 10 Pro x64
       05 Sep 2015 #10

    oh okay then...I was going to suggest checking the driver for secondary usb controller and chipset. But if there is not a discernible pattern then it may be a moot point. Your laptop probably only has the single controller. Sorry
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I am really missing the ability to easily see how much storage space is left on each of my drives. Why is this not easily seen just by opening "This PC" like it was in Windows 7. It seems like I have to click on properties in order to see disk...
Solved Extra storage in Drivers and Hardware
I want to add extra storage to my Surface Pro 3. I have 128gb on my HDD and would like to add at least another 64gb. Would I be better with an SD card or Flash Drive? RogerB
Solved storage setting in windows 10 in General Support
hi the setting app shows way more storage used than actually used says used 296 out of 580 when its only using 16 gb is there a way to reset it thx
disk storage in Drivers and Hardware
This is a odd one for even a support geek like me. For some reason windows 10 is reporting my total storage as 983gb and that all 983 has been used up even though I deleted a bunch of stuff and uninstalled some programs. I might add i also have a...
Storage Sense in General Support
I was getting ready to send MS a message about creating a storage usage App, and lo and behold there's storage sense. I don't know about anyone else but this is really great for me. Now I can easily see exactly what's taking up space without...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:03.
Find Us