Help needed - installing printer driver on win10 (ultimate solution)


  1. Posts : 20
    Win 10 Pro x64 21H1
       #1

    Help needed - installing printer driver on win10 (ultimate solution)


    Hello everyone, it is my first post on this site and on forum overall (and i am already looking for help :) ) so forgive me please if i violated any rule or explained myself uncorrectly (cause Non-Native Eng speaker).

    My problem is that i want to get my all-in-one printer-scanner working on my laptop through usb but sadly cannot get it working (for around 4 years i am haunted by this and maybe cursed). I want to find a ultimate way to get ant least my printer working on at least win10. After countless tries to find fix i was forced to make account here and ask directly.

    Device is: Canon PIXMA MX925 but it would be nice if any solution would work on other printers i have too in case of need to format and set up other systems from scratch.

    I belive it is windows itself issue since it is very unlikely to not beign able to setup normally 4 different printers from 2 brands at all on win10. Probably print spooler service issue.

    I want to get the printer working on usb - cable (not by wireless setup)

    Every trial always throws that “print spooler service stopped working” thus preventing further driver installation.

    Thing i’ve tried:

    1. Plug in device (USB) and install normally through official driver installation from manufacturer site + tried installing older versions of installers and all combos of x86 and x64 drivers.
    2. Start menu --> Settings --> manage optional features --> installing Print Management Console (since somehow it was missing)
    3. Checking if EduPrintProv task is working correctly in Task scheduler
    4. Group policy options: Admninistrative Templates/Printers:
    - “Allow for printers publishing - on”
    - “Allow for accepting cilents connections by Print Spooler - on”
    5. Adding/modifying reg keys:
    HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Printers\PointAndPrint (that was missing in reg)
    -NoWarningNoElevationOnInstall = 0
    -UpdatePromptSettings = 0
    HKLM\SYSTEM\CurrentControlSet\Services\Spooler\Performance
    -Open Timeout = changing to really high value and 0
    HKLM\SYSTEM\CurrentControlSet\Services\Spooler
    -DependOnService = RPCSS http --> RPCSS
    HKLM\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services\Servers
    AddPrinterDrivers = 0 --> 1
    6. Turning on and off windows features in classic control panel + restart:
    -Online printing client
    -LPR port monitor
    -printing service through port LPD
    7. Trying to install drivers in safemode (welp)
    8. Checking if windows-printing-pmcpcc-fod-something packages are installed-running using dism
    9. Installing manually update:
    https://www.catalog.update.microsoft...px?q=KB5004946
    10. Copy - paste - replace printing related files from pc on which printer is working like:
    spoolsv.exe
    PrintPlatformConfig.dll
    C:\Windows\System32\spool folder
    and everything in that folder and anything that have Print or spool/spooler in name
    11. step above but delete these files - restart pc and try again
    12. downloading from random sites files above and repeat this step
    13. everything related to stupid mainstream commands like sfc scannow and so on
    14. Checking in pc bios if maybe some option related to printing is disabled
    15. Disabling/ uninstalling antiviruses
    16. Disabling DEP in control panel
    17. Checking if print spooler service is working with other services related/relying on them like RPC
    18. services.msc --> spooler.svc --> tab log on --> tick off: allow service to work with desktop
    19. as above but tab recovery --> restart service for all errors
    20. Checking if any software installed is causing my problem somehow.
    21. Trying to bypass installation like from this link:
    Get old printers up and running on Windows 11 or 10 (Setup)
    (tbh i have recently set up hp printer on windows 7 like that and it is working - but this method doesnt work for me on win 10)
    22. Tried to install printer drivers using soft like Snappy driver installer and driver booster
    23. Default printer troubleshooting
    24. Extracting self-installer drivers and installimng manually .inf drivers
    25. Tick on/off read-only attrib from spoolsv.exe and whole Spooler folder in system32
    26. Stripping down to bare minimum windows using NTlite and check if it changes something
    27. Trying to repeat all above on virtual box
    28. Trying to install drivers on different account (even though all tries here were on Admin account)
    29. Checking for viruses using 4 different AVs
    30. Checking for health of my SSD
    31. Looking for some modded drivers from various sites
    32. Installing newest ISO from official MS site with latest updates-things and trying again
    33. Disabling driver cert enforcement and trying steps above

    And probably some more tries i forgot about.
    None of above them worked.

    Things ive not tried:

    -Updating windows 10 (Never - ever)
    -Downgrading to win 7
    -Checking everything described above on windows 11 (will not try this for sure)
    -Checking above points on 32 bit versions of any major windows aswell as minor editions like N, S Education, LTSB and so on
    - Installing drivers from shipped CDs - since i have none of them
    - Any system recovery options (since i have disabled this joke-feature)
    - Switching to Linux/Mac and try this horror again :)

    Things that are disabled/ non present on this system (maybe this affects something but i doubt it)
    (I really doubt it it affects something since i have couple of os-s that are stock-installed with everything default and i cannot set printers on them too)

    -Default Windows Defender
    -Classic CPL firewall disabled
    -Auto win10 updates
    -PAGEFILE + SYSMAIN OFF

    Overall problem looks like this:
    When i want to install driver software package it self-extracts - starts to install itself. - MP Drivers with progress bar pop ups --> welcome screen with Next button --> it starts to install with progress bar “deleting shortcuts” or something --> and boom warning : “Cannot continue because Print spooler service has been stopped. Restart service and try again”
    Then only thing left is to click OK and Close (installer prompts - install failed) and start depression again. - it looks like print spooler specifically stops for 1ms during installation and that prevents drivers from getting further.

    I really need to get official Canon driver packages working since it have bundled nice Ij Scan thing that you have multiple options to scan things into PDF and other options. I am fine with 3-rd party software workarounds

    Only thing that ive noticed is that after steps 6 and 4 (but only once after reboot) the automatic driver-software installer for printer went one step further without throwing error but then it still stops from installing further and timeout hits saying cannot find printer when printer is connected through usb - so installer cant go further. Also on windows 10 when i plugged device in then win10 self-installed something (or just set up entry) and My device shows in Classic cpl/devices and printers under “Printers” section. Printer showed also under “imaging devices” category in devmgmt.msc. Looks like it just added entry but not installed any driver or something so it is still not working.

    Ive had many issues with printers from start of my adenture with Windowses but i somehow managed to get them working. Only flawless working installation was HP printer-scanner (cant remember model) on my dads old laptop with Win 7 x64 (but switching to win 7 is not an option)

    I dont really care about print nightmare bullshit and anything like that - i just want these printers to be working through USB only without having to reinstall os (i hope for ultimate solution) so i can grow up my all pulled hairs again :)

    Device specs i want to get it working currently:
    Windows 10 Pro x64 running on sata SSD
    21H1 19043.1021
    (custom modded-stripped called Nexus-OS from World of PC)

    Just want to say overall thanks to users like Bree, Brink, Kari and may others for all of these tutorials since it greatly enhanced my experience with windows os-s through years.

    And thanks for your time if you wish to help me - any idea is appreciated.
    Forgive me if this post is too long to read.
      My Computer


  2. Posts : 43,282
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #2

    This is a hacked/modified O/S. As such, you use it at your own risk.
    I suggest to anyone thinking of responding that they very much bear this in mind.
    As such, considering the problem to be a 'Windows' issue may be entirely questionable.

    Device specs i want to get it working currently:
    Windows 10 Pro x64 running on sata SSD
    21H1 19043.1021
    (custom modded-stripped called Nexus-OS from World of PC)

    For reference: drivers page or printer.
    Pixma mx925 drivers
      My Computers


  3. Posts : 20
    Win 10 Pro x64 21H1
    Thread Starter
       #3

    Even if this is considered as hacked/modified windows it has nothing to do with it since i had problems like that on originally shipped win 10 when i bought this laptop, starting from very early first version 1507. Every windows 10 and 7 i tried to get printing work is legit. This one is legit too since i have original license key put there.

    - - - Updated - - -

    For reference: drivers page or printer.
    Pixma mx925 drivers[/QUOTE]

    yes this is this driver
      My Computer


  4. Posts : 43,282
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #4

    And thank you for your reply. I'm leaving this to someone else as you can see. Good luck.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:44.
Find Us




Windows 10 Forums