Any Microsoft guidance regarding driver installs?


  1. Posts : 459
    Windows 8&10
       #1

    Any Microsoft guidance regarding driver installs?


    My system seems to show several devices which do not yet have drivers, and some are just the Basic drivers for other devices.

    Has Microsoft given any guidance as to how drivers need to be installed in Windows 10? ASUS does not have any Windows 10 drives for my motherboard. I can, of course, use the 8.1 drivers. I just wanted to know if Microsoft had prescribed some process for updating drivers and wanted us to wait to see if they might come via Windows Update.

    Thanks..
      My Computer

  2. Dude's Avatar
    Posts : 15,804
    Windows 10 Pro X64
       #2

    I would use the 8.1 drivers for now. As the preview develops, more info will come out. That is the only info I have found, if It worked on 8.1, it will work on 10.
      My Computers


  3. Posts : 459
    Windows 8&10
    Thread Starter
       #3

    OK, thanks. I have been having problems dual booting where every time I booted to the other OS, I would get a "Your computer needs to be repaired" message. Since the OS booted normally by itself, I was thinking a possibility might be using different drivers for the same devices with going between OSes...

    Still investigating to see if I can pin it down. The 8.1 drivers will be installed.
      My Computer

  4. bromanbro's Avatar
    Posts : 282
    Windows 10!
       #4

    Works fine out of the box? Don't touch.
    Needs drivers? Get 8.1's, they should work. However keep your eyes open for 10 drivers.
      My Computer


  5. Posts : 459
    Windows 8&10
    Thread Starter
       #5

    bromanbro said:
    Works fine out of the box? Don't touch.
    Needs drivers? Get 8.1's, they should work. However keep your eyes open for 10 drivers.
    Whether it works out of the box might depend on how new your system is. I have a Z77 which had no yellow triangles, and a Z87 which had several.

    I have installed the drivers which seem to be necessary. Right now it looks like my booting problem was with the original Win X installation and its hard drive....
      My Computer

  6. Dude's Avatar
    Posts : 15,804
    Windows 10 Pro X64
       #6

    So all the bangs(yellow triangles) are gone now?
      My Computers



  7. Posts : 459
    Windows 8&10
    Thread Starter
       #7

    Dude said:
    So all the bangs(yellow triangles) are gone now?
    Yes, no triangles and no unknown devices. But again, it depends on your system. Asus has always been good about supplying drivers for their motherboards...

    On my Z77 board, all the devices were set up without any additional drivers. I do, however, still have the Plain Vanilla driver on my primary SATA controller, which probably works fine.
      My Computer

  8. CountMike's Avatar
    Posts : 19,056
    W10+Developer Insider + Linux
       #8

    Only after second or third boot, all the drivers were installed automatically, guess they had to be retrieved from internet. One of them (for TV card) is still wrong.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:14.
Find Us




Windows 10 Forums