Windows 10: Printing through server doesn't work anymore

  1. Posts : 5
    Windwows 10 Pro 64-bit
       28 Aug 2015 #1

    Printing through server doesn't work anymore

    Hi everybody,

    I have a multifunction HP C5280 printer connected via USB to my router that has a built in printer server and it's a couple of days I can't print through it from my laptop anymore (but I still can print from my smartphone as always).

    The problem started when I removed the device from control panel to try installing the latest driver downloaded from the HP website, because I wasn't able to scan from it, but at least I still could print. Since then, even if the printer appears as ready, Windows doesn't even send documents to the spooler: the printer icon appears on the taskbar but it just says "0 document(s) pending".

    Additional informations: I already uninstalled the downloaded new driver and installed back the previous working one and it's not a spooler problem since I can print if I directly connect the printer through the laptop USB.

    Thanks a lot
      My ComputerSystem Spec

  2.    28 Aug 2015 #2

    Did you try rebooting the router? I've seen routers get confused and forget that they have a printer attached too might try it.
      My ComputerSystem Spec

  3. Posts : 5
    Windwows 10 Pro 64-bit
    Thread Starter
       29 Aug 2015 #3

    Thanks for the answer but I already tried it.

    The worst part is that I can even see the printer from the network folder as in the screenshot ( but even if I click on it, add it as a printer and install the driver from the printer's CD-ROM, when I'll try to print the test page or anything else, there's no response.

    I'm going crazy over this thing, I really can't manage to figure it out ahahah.
    Please help
      My ComputerSystem Spec

  4. Posts : 5
    Windwows 10 Pro 64-bit
    Thread Starter
       29 Aug 2015 #4

    Another funny thing: when I try to add the printer from the printer manager, and I enter the IP address, the laptop tries to contact the printer (, the printer sucks a paper sheet to make you think it's going to work, prints the first line (, but then the sheet stops halfway and this error message pops up: (
      My ComputerSystem Spec


Related Threads
Solved Win+X doesn't work anymore in General Support
pressing Win+X doesn't show the power user menu for me anymore. right clicking Start button doesn't work either, but when I do it, the mouse cursor jumps several pixels up and to the right. I did sfc /scannow and it didn't fix the issue. does...
Clean installed Windows 10 Pro. Installed ProjectCars and the updates to it. The game will start, but when selecting a racetrack to begin race or qual or testing, it crashes to desktop without any error. Have tried to update everything, windows...
Tried to turn on Hey Cortana, it still doesn't work. i messed with the privacy settings, but i may have missed something. please let me know.... common.... thanks!
Key doesn't work in Windows Updates and Activation
Trying to upg from 8.1 w wmp and used produkey to get outlook and system reg key and when I when install asks for reg key, neither work. I downloaded from ms win 10 download site. the install window doesn't give ANY other options except QUIT. ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:27.
Find Us