Windows 10: USB3 ports on Logilink PCI ExpressCard are not work Solved

  1.    27 Aug 2015 #1

    USB3 ports on Logilink PCI ExpressCard are not work


    Okay, I upgraded from Windows 7 Pro 64Bit to windows 10 Pro 64bit.

    Everything ran smooth and fine.
    But my USB3 ports mounted on a Logilink product (Art. PC0058) PCI ExpressCard 2xUSB3 work only as power supply.
    The error indicated by device manager point to USB Root hub (xHCI)
    The screenshots are attached.
    Can somebody help me ?

    Regards Adrian
    USB3 ports on Logilink PCI ExpressCard are not work Attached Files
      My ComputerSystem Spec

  2.    27 Aug 2015 #2

    The solution are to download and install the new VIA_XHCI_Driver_V4.70C_AP from Viasite.
      My ComputerSystem Spec

  3.    01 Nov 2015 #3

    Anyone know a US source for this product?
      My ComputerSystem Spec

  4.    01 Nov 2015 #4

    Anyone know a US source for this product?
    Or an equivalent product sourced from US. Primary need is a PCI e card with a 19 pin USB 3.0 connector. Have a HootToo pci e card but it doesn't have w10 drivers.
      My ComputerSystem Spec

  5.    04 Jan 2016 #5

    deleted


    delete below, wrong thread
    HooToo said the drivers were from Microsoft. After a few weeks, the USB ports started working. right now my drivers are Microsoft 10/29/15 10.0.10586.0.
    Last edited by brucewol; 04 Jan 2016 at 17:44. Reason: posted to wrong thread
      My ComputerSystem Spec


 

Related Threads
Solved Update disabled USB Ports. in Drivers and Hardware
Windows 10 USB 3.0 Ports got Disabled after a recent failed update try. KB3081438 which downloads, but fails to install HERE] The ports are powered since i can connect my mobile to the 'disabled' ports and yet charge the device but cannot do...
slow transfer using USB3 in Drivers and Hardware
Hi as the title says I cant seem to get what used to be hi speed data transfers on my 2 win 10 devices, a custom build PC and a surface pro 3. Prior to the update I would see a transfer speed of at least 100-148mb now I'm lucky to see 60mb....
I used the upgrade tool to install w10x64. Installation went fine, I can use my computer and all. Problem is that both of my LAN ports don't work. I get the usual red icon in the taskbar that shows no internet. I went into networking and it doesn't...
I've just fitted A Silverstone pcie board which has two internal 19 pin usb 3 outlets. it works fine with W7 and 8.1 but sadly the drivers won't work with 10 (all 64 bit). W7 required the driver cd but 8.1 found the drivers automatically. No doubt...
Hi there WD passport (small self powered 2 TB USB3 drive) has appalling performance compared with an OLD laptop HDD that I connect via a USB2==>SATA cable to USB2 port. Same file (2GB mp4 video) copied to a directory on the SSD. External...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:15.
Find Us