Windows 10: Old Dell 9400/E1705 Workhorse ATI x1400 Driver for Windows 10 Solved

Page 2 of 2 FirstFirst 12
  1.    13 Jan 2016 #11

    spapakons said: View Post
    No problem! There is an official Intel Window Vista driver for Intel 945G graphics. Run the setup in Windows Vista compatibility mode with Administrator rights. If this doesn't work, open it with WinRAR to extract the files in a folder and install the driver manually from Device Manager.

    Link for the 32-bit driver version...

    Thanks again for the fast reply and the links! :-). I just tried running the Intel utility, and unfortunately after it unpackages itself it gives an error and says "This operating system is not supported. Setup will exit." I am running the latest Win10 32-bit.

    Any other suggestions?
      My ComputerSystem Spec


  2. Posts : 2,231
    Windows 10 Pro 64-bit 1607 (AE build 14393.1198)
       14 Jan 2016 #12

    Download the 32-bit driver. If you don't already have WinRAR, you can download and install it from WinRAR archiver, a powerful tool to process RAR and ZIP files. Right click on the driver and select Open with WinRAR, then extract the files to a folder. Go at Device Manager (search for device to see link), expand Display Adapters and right-click on the graphics card. Select Update Driver, but do not let Windows automatically search for the driver. Instead select the last option and then again the last option. You should see a "Have disk" button, click on that and browse to the folder you extracted the files. If it gives you a list, select the first Intel 945G model from the list and continue. Ignore any warning that Windows cannot verify compatibility and proceed. Restart the computer and you should be OK.
      My ComputerSystem Spec

  3.    15 Jan 2016 #13

    Thank you very much for the reply with details. I tried this last night, when downloading the trial version of WINRAR.

    Once I referred to the driver my screens went black and after waiting more than 10 mins and even trying to restart using ctrl alt delete to restart blind,I ended up using the power button. Upon starting Windows the icons were all big and out of proportion so after a quick test of seeing the problem persisted, I restarted again. This time icons were all at the correct display resolution. I fired up chatting again and it seemed to be able too multitask at a reasonable speed. Then later my wife got on and it was back to its old problems of jumpy video chatting and not being able to multitask even to do a basic web search.

    Do you have any other suggestions or do you think I should just throw in the rag and downgrade back to win 8?

    Thanks! Lawrence
      My ComputerSystem Spec


  4. Posts : 2,231
    Windows 10 Pro 64-bit 1607 (AE build 14393.1198)
       16 Jan 2016 #14

    Is that possible that a Windows Update restored the old drivers? Make sure you have the proper drivers installed and then use the show/hide tool to hide any driver update so it won't install again.
      My ComputerSystem Spec

  5.    18 Sep 2016 #15

    x1400 on windows 10 - on mouseover things vanish!


    I Have an Inspiron 6400 with a wxga screen 1680x1050 running windows 10 32 bit. I have the radeon x1400 graphics and have 'sucessfully ' installed the vista 32 bit drivers

    I have the correct resolution, but on mouseover of various things on screen, they vanish - i.e. start menu, tiles in settings pane. Sometimes they come back sometimes not......

    Any ideas please?

    thanks! G
      My ComputerSystem Spec


  6. Posts : 2,231
    Windows 10 Pro 64-bit 1607 (AE build 14393.1198)
       18 Sep 2016 #16

    I guess these glitches are because of the different DirectX 9 implementation of the Vista drivers. I also have a similar glitch with the Marine Aquarium screensaver in any computer with NVidia Geforce FX 5200 (or similar) graphics card using the NVidia Forceware 96.85 driver (only one available for FX series). When the fishes move they leave a visible trail and eventually the screen becomes a mess. The same screensaver has no problem running in another computer using different drivers. Unless you can find different drivers (newer or older) there is no way to fix it. I hope it is not that bad.
      My ComputerSystem Spec

  7.    18 Sep 2016 #17

    Thanks so much for the quick reply. I'm afraid that the way it's behaving now means that it will be a deal breaker..... I could live with a little mis-behaving, but this degree of screen erasing is too much

    Any other ideas please?
      My ComputerSystem Spec


  8. Posts : 2,231
    Windows 10 Pro 64-bit 1607 (AE build 14393.1198)
       19 Sep 2016 #18

    In worst case you could replace the ATI driver with Microsoft Basic Display Adapter (software only, no hardware acceleration). Your problems should disappear, but the performance will be slow due to no hardware acceleration at all. Otherwise go back to Windows 7.
      My ComputerSystem Spec

  9.    19 Sep 2016 #19

    ATi Radeon X1400M isn't supported by Windows 10.
      My ComputerSystem Spec


  10. Posts : 2,231
    Windows 10 Pro 64-bit 1607 (AE build 14393.1198)
       19 Sep 2016 #20

    RoasterMen said: View Post
    ATi Radeon X1400M isn't supported by Windows 10.
    Yes, as far as I remember the only WDDM driver is a Vista driver (WDDM 1.0) but it should work fine if installed in Vista compatibility mode or manually from the control panel. To avoid the graphic glitches you could try Microsoft Basic Display Adapter, but without any hardware acceleration your computer will be very slow... Your alternative is to format and install Windows 7 32-bit where the Vista driver might work better or you could also try the Windows XP driver (XPDM).
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
guys i keep getting bsod when i plug this dell monitor usb cable (SP2208WFP) the usb cable is for builtin webcam+mic and also 4 usb port i tried download&install monitor webcam driver, that it said compatible for win7/8 but no work, it install...
Hello : I have my realtek driver tweaked in windows 7 , I have it set in the registry to have 2 outputs , instead of one - will the new win 10 driver be able to be adjusted ... Thanks
After the upgrade to Win 10 Pro from Win 7 Pro, my Dell Backup and Recovery Manager gives me an error message basically saying it does not recognize my Dell . Dell support suggested I contact Microsoft support as this new problem is due to the Win...
Dell E5430 Video Driver 0X80248007 in Drivers and Hardware
Afternoon all, I upgraded and ran the install over night on top of a very dirty Windows 8.1, followed the tutorial for the clean installation- ran through all ok, reinstalled most of my software and have had no problems. I've since ran Windows...
Upgraded my Dell Inspiron 15R laptop from 10041 to 10049. Went well though it took a long, long, time. Anyway, I have drivers for all devices except these two and can't actually figure out what they are. 16384 16383 16382
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:10.
Find Us