Windows 10: Kde partition manager, resized and move C: raw now. Solved

  1. Posts : 38
    Windows 10 familly x64
       25 Aug 2015 #1

    Kde partition manager, resized and move C: raw now.


    I have a samsung f3 of 500gb (465Gio)
    Windows 10 64 family
    I tryed to use kde partition manager to resize and move C: (ntfs partition 1 gpt)

    I did a move to the right it was about 328.98 Mb in size. and kept 0 at C partition end.

    Problem is i stopped process at 20%, now my C partition is raw.

    Check disk is not working on it.
    It does say something about first mft sector (on efi gpt disk ?) damaged.
    Tryed second sector for ntfs if i remember but couldn't recover, damaged or something.

    I have a kubuntu 15.10 live dvd 64bit, and used command: apt-get install testdisk.
    Next i runed testdisk in kjonsole with sudo rights.

    I would like an advice about what to do.
    Before i closed kde partition, i saw a unallocated 328.98Mb space, and normal Ntfs C:

    I launched it again, and it was Raw on C.

    I will try to n ot touch the hard disk , if someone has a good advice, on how to use test disk, i can't do a screenshot of my partition table.

    Thanks you very much.

    ps i tryed to put efi then msr at start of hdd, and Recovery win Re at end of the system partition.

    I didn't touched those partition yet, but i know i could done a copy of each to put them at start of the 328.98mb unnalocated space.

    Oh i forgot a thing i sayd i didn't touch partitions, but i did it even if i known it should lead me to errors.
    I tryed to convert in win re mode with fs tool my C: to ntfs (automatic windows repair trigered from win re partition) but i wanted to try.

    Thank you very much in advance :)
    Last edited by Elbern; 25 Aug 2015 at 15:13. Reason: more step about chkdsk
      My ComputerSystem Spec

  2. Posts : 38
    Windows 10 familly x64
    Thread Starter
       25 Aug 2015 #2

    In dolphin i try to check folder of this disk, i have:
    failed to open $MFT/$BITMAP: no such file or directory
    Failed to load $MFT no such file or directory

    In test disk i maybe did an error.
    I loaded the disk with efi gpt, next ntfs, pressed advanced recover boot, and choosed the main mft because the mirror and main was not matching.

    Maybe it was the mirror version i had to select.

    Anyway now the c: partition is set as unformated if checking on kde disk manager.

    I tryed ntFsdisk it find a ntfs partition, but ask me to go to windows and run chkdsk to fix the ntfs .

    But even if i had important data on the hard drive, it's a good experience for me, i keep learning my way :)

    And one thing:

    Never stop a partition move to a way or another.
    For me extand or grow a partition with windows 10 disk manager is totally safe.
    Last edited by Elbern; 25 Aug 2015 at 15:08. Reason: More steps i tryed
      My ComputerSystem Spec

  3. Posts : 38
    Windows 10 familly x64
    Thread Starter
       25 Aug 2015 #3

    I just did a testdisk, advanced mod, rebuild mft, and repair boot, it ended well, and about boot, mirror is ok.

    I will still have to find a way to repair the unknown 464.67 Gib that was ntfs C: before.
      My ComputerSystem Spec

  4. Posts : 38
    Windows 10 familly x64
    Thread Starter
       25 Aug 2015 #4

    Just after i installed gpart and gparted in a live virtual disk, i could fix something but not the ntfs.

    I just went back to windows 10 repair disk, and command prompt work again.

    Before win 10 was complaining windows 10 couldn't be found, but now i can access win re from the repair section.

    If i do a repair, it will boot, repair, bot again, loop...

    But with a command prompt i was able to run a command and check something:

    convert C: /fs:NTFS

    The result is: Drive C: is already Ntfs.

    in diskart there is a * meaning it's a gpt volume.

    Chkdsk can't repair it because master table is not readable.

    I will try to find other options on the web, but i think the move/ resize that stoped at 76% corrupted everything.

    I went back to testdisk, and seletec gpt, then ntfs.

    I can only select un recover partition, but even with a detail scan, all of them contain no files.

    Sorry for long post, but i keep posting as i am trying to fix it :)
      My ComputerSystem Spec

  5. Posts : 38
    Windows 10 familly x64
    Thread Starter
       26 Aug 2015 #5

    Ok, i prefered to zero the disk with dd in linux, just to be sure, and i'm currently installing windows.

    A thing is win 10 is setting a efi system partition of 99Mb while on win 7 it was set to 128mb.
    I don't understand it.

    And usually on a 4k per sector hard drive, it require a 260Mb efi .

    Should i let win 10 doing that ?

    ANyway i mark this topic as resolved because i can't come back to the old partition table.
      My ComputerSystem Spec

  6.    26 Aug 2015 #6

    Your drive is not Native 4k, it is 512e. So no The EFI partition Windows 10 setup is correct.

    There are no consumer driver out that are 4k native at this time. Unless you bought an expensive enterprise server drive.

    It is probably good advice, when working with partitioning tools. Do not cancel the operation.
      My ComputerSystem Spec


Related Threads
I am trying to make space on an empty partition as a temp backup before I install a fresh copy of 8.1 to upgrade to 10. I'm using Mini Tools Partition Wizard 9 Free Edition. What I have looking at the partitions are, a C partition (700 gigs...
I have tried out a few different monitors recently, but I just settled on the one I want to use. All was going well but after it wakes from "sleeping", the windows are being resized and moved. Perhaps there is some issue with drivers from the other...
Hi TenForums! I am loving Windows 10 and I want to remove Windows XP from my dual-boot configuration (and remove the whole dual-boot thing completely) but it also acts as the system partition, so I guess it's not as straight-forward as I had hoped....
System: Intel NUC 54250WYKH Monitor: Acer T232HL (1920x1080) OS: Windows 10 Pro (clean install) When my NUC wakes from sleep mode, existing windows are sized and positioned as if the display resolution had changed to a much lower value (e.g....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:25.
Find Us