Windows 10: W10 Didn't install my printers and can't even see them

Page 1 of 2 12 LastLast
  1.    22 Aug 2015 #1

    W10 Didn't install my printers and can't even see them


    I have two common home printers, Lexmark inkjet and HP laserjet on a home network, and when I upgraded from W7 to W10 they were not installed. The W10 network scan brought up nothing, even though both printers were switched on and 'awake'. Even with the laptop placed right next to the printers, still nothing! So I now have no way of printing and no way of installing a printer! Thanks MSoft. Can anyone help at all?


    PS: I also have blurry fonts, and I see from this forum and the web in general that that's a whole separate world of grief!
      My ComputerSystem Spec


  2. Posts : 3,431
    EL Capitan
       22 Aug 2015 #2

    It does help to know the model numbers of both printers and how they are connected. Also have you installed the manufacturer software, and is the connection set for "Private", when you open the Network & Sharing Center from the Control Panel?

    Also what has the blurry fonts? And what is the full model number of your Toshiba Satellite, not just the model group info. There are 10 different versions of that Group for that laptop.
      My ComputerSystem Spec

  3.    22 Aug 2015 #3

    Hi, many thanks for replying, and sorry for not providing enough info. I've updated my spec.

    The Toshiba laptop is a Satellite Pro L670-18F. Part No. PSK3FE-01L00QEN

    The printers are:
    Printer 1 - HP LaserJet 100 Color MFP M175nw
    Printer 2 - Lexmark Inkjet Prestige Pro 805

    The blurry fonts are wherever there is normal text, e.g. Edge, Office, everywhere really. There is a thread on this and some kind of workaround is discussed, but it doesn't seem to work for everyone. It's nothing to do with display drivers; it's a MSoft move to make text appear best on mobile devices (and to hell with the rest of us with laptops and desktops). I would hope the furore about it on the Web will make MSoft implement a fix/option in a forthcoming W10 release.
      My ComputerSystem Spec

  4.    22 Aug 2015 #4

    Did you try going to Devices and Printers > Add a Printer ? Printers should be turned on and internet active.
      My ComputerSystem Spec

  5.    22 Aug 2015 #5

    CountMike said: View Post
    Did you try going to Devices and Printers > Add a Printer ? Printers should be turned on and internet active.
    Yes, and no devices found.
      My ComputerSystem Spec

  6.    22 Aug 2015 #6

    I have just found out that w10 fails to detect and install any networked printers (at least for me). w8.1 just did it fine. You must install them manually.
      My ComputerSystem Spec

  7.    22 Aug 2015 #7

    eLPuSHeR said: View Post
    I have just found out that w10 fails to detect and install any networked printers (at least for me). w8.1 just did it fine. You must install them manually.
    I'd hesitate to generalize like that, but I have a network printer connected by Ethernet to the router.

    I had to install it manually. I used the Win 8.1 installer package.
      My ComputerSystem Spec

  8.    22 Aug 2015 #8

    Is there a way I can install printers if W10 says it can't find any devices on my network?
      My ComputerSystem Spec

  9.    22 Aug 2015 #9

    Perhaps the Manufacturers Installation software will find your printer(s). That is how it is with my Canon printer.
    You may need to visit your manufacturers web site and download the most current install software.
      My ComputerSystem Spec

  10.    23 Aug 2015 #10

    SkylineW10 said: View Post
    Is there a way I can install printers if W10 says it can't find any devices on my network?
    I had exactly the same problem with my networked HP inkjet printer: Win8.1 found and installed it with no problem, Win10 couldn't even see it!

    What worked for me was downloading the latest Full Software suite package from HP and running that. It found the printer, installed the drivers, and installed the supporting HP software.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I didn't save my IE bookmarks :( in Browsers and Email
So I installed Windows 10. I didn't even think to save my bookmarks before I did. Is there anyway to recover them? Thanks
Hi, I've run into a following problem with Win 10 installation. A month ago I've bought an inexpensive Atom 3735F + 1 GB RAM + 16GM storage Win 8.1 tablet. I've first tried to install Win10 using "forced" windows update option (wuauclt.exe...
Hope I didn't 'Brick' my PC! in General Support
I think I've DONE it this time!:o Don't really want to discuss it but I might need some help! :sick:
Solved Build 10049 didn't install in Installation and Upgrade
Hi there. I am dualbooting Windows 7 and Windows 10 TP on a laptop. I downloaded 10049 overnight with Windows Update. When I got back to the laptop this morning, it had a brief error message saying, "Cannot install 10049 on a virtual drive". That's...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:02.
Find Us