Unknown USB Device (Set Address Failed)

  1. Posts : 104
    Windows 10

    Unknown USB Device (Set Address Failed)

    Windows version 21H1 19043-985 Windows 10 Pro 64bit

    I am running a WD RED 10GB RAID 1 mirror on an unmanaged external enclosure. Enclosure specs are here HUR5-SU31C , 2 Bay USB 3.1 Type-C Specs - Mediasonic Forum

    I've had this enclosure connected to a Windows 10 machines for several months now with no hiccups. It acts as my Plex library. A couple days ago after I performed a Windows update, the drive started to disconnect when attempting to write data to it. I checked out device manager and it showed Unknown USB Device (Set Address Failed). I can toggle the power on the enclosure but as soon as I try to write something to it or even delete something explorer freezes and disconnects the enclosure. So I moved it over to another machine, running same windows version and it works fine. I can write and delete to it and no problems, no freezes, no disconnects.

    While the drive is in the Unknown USB Device (Set Address Failed) state, I uninstall the driver, rescanned hardware and it pops up again as Unknown USB Device (Set Address Failed). The only way I can get it to recognize it to power cycle the enclosure but the problem occurs again. If I reboot the computer sometimes the drive will be recognized and sometimes it won't.

    Since the enclosure works in another computer I assume there is something wrong with the specific machine. I have 2 other external drives connected to it, an external WD 12GB and a smaller 4GB 3rd party external enclosure, all working fine. I've tried switching usb ports but same result. I don't believe the cable is bad because it works fine on another machine with the same usb cable.

    Any suggestions?

    Unknown USB Device (Set Address Failed)-untitled1.png

    - - - Updated - - -

    I am going to try this and will report back if it does not fix it.

    USB drive or flash problems? How to cleanup and remove old USB storage drivers | TechSpot Forums
      My Computer

  2. Megahertz's Avatar
    Posts : 3,074
    Windows 7 HP 64 - Windows 10 Pro - Lubuntu

    Open a CMD window as administrator and type:
    sfc /scannow
    If it finds any corrupted file (fixed or not), restart and run it again.

    Then run
    Dism /Online /Cleanup-Image /ScanHealth


    Dism /Online /Cleanup-Image /RestoreHealth
      My Computers

  3. jimbo45's Avatar
    Posts : 10,944
    Windows / Linux : Arch Linux

    Hi there
    Another solution


    If you have the previous version of Windows on an HDD / SSD hdd / iso or whatever available then do update driver and use scan from computer to search for driver --> point to the driverstore on the previous version of windows.

      My Computer

  4. Posts : 104
    Windows 10
    Thread Starter

    - - - Updated - - -

    I am going to try this and will report back if it does not fix it.

    USB drive or flash problems? How to cleanup and remove old USB storage drivers | TechSpot Forums
    So far this method has fixed the issue. I've been copying data on the drive all night long and it's holding up. Thanks for the responses!
      My Computer

  5. tony359's Avatar
    Posts : 90
    Windows 10 Pro

    Hello there

    I have the same problem with a SATA docking station. It's USB3. It gives the same error message of the OP. If I plug the dock on a different set of ports (USB2 or even a different set of USB3 ports) it works. It won't work on a specific port. It was working yesterday, not working today. I did not do anything.

    On the same set of ports I have a USB 3.0 hub where I have my keyboard and mouse connected. That works in either ports. If I plug the dock into the hub - which is going to the same USB 3 port where the dock does NOT work directly... then it works. The hub is NOT powered. I am confused :)

    I tried the TechSpot method but it did not improve the situation.

    Any ideas?
      My Computer

  6. tony359's Avatar
    Posts : 90
    Windows 10 Pro


    I happened to have another installation of Windows on my system and it shows the same issue. It's a fresh install of Windows Server so I doubt this is a driver issue.

    I tried downgrading to the previous AMD drivers (it's a B550 chipset) as I noticed AMD recently moved from version 2 to version 3. No change.

    Other USB3 devices work on the affected port.

    The USB3 dock works on another (intel) USB3 system.

    It was working before. I'm not sure what happened but as now I cannot really blame the motherboard - as other USB devices seem to be working fine. Yet, I cannot even blame the USB3 docking station as it works on another USB3 system.

    I'm returning the dock (it's a cheapo one from Ebay) and I'll get a decent one I guess.

    Any suggestions is still appreciated though! :)
      My Computer

  7. Berton's Avatar
    Posts : 11,737
    Win10 Pro Versions 2004 and 2009/20H2, Win10 Pro IP_Dev, Win10 Home 1909

    The only issue I've seen with my USB 3 Dual-Drive Dock with 3 USB ports on the front is with one being the charging port, the other 2 ports work fine with Thumb drives.
    Unknown USB Device (Set Address Failed)-image.png
      My Computers

  8. tony359's Avatar
    Posts : 90
    Windows 10 Pro

    Unfortunately the port on question is the motherboard one. My dock has the same - the charging ports are orange in colour.

    Other USB3 devices work fine on that same port.

    I could consider an incompatibility but it was working last week…
      My Computer

  9. Stigg's Avatar
    Posts : 481
    Windows 10 Pro

    Did anyone find a fix for this?
    It appeared for me today.

    I have tried uninstalling it, but it appears next boot.
    I have cleared non-present devices.
      My Computer

  10. tony359's Avatar
    Posts : 90
    Windows 10 Pro

    Good to see it’s not just me then. I could not find a solution but I ‘blame’ the device. It showed up the same error on a different PC even though it then cleared up after unplugging and replugging.
    It could be a combination of HW and SW?
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:14.
Find Us

Windows 10 Forums