20H2 removed Intel drivers- unable to force install Intel driver

Page 1 of 3 123 LastLast

  1. Posts : 111
    Windows 10 Pro 21H1

    20H2 removed Intel drivers- unable to force install Intel driver

    Optiplex 9020 i7-4790 Q87 chipset. Originally Windows 8 Pro but had been upgraded to Windows 10. I was running Win10 Pro 2004 and everything was working. My chipset, USB 3.0 drivers, and Sata driver were all Intel. I used Double Driver and backed up all my drivers. I then updated to 20H2 . On first boot Windows replaced all Intel's drivers with its own drivers. There are way less drivers than what DoubleDriver backed up. I used Doubledriver to restore all my backed up drivers.The only one of my backed up drivers that I could get to over-ride the Microsoft driver was for Sata/raid. None of the chipset or USB drivers would restore using Doubledriver.

    The PC has USB 3.0 ports in front and in back. It also has USB 2.0 ports in front and back. Using the Microsoft 3.0 controller driver, my 3.0 ports now run barely over 2.0 speed. I then tried to force install the Intel drivers I had backed up for the 3.0 controller and chipset but Windows would not use them. Got best driver already installed.

    So I downloaded the 3.0 Extensible controller driver and my chipset driver from Intel, , (these were the drivers I was using in 2004) and used intel's .exe file but Windows says 'best drivers for your device are already installed'. I tried to force the drivers, got same error. I disabled driver signature enforcement and still couldn't override the Microsoft drivers. I tried to install them in compatibility mode for Windows 8. Wouldn't install.

    I then uninstalled the USB 3.0 Host Controller. When I did it killed all my usb ports including the 2.0 ones both front and back. This should NOT have happened. How can I force Intel drivers to install to see if I can get my 3.0 ports to work correctly? And how can the the 3.0 controller driver control the 2.0 ports as well? 2.0 ports are independent of the 3.0 ports.

    I want to use Intel drivers.

    The best driver for my device can't be installed if everything is working worse than when I used all the the Intel drivers.
    It's like we are at Microsoft's mercy.This computer is not so old that the drivers should have to change when Windows updates its version.
    Here's a copy of device manager, and the error I get. Also usbtreeview that shows I have a usb 3.0 device connected at superspeed. Can someone tell me how the heck do I over-ride Microsoft drivers.

    Attachment 330681
    Attachment 330683

    20H2 removed Intel drivers- unable to force install Intel driver-usbtreeview.png
      My Computer

  2. Posts : 2,217
    Windows 11 Pro 64bit

    Can you right click on the USB, choose update drivers>manually install driver then choose I have disc, this will allow you to find the Intel driver/s & install those. Or are you already doing this?
      My Computer

  3. Posts : 111
    Windows 10 Pro 21H1
    Thread Starter

    Yes, I tried that. Many times. That's what I mean when I said 'force the drivers".

    - - - Updated - - -

    Yes, I tried that. Many times. That's what I mean when I said 'force the drivers". I notice all my attachments are not showing in my original post so here are the ones for device manager and the error again. And I've also tried 'search windows update'. It finds no new drivers.
    20H2 removed Intel drivers- unable to force install Intel driver-usb-3.0-device-manager.png

    20H2 removed Intel drivers- unable to force install Intel driver-error.png
      My Computer

  4. Posts : 2,217
    Windows 11 Pro 64bit

    You might have to reinstall the driver this way:Right click device.Choose update driver.Choose ‘browse my computer for drivers’.Choose ‘let me pick from a list of available drivers on my computer’.Choose the compatible hardware from the list, then choose next.This will then reinstall the driver.
    Or check the Intel website.
      My Computer

  5. Posts : 920
    Windows 10 Pro

    I'm wondering how you are measuring your USB performance, I have 20H2 using a two - three year old Intel B360, i5 (8th gen) system, the original Intel USB drivers have been changed to Microsoft ones (interestingly the same for the USB host on the RTX card, previously an Nvidia driver).
    However the speed of my ports has not changed, I regularly copy 16GB image files to an external USB3.0 (Seagate 3TB Disk), using 1909 - 2004 with Intel drivers I got 184MB/s per file, with the current 20H2 and Microsoft drivers with the latest chipset .inf from Intel, I get 184MB/s per file, so absolutely no change. I have tested just now with 2 external USB3 hard drives and a handful of Kingston and Integral flash drives (USB2 and USB3) and all perform the same as before.
    I am not saying you are mistaken in your assessment of performance but if you have issues it doesn't seem to be the drivers being supplied by Microsoft that are at fault here, at least not based on my system.

    20H2 removed Intel drivers- unable to force install Intel driver-one.png

    20H2 removed Intel drivers- unable to force install Intel driver-two.jpg
      My Computer

  6. Posts : 111
    Windows 10 Pro 21H1
    Thread Starter

    Pejole2165, I ran my tests using both Crystal Disk Mark as well as USBFlashBench but Crystal Disk Mark is what I usually use..
    I found a screenshot I had saved from back when I was using the Intel drivers. Then my 3.0 external hard drive ran at 169MB/s
    sequential read and 167 MB/s sequential write.
    Now it runs 91 MB/s read 17 MB/s write. The same drive plugged into 2.0 port tests 41 MB/s read 41 MB/s write.

    Bastet/Virginia, I just tried that method and it said the drivers installed. I thought, thank god, finally. I rebooted expecting to see the USB 3.0 Extensible Host Controller to be Intel. But nope, still running the Microsoft driver. At least, with this method I didn't see the 'best driver already installed message.
      My Computer

  7. Posts : 872
    11 Home

    Have you also tried:
    Device Manager | View | Show hidden devices | Universal Serial Bus Controllers ➜ remove all the ghosted items that appear in there?
      My Computers

  8. Posts : 920
    Windows 10 Pro

    Ok, that is a significant drop, just thought I would give you another similar setup to compare.
    Is that the only drive suffering issues or are all USB3/ 2 devices having problems?
    If that is the only device with issues, it is possible the disk or the external controller interface are failing, have you checked the SMART info with CrysalDisk Info?
    As a side note, the only USB3 host controller software I could find on Intel's site for your system is version :, this is Win7 32bit, Win7 64bit and server 2008 R2 only. Is this the version you are trying to use?
    I believe that starting last April Intel said they would distribute certain drivers through Microsoft going forwards, the RST app and drivers are now in the MS store. If these Microsoft USB drivers are actually provided by Intel for inclusion in the Windows distribution, then they are the most up to date versions.
    Last edited by Pejole2165; 02 May 2021 at 05:24.
      My Computer

  9. Posts : 2,217
    Windows 11 Pro 64bit

    Check under Windows updates>Optional updates for any drivers.
      My Computer

  10. Posts : 920
    Windows 10 Pro

    I have been searching for the Intel USB3.0 Extensible Host Drivers and have turned up these snippets.
    20H2 removed Intel drivers- unable to force install Intel driver-nousb_intel01.jpg
    20H2 removed Intel drivers- unable to force install Intel driver-nousb_intel02.png
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 19:22.
Find Us

Windows 10 Forums