Volume won't mount unless HFS+ is running but it's NOT HFS+


  1. Posts : 40
    Win 10
       #1

    Volume won't mount unless HFS+ is running but it's NOT HFS+


    This is a weird issue I can't seem to resolve. Here we go:

    I have a PC running Win10. Attached is a 4-bay USB3 enclosure with all bays occupied. When I power up the enclosure, only three of the four drives actually mount. The only way I've been able to get that fourth drive to appear is by running HFS+ for Windows (and then it appears). At that point, Windows says that drive is NTFS and the HFS+ app doesn't see the drive as anything it can handle (which means it doesn't see it as HFS+). The drives are M, N O and P.

    I've attached a screenshot which highlights the troublesome disk (M). Of the four, it's the only one formatted as GUID with NTFS; the other three are MBR/NTFS. If I plug this enclosure into my Mac, Drive M will not mount. Drives N, O and P were formatted some time ago and I guess I used MBP at that time but specified NTFS so I wouldn't have the 4GB file size limitation.

    My Drive C is GUID/NTFS (as it came from Lenovo). Drive F apparently was formatted at Lenovo (or maybe by the mfr) as NTFS but, because I don't see the EFI partition, I'm assuming this drive is MBR.

    Drive 2 (Disk E) I formatted as GUID/NTFS when I first got it and it worked in my HP (and continues to do so now that I've simply moved it into the Lenovo).

    I am making an assumption that GUID is what creates the EFI partition (Disks 0, 1 and 3). Further, I've been operating under the assumption that GUID is what I should be using.

    I have one additional HD (not shown in the screenshot) that was formatted GUID with NTFS (by HP - the original HD in an old Envy desktop). I formatted that drive in Windows ("fast" in Explorer) yet I still see a 20GB HP recovery partition. This drive has no trouble mounting on my Mac or PC in a USB3 enclosure (without the HFS+ for Windows software loaded)

    I will admit I have been a Mac person for many years and only in the last few years have I moved over to Windows so I know that I don't know but would love to learn the proper way of handling my disks (both internal and external).

    I don't think Drive M is "bad" because, as soon as the HFS+ for Windows software loads, the disk mounts (while my Mac won't mount it at all - although it does see the physical disk in the Disk Utility software (but can't repair it - probably because the Mac doesn't have the ability to write to NTFS). I will note that I do have an NTFS driver that does permit writing but, while it does permit writing to Disks N, O and P, Disk M will not appear regardless.

    So, there you have it and I apologize for the rambling explanation. Advice gratefully accepted.

    Thank you,
    Barry
    Attached Thumbnails Attached Thumbnails Volume won't mount unless HFS+ is running but it's NOT HFS+-disk-management-screenshot.png  
      My Computers


  2. Posts : 12,417
    Win10 Version 21H2 Pro and Home, Win11 Pro
       #2

    I may be a bit wrong but what I see is Disk 3 is/was from the same or a different computer originally with a running version of Windows and only the partition shown as Drive M was formatted. If it were mine I'd have first wiped the drive completely then partitioned and formatted the full drive as a single partition for storage.

    My MacBook Pro from mid-2010 with Mac OS X Mavericks decided to die just as macOS came out [drive controller crapped out] but I had a third-party program on it that would allow read and write of NTFS, can't recall the name. The drive in it was formatted as HFS+ but I used Linux to recover files I needed, wiped it and formatted as NTFS, still runs in a portable case when needed.
      My Computers


  3. Posts : 40
    Win 10
    Thread Starter
       #3

    Berton,

    I think you're correct about "Disk 3" as it was originally the boot drive for my HP. What I think happened is that I used the "Format..." command from the contextual menu to erase that disk (after I had cloned that drive to a new SSD in the old HP). I had left that drive in the HP and reformatted it so I could use it as a data drive. It was working properly as such until I removed it from the HP and placed it into the USB enclosure. That's when the "have to use HFS+ for Windows" issue started. (As I'd been a Mac user, I had some Mac-formatted disks I still needed to access via USB.) What I'm learning is that using that "Format..." command (from that contextual menu) erases the volume and provides the choice of file system (FAT, exFat, and NTFS if I remember correctly) but leaves the underlying partitioning of the physical disk as it exists. So that accounts for the GUID partitions remaining. But, as GUID is not HFS+, why did the HFS+ software for Windows permit that volume to mount?? As the King of Siam said, "It is a puzzlement."

    I will properly format another disk as GUID—using the diskpart commands—and copy over the data from the "M" volume, then replace that disk in the USB enclosure. If it mounts properly on both my Lenovo and my Mac, then I'll know I've got this conundrum solved.

    I found another example of how the "Format..." contextual menu command doesn't work (as I expected, any way). I needed a flash drive for a stand-alone photo scanner so I grabbed one from a box and used the "Format..." contextual menu command. It appeared to format correctly as FAT and, in fact, was seen by the photo scanner. However, when I initiated a scan, a progress percentage ("0%") appeared on the scanner's tiny screen and never actually progressed beyond that 0%. I thought the scanner was broken. Then I remembered that the flash drive had previously been used as a Windows Installer boot drive so the partitioning scheme was GUID. The scanner must not have liked that. So I brought the flash drive over to my Mac and used Disk Utility to erase the physical drive (and not just the volume). This gave me the choice of partitioning so I chose MBR; I chose DOS (FAT) for the volume format. When I reinserted the flash drive into the scanner, everything now worked.

    So it appears I only have myself to blame as I was making the same mistake (on Windows) that I used to chide Mac newbies about: I was not registering the difference between volumes and partitions (and that Windows-and macOS-provides no warnings about such a conflation). Frankly, the Disk Management app does little to help this issue (as Apple's Disk Utility app is almost as obtuse but in a "Mac-friendly" sort of way).

    I'll do the "diskpart" partitioning and formatting followed by the copying of the data and then put that new drive into the USB enclosure. If that resolves the issue, I'll come back here and mark the thread solved.

    - - - Updated - - -

    So this situation became so complex that I'm making some major changes.

    The 4-bay enclosure seems to be failing. The hard drives in there (old 2TB units) seem to be noisy, as well, so there's no happiness there either.

    I did use diskpart to clean the goofy hard drive, then used Disk Management to format the entire drive as GUID/NTFS. Now there is no EFI nor Recovery partitions (which seems to be correct as this HD isn't a boot drive). I have it in a separate USB enclosure and that works fine.

    I'm in the process of copying all the data from the remaining two 2TB HDs into a new 4TB USB. When that's done, the 4-bay enclosure will be discarded and the older 2TB HDs (some as old as 2011) will be destroyed as they are no longer reliable.

    None of this explains why the GUID/NTFS disk that would not mount in Windows only did so after the "HFS+ for Windows" software (from Paragon) was run (as that should not have been able to help because the disk wasn't HFS+ but was GUID). That immediate problem was resolved (by the diskpart/Disk Management stuff).

    Bottom line is that I'm using this situation to re-organize all my data from the externals and consolidate everything from the 2TB units to a new 8TB external with a couple of extra 8TB externals for grandfathered backups. My internal SSDs/HD have a few backup sets, as well, so I'll be able to sleep soundly.

    I'm going to call this issue resolved with Berton's suggestion as quite helpful as it started me moving toward the resolution. Thanks.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 05:32.
Find Us




Windows 10 Forums