External D Drive doesn't show up on file explorer.


  1. Posts : 31
    Windows 10
       #1

    External D Drive doesn't show up on file explorer.


    I got the 'USB Device Not Recognized' message last week while trying to plug in my external drive, it doesn't show up in file explorer, none of the files have been deleted and as far as I know it is recoverable. Can someone help with this one? Mine is 10586.122 and version 1551.
      My Computer

  2. Berton's Avatar
    Posts : 12,012
    Win10 Pro Versions 2004 and 2009/20H2, Win10 Pro IP_Dev, Win10 Home 1909
       #2

    Monstermaster said:
    I got the 'USB Device Not Recognized' message last week while trying to plug in my external drive, it doesn't show up in file explorer, none of the files have been deleted and as far as I know it is recoverable. Can someone help with this one? Mine is 10586.122 and version 1551.
    If the drive isn't recognized by Device Manager and Disk Management it can't be read. Try the drive in a different USB port or all if having more than one. Also try the drive in a different computer. The main thing is the drive has to be recognized before it can be worked with such as running a program to recover any data.
      My Computers


  3. Posts : 31
    Windows 10
    Thread Starter
       #3

    Berton said:
    If the drive isn't recognized by Device Manager and Disk Management it can't be read. Try the drive in a different USB port or all if having more than one. Also try the drive in a different computer. The main thing is the drive has to be recognized before it can be worked with such as running a program to recover any data.
    It blinks and makes sound and the blue light is always on, but it doesn't show up.
      My Computer

  4. Ivan Petrov's Avatar
    Posts : 242
    Windows 10 Home 21H2
       #4

    I get somethimes something similar, never happened before. When I plug my external USB HHD Toshiba in the usb 3.0 port, it's lighting up with its blue LED for a long time, not blinking??? From time to time the drive doesn't show up in Device Manager, Disk Management and Explorer. And also from time to time it's switching to the white LED??? Checkdisk doesn't find errors.
    I assume that the female USB 3.0 plug is a bit loosen - in the other USB port everything is fine.

    Hope this helps a tiny bit
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 09:28.
Find Us




Windows 10 Forums