PC spec: Windows 10 version 20H2
AMD Ryzen 3700x
Asus Crosshair Hero VIII wi-fi
BIOS version: 3401

Since last windows update. I had issue again with high latency like when I bought all my pc parts. Solved the problem a year ago by installing drivers manually.

This time I'm trying to install new drivers provided by AMD directly and the others drivers that Asus have linked for my Crosshair VIII wi-fi motherboard.

There is something strange happening, I extracted the drivers for the Intel Ethernet driver of my motherboard for example. When I click AsusSetup.exe I get the pop up asking If I authorize this app to make chance to my device, I click yes and nothing happen.
Screenshot - ada898e88a19df8a3c62441e081fa71a - Gyazo

I get this same issue with most drivers.

Also when I run the AMD_chipset_software from AMD. The software show me 5 drivers to install. I install them, reboot. Rerun the same software, it still show me 5 drivers to install. Is this normal? Screenshot - 9a3659d79cc5544148fb602f93bb9518 - Gyazo

Is there a software online that I could download and make a report of all my installed drivers version so I could compare with drivers version I am trying to install.