Dell XPS 89xx Power LED

Page 1 of 2 12 LastLast

  1. Posts : 68
    Inspiron 530: Windows 7 (64), XPS 8920: Windows 10 (64)
       #1

    Dell XPS 89xx Power LED


    The Dell Community has numerous topics like this one about the 89xx series chassis power LED blacking out. I am posting here for a wider audience.

    My own XPS 8920 (July 2017) had this happen. The LED did function briefly in late 2020, so I am convinced this is a software issue.

    That power LED is supposed to show 'Alerts' if there is a problem during Power On Self Test (POST), then stay on steadily after a successful boot-up. Apparently, the LED is controlled by some code in the system BIOS.

    Since Windows can do software restart and shutdown, there must be some program code that handles this. What we need is a routine that can activate the LED without affecting the on/off state of the computer.

    Windows version: 2004 (OS Build 19041.804)
    All Dell software updates, including BIOS, are current.
      My Computer


  2. Posts : 2,585
    Win 11
       #2

    I'll try to help, I'm one of the Dell forum "Rockstars" (supposed user tech - but I'll leave it at that).

    Support Assist may be the culprit. We see many problems or problems caused by Support Assist. I'll post the link, below, to the procedure to update Support Assist, which I would try as a first step.

    We have a different Support Assist problem that only certain model Alienware laptops and one model Inspiron laptop (a model 5577) that was apparently triggered by some early December 2020 Win 10 update. Support Assist at power on or restart erroneously reports "amount of memory has changed". This has been escalated to both our Dell Rockstar interface and to the Alienware support. Uninstalling Support Assist using Windows uninstaller does not completely remove Support Assist and the problem remains. We have found two ways to get around the problem until a fix is issued (1) completely uninstall Support Assist with "Revo Uninstaller Pro" (that scans registry and allows removing left over registry). (2) Uninstall with Windows Uninstaller then run Registry Repair with Ccleaner and remove left over Support Assist entries.

    If updating to the latest version of Support Assist doesn't fix it, do the removal as noted and see if the power light remains on. It won't show any error codes, but at least light (and prove another Support Assist problem). If this does "fix" the power light I'll escalate this to our Dell RockStar Interface.
    Support Assist Update Procedure
      My Computers


  3. Posts : 68
    Inspiron 530: Windows 7 (64), XPS 8920: Windows 10 (64)
    Thread Starter
       #3

    fireberd,
    Many thanks! I did the "Support Assist Update Procedure" with limited success.
    1. Uninstalled
    Dell SupportAssist, Dell SupportAssist Update Plugin, and Dell SupportAssist Remediation.
    1a. I did a software restart - no light.
    1b. I did a "Cold Boot" - software shutdown, then hardware restart. - The light flickered briefly when I pushed the power button. It never came on again after that.

    2. Reinstall
    SupportAssist.
    2a. Software restart. - The light pulsed slowly ~after Windows reloaded~ then strobed dimly as through there was a loose cable connection. After a couple of minutes, it glowed steady, but dimly.

    3. Reinstall SupportAssist Update Plugin.
    3a.
    Software restart. - The light glowed softly briefly during boot-up, then went out altogether.

    That the light came on at all suggests that this is not a hardware problem. Replacing the LED and button assembly, or that cable, will likely not help. There must be some software (BIOS or Windows) that controls this LED.
    The only way to eliminate the theory of a hardware problem would be to disconnect the power button cable, then apply the correct voltage to the cable connectors. I do not have the pinout specs to do that.
      My Computer


  4. Posts : 2,585
    Win 11
       #4

    Do the complete uninstall of SA, either by the (1) or (2) methods I listed. This sounds similarly like the other SA problem mentioned, that was also keyed from an apparent Microsoft/Windows update of some type.

    Revo Uninstaller Pro will allow downloading a trial version.
    RevoUninstaller | Remove programs easily with Revo Uninstaller
      My Computers


  5. Posts : 68
    Inspiron 530: Windows 7 (64), XPS 8920: Windows 10 (64)
    Thread Starter
       #5

    fireberd,

    After using the Windows Uninstaller (yesterday), with limited success, I downloaded and ran the "Revo Uninstaller Pro" per your suggestion.
    1. I uninstalled Dell SupportAssist and Dell SupportAssist Update Plugin.
    1a. Software restart. The power LED did nothing after a software restart.
    1b. Hardware reboot. The LED did wink when I pushed the power button after a shutdown and cold (hardware) reboot, but never came on after that.

    2. I re-installed Dell SupportAssist and Dell SupportAssist Update Plugin (no restart). The LED never winked. 2a. Hardware reboot. The LED winked when I pushed it, but never even flickered after that.

    While I am still convinced that this is a software problem, test results between today and yesterday are inconsistent.

    P.S.
    From where I sit, there is part of a window behind the tower case. To insure that I did not miss anything, I hung a dark-colored paperboard photo frame over the corner of the tower (case) above the power switch. If it glowed at all, I should have been able to see it.

    It should make no difference, but both of my computers are on Uninterruptible Power Supplies (UPS). I do not have power strips for either of them. I never unplugged the system unit power cord.
      My Computer


  6. Posts : 2,585
    Win 11
       #6

    Did you uninstall and also uninstall the registry entries and any left over files? If so, it doesn't seem my theory on SA is the reason.
      My Computers


  7. Posts : 68
    Inspiron 530: Windows 7 (64), XPS 8920: Windows 10 (64)
    Thread Starter
       #7

    fireberd,

    Yes, I did the uninstall, then cleaned up the registry entries and some left over files. I did get some LED activity during yesterday's attempts, so there still may be some underlying cause. Others should try this to see if their results are different.

    That LED should come on at power-up, stay on after POST, and stay on after Windows loads. I do not know what other software could affect it, but apparently something does.

    If there was a hardware problem, the LED should never light up. I'd bet my bottom dollar that, between Microsoft, Dell, and other software vendors, some thing in all of that code is throwing a monkey wrench into the works.

    I'd spit on a spark plug if I thought it would do any good. Keep at it!
      My Computer


  8. Posts : 2,585
    Win 11
       #8

    One other Support Assist thought. Some models have a Support Assist entry in the BIOS. Disabling the SA in BIOS had an affect on the other erroneous "memory change". If your model has a SA entry disable it and see if it makes any difference.
      My Computers


  9. Posts : 68
    Inspiron 530: Windows 7 (64), XPS 8920: Windows 10 (64)
    Thread Starter
       #9

    fireberd,

    Support Assist has these BIOS entries:
    Auto Recovery Threshold (originally 2)
    Support Assist OS Recovery (originally "Enabled")

    I turned Auto Recovery Threshold to "Off" and
    Support Assist OS Recovery to "Disabled" then did a software restart.

    The computer completely powered down* (the BD drive LED went off), then restarted. No power LED light at all.

    I reset the BIOS entries and did another software restart. Still no light on the power LED.

    Before I shut down last night (19 Feb), I put the computer in "Sleep" mode, something that I had never done before. Moving the mouse, clicking the left and right buttons did not wake the computer up. I tried several keys on the keyboard, but these failed to wake up the machine. Finally I tapped the power button. That brought the desktop back, but neither the mouse nor the keyboard could activate any application, or access the Start menu. The mouse did move the cursor, but clicking on anything did nothing. I did a CTRL + ALT + DEL to reach the shut down menu.Back to the drawing board!

    * I should have done a cold reboot with a hardware restart. Something had to be running to restart the machine.
      My Computer


  10. Posts : 2,585
    Win 11
       #10

    Thanks for trying that. I still think somehow SA is the cause.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 09:42.
Find Us




Windows 10 Forums