Dell 1710 laser printer problem

  1. alexm1's Avatar
    Posts : 12
    iOS
       #1

    Dell 1710 laser printer problem


    Hello, I have a dell 1710 laser printer installed on my Lenovo helix. I had the Lenovo and an HP desktop connected
    to the printer via a switch so that I could share the printer. I was not using the HP desktop so I removed the switch and connected the Lenovo directly. It has not worked since.
    I have the disk that came with the dell 1710 but windows 10 is not able to install from that disk (too old I expect).
    I have tried various methods to install the driver but without success.
    when I go to settings, devices, it does show the dell laser printer 1710 and below it is Default, error.
    when I print a test page it appears in the dialog box but status is blank and it fails to print.
    when I go to the device manager there are no printers showing.
    any thoughts on what I am doing wrong?
    windows version 20H2
      My Computer

  2. spunk's Avatar
    Posts : 2,886
    Windows 10 Pro 64 Bit 20H2
       #2

    connected the Lenovo directly..............I have tried various methods to install the driver but without success.
    How do you have the printer Connected directly? USB Cable? Wifi? Ethernet?
    What "various methods" did you use to install the driver? This printer is not supported in Windows 10.
    Did you try to download the driver from the Dell Drivers site? https://www.dell.com/support/home/en...-1710n/drivers. When you download, it comes down as a self extracting Zip file. It usually unzips to C:\Dell\Drivers\ take note of where it goes. If the install fails, browse to the Unzipped location and open the file, Right click Setup.exe and choose Properties/Compatibility. Put a check in the box Run This Program in Compatibility Mode for and take the drop down arrow and choose Windows 7. Also put a check in the box for Run As Administrator. Apply and OK. Double click Setup to install the driver.
    If all fails, put the printer back in the switch.
      My Computer

  3. alexm1's Avatar
    Posts : 12
    iOS
    Thread Starter
       #3

    Spunk, thanks for your response. The printer is connected via a USB cable. The final method I used was the one you outline. I downloaded the file, extracted the program, ran setup as you suggested, but there was no option to run as administrator. I have just reconnected the switch but no joy.
    when it gets to the final dialog box there is an option to print a test page, I select that, the test page is sent but never prints. In the print dialog box the status shows Error - printing, I can change it to paused (Error - paused) and back to printing but nothing changes.
    thanks again, with luck someone may come up with an answer.

    - - - Updated - - -

    Problem solved, I had selected port LPT1, changed it to USB001 and it all worked!
      My Computer

  4. spunk's Avatar
    Posts : 2,886
    Windows 10 Pro 64 Bit 20H2
       #4

    That was it! Glad you got it sorted.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:45.
Find Us




Windows 10 Forums