My USB3 external HD doesn't work in my new hardware


  1. Posts : 7
    windows 10 pro x64
       #1

    My USB3 external HD doesn't work in my new hardware


    Hello.
    Recently I have changed my hardware from an i7920, Asus P6x58D premium to a i7 10700K, asus rog strix z490-e gaming.
    I have NOT reinstalled windows neither formatted (It's windows 10 pro 1909 btw). I've tried to let windows to find drivers and everything is fine but my external hard drive. It is a Seagate expansion desk 2Tb, USB3.0.
    The thing is:
    When switched to an USB3 port, the system hangs when I double click in my external drive. It is recognized, but it shows a blank icon in "This PC". It shows de bar in the windows as it is "searching" infinitely.
    BUT, if I unplug and re plug again, windows detects the HD without problems and I can use it for all session.

    When switched to an USB2 port, everything works fine (but it's a USB2 spped, of course...)

    I have tried the "legacy USB" and the "XHCI hand off" things in BIOS. The problem is there no matter they're enabled or disabled.
    I have tried to uninstall the HD in device manager, reset PC and plug again. It works until I reset again and the system boots with the HD plugged

    SO, when the system boots with the HD plugged (in USB3), it goes crazy and give HD detection errors/hangs
    BUT if I boot the system with the HD unplugged and plug it after the system has booted, everything is right. Also, after the system hangs searching from the HD, if I unplug and re plug, it works OK again.

    Of course I know I could try to reinstall windows from scratch. It's not an option right now. I prefer using my HD under USB2 actually.

    Any ideas? Thanks in advance and sorry form my terrible english.
      My Computer

  2. Megahertz's Avatar
    Posts : 2,516
    Windows 7 HP 64 - Windows 10 Pro - Lubuntu
       #2

    Please update your system specifications => How to Fill in your System Specs at Ten Forums.
    It will help us to help you!

    Open Device manager and delete the USB3.x drivers and install a new one that came on the MB disk.
      My Computers


  3. Posts : 7
    windows 10 pro x64
    Thread Starter
       #3

    Hello, I've updated my profile, thanks.

    I have already latest chipset and bios (non beta) available in Asus' web. Still no changes.


    I have uninstalled the USB3 hubs in device manager and let windows reinstall again. Still no changes.


    It's very odd. If I unplug and replug the USB, the HD works correctly during all session. The problem only appears when booting the pc up with the HD already plugged.


    Maybe the problem is the HD? Although it's a USB3 unit, is a bit old (2014 I think...). It's a Seagate expansion desk 2Tb USB3. Anyway I have passed chkdisk and speed tests (As I tell you, I can use the HD perfectly if I unplug and re-plug the USB) and it seems that the unit is not damaged.
    Thanks.
      My Computer

  4. Megahertz's Avatar
    Posts : 2,516
    Windows 7 HP 64 - Windows 10 Pro - Lubuntu
       #4

    Check to see if USB drives are on top drive boot priority on BIOS. If positive, change boot priority to Windows boot manager.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:43.
Find Us




Windows 10 Forums