New NVMe drive is giving this (driver?) error


  1. Posts : 481
    Windows 10 Pro
       #1

    New NVMe drive is giving this (driver?) error


    Greeting
    I have got a new NVMe drive, Adata XPG GAMMIX S11 Pro 1Tbyte, and it does seems to work, but something is fishy. Adata's ToolBox can't read the firmware of the drive (CrystalDiskInfo can!), and in Device manager I got this error:

    New NVMe drive is giving this (driver?) error-image.png

    I have 2 other NVMe (Samsung 960 EVO and 970 EVO), and the mobo is AsRock Z390 Phantom Gaming X.

    The Adata drive does seems to reach the speed that is promished, so I'm not sure if this error cause any problems in the long run.
    There are no drivers for this Adata as there is for the Samsungs, so it is using a standard NVMe driver from Microsoft.
    Ideas?
      My Computer


  2. Posts : 1,867
    Windows 10 Pro 2004 20H1
       #2

    Read one online review saying that it needs to be installed in an M.2 x2 slot or higher, instead of a straight M.2 slot.
      My Computer


  3. Posts : 481
    Windows 10 Pro
    Thread Starter
       #3

    I have tried to move around between the 3 NVMe drives but that does not change anything. I have an ASUS NVMe adapter for PCIe x4, and right now the Adata-drive is running in this, and the Samsungs on onboard slots, but still the same "error"
      My Computer


  4. Posts : 132
    windows 10
       #4

    I don't know. But in passing, you don't need the drivers for the Samsung's, they should just work in a Z390 board without any.
    As far as I know the ADATA is not in the supported device list for the mobo, so I am wondering if it is just a BIOS issue and you need to update the motherboard BIOS. I would check that though before you try, you don't want to accidentally destroy your motherboard if there was no reason to even try to update it.
      My Computer


  5. Posts : 481
    Windows 10 Pro
    Thread Starter
       #5

    There are no new BIOS for this AsRock mobo. But that is of course a possibility.
      My Computer


  6. Posts : 481
    Windows 10 Pro
    Thread Starter
       #6

    A clean install of Windows 10 Pro did the trick. No driver problems any more in Device Manager. But Adata's software will still not read the info about the Adata drive, so I can't check for firmwareupdates to this drive, but everything seems to work fine.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:43.
Find Us




Windows 10 Forums