External USB drives not recognized after Win 10 clean install

Page 2 of 2 FirstFirst 12

  1. Posts : 69
    Windows 10 Pro
    Thread Starter
       #11

    [QUOTE=Paul Black;1945584]Hello @KenY7744
    I have just re-read this thread and omitted to tell you why you should ALWAYS disconnect ANY other drive [ external, USB, etc ] when reinstalling. One of the main reasons is to STOP Windows installing the Boot Partition on the WRONG drive. Also, with other drives attached this can cause [ probably will ] conflicts which lead to problems!

    Please elaborate on the conflicts/problems that can occur.

    Can you explain the following experiences I've had:

    I recall that once I disconnected a 2nd internal drive, and when I connected it after the install, I had all kinds of problems with permissions. I finally had to reinstall with the 2nd internal CONNECTED and afterwards, I didn't have any problems with permissions.

    I have installed Windows 10 many times before to an unallocated partition on Drive 0 with internal and external drives connected and never had any problems with permissions or recognition by the OS.

    I've never had a situation where the boot partition was installed on the wrong drive.

    Many thanks for your suggestions.

    Ken
      My Computers


  2. Posts : 4,470
    Windows 10 Pro x64, Various Linux Builds, Networking, Storage, Cybersecurity Specialty.
       #12

    Paul Black said:
    Did you make sure that ALL external drives were disconnected BEFORE you did the clean install?
    Right on target! This is a must before you do the clean install. All you can leave is the keyboard and mouse.

      My Computer


  3. Posts : 4,091
    Windows 7 HP 64 - Windows 10 Pro - Lubuntu
       #13

    If there is any problem with the USB drivers, the computer don't recognize the drives.

    Open Device Manager.
    Is there any yellow alerts of missing drivers?
      My Computers


  4. Posts : 69
    Windows 10 Pro
    Thread Starter
       #14

    Compumind: Why is it a must? I've done it in the past with no problems.

    - - - Updated - - -

    Megahertz, I found no yellow marks in Device Manager.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:39.
Find Us




Windows 10 Forums