USB COM Port mess


  1. Posts : 9
    Windows 10
       #1

    USB COM Port mess


    I had an Arduino UNO happily connected to my COM3 port via a USB hub. Last week, I needed to install a FTDI USB-UART adapter and had problems with its drivers. Eventually I got it going.

    Now here's the problem- whenever I plug in my Arduino, Windows thinks its the USB-UART adapter and assigns COM3 to it. I've tried updating the Arduino driver but Windows doesn't see it (thinks its a UART now?). I've tried deleting and reinstalling but the Arduino still shows up as the UART.

    How can I get back to where I was, with the Arduino happy again?! Thanks,

    DHJ
    Windows 10-1909

    - - - Updated - - -

    My previous post wasn't too clear so I thought I would update with what I'm seeing.

    On start-up, my only connected USB devices to my laptop are a mouse/keyboard and a hub. The laptop functions perfectly and Device Manager is fine. I have 2 additional USB devices that need to be connected:
    A: which is a Arduino UNO and
    B: which is a USB/TTL UART adapter.

    When I connect A, the Device Mgr shows it as the UART device (device B). When I connect B, Device Mgr shows it as USB Serial Device (COM4) (device A). I can't update the driver for either because Windows doesn't see the correct driver ie. if I go to the Arduino driver folder to load the proper driver, Windows will not load as it's looking for UART drivers. It's as if the 2 devices have switched identities.

    Can I "delete" this devices from the registry somehow and start over? I've tried deleting the devices using Device Manager but when I re-connect them, they assume their old identities.

    I'm quite stuck on how to further troubleshoot or come up with a potential fix. Any help would be appreciated!
      My Computer

  2. hsehestedt's Avatar
    Posts : 1,100
    Windows 10 Pro, 2004
       #2

    You should not need to go into the registry to clean this up.

    Try this:

    1) Make sure that neither the FTDI adapter or the Arduino are connected
    2) Open Device Manager
    3) Select View > Show hidden devices
    4) Expand open the the "Ports (COM & LPT) section
    5) Look for any entries within this section that are dimmed or greyed out. Delete those entries by right-clicking and choosing "uninstall device". DO NOT check the box that says "Delete the driver software for this device".
    6) Close device manager.

    At this point, you should be able to plug in your Arduino and have it redetected. Note that it may show up on a different COM port than it was before. You can go back into Device Manager to see what COM port is assigned to it now.

    Open your Arduino IDE and select the appropriate port (Tools > Port > Select the correct port).

    Let me know if that resolves the issue for you.
      My Computers


  3. Posts : 9
    Windows 10
    Thread Starter
       #3

    No luck yet.

    Performed the steps as requested, plugged in Arduino. Doesn't show in Ports. Device Manager shows it in "Other Devices- CP2104 USB to UART Controller". With no driver installed ie. with a ! in icon.

    Next steps? Thanks.
      My Computer

  4. hsehestedt's Avatar
    Posts : 1,100
    Windows 10 Pro, 2004
       #4

    Sounds like Windows simply cannot locate a driver for it. What happens if you right-click the device in device manager and you choose to update drivers? You can try searching your local computer to see if it can find the driver.

    If a bad driver somehow got installed, try repeating the steps done previously (with showing hidden devices). If it still shows up, try removing it again but this time tell it to remove the driver software. Then try again searching for a new driver.

    BTW, just out of curiosity, what kind of FTDI adapter do you have? I'm interested in this because it just so happens that I ordered one yesterday and now I'm curious whether I'll end up running into this as well
      My Computers


  5. Posts : 9
    Windows 10
    Thread Starter
       #5

    I bought the adapter off Amazon- DSD Tech (China, cost ~$10). It has the FTDI R232RL chip and I used drivers (2.12.28) from the FTDI site. Works perfectly.

    So more investigating- The adapter appears as USB Serial Port (COM4) in Device Manager. The Driver information and Details under Properties are all good and the adapter works perfectly. I can live with the weird name. Or go into regedit and fix it sometime later.

    But the Arduino UNO shows up in Other Devices as CP2104 USB to UART Bridge Controller, without an installed driver. When I try to update the driver manually or allow Windows to search, it says it can't find a driver. So I obviously can't remove the existing driver. How can I "force" it to accept the Arduino drivers? Thanks for your help so far!
      My Computer

  6. hsehestedt's Avatar
    Posts : 1,100
    Windows 10 Pro, 2004
       #6

    Hmm, I need to think about that one a bit. It may be tomorrow before I reply as I've got some tasks I need to finish this evening, but I promise I'll look into this further.
      My Computers


  7. Posts : 9
    Windows 10
    Thread Starter
       #7

    I forced a new driver update on the UNO in Device Manager by going to Update driver->Browse->Let me pick and selected the Arduino driver manually. The update worked, sort of, and now I can connect the UNO but I cannot load a sketch. I get an error:

    avrdude: ser_open(): can't set com-state for "\\.\COM6"

    I have another UNO board that works perfectly so I connected it to COM3 and compared its driver details to those of the non-working COM6 board and have attached the results. There are a lot of differences. The driver still thinks its talking to something other than an Arduino. For example, the vendor id is for Silicon Labs (10c4) and the PID is for the UART (ea60). I think this may be the reason why the IDE says its connected to an unknown board and the sketches will not upload. Very frustrating!
    Attached Thumbnails Attached Thumbnails USB COM Port mess-arduino-not-working-com6.jpg   USB COM Port mess-arduino-com3.jpg  
      My Computer


  8. Posts : 329
    Windows 10
       #8

    Windows 10 doesnt support prolific Serial to USB anymore.

    See if you can get a newer lead that supports Windows 10 and can work with the UART interface

    Good luck

    Im pretty sure its a security thing. Positive note about Windows 10 i suppose
    Last edited by Pluginz; 4 Weeks Ago at 18:11.
      My Computer

  9. hsehestedt's Avatar
    Posts : 1,100
    Windows 10 Pro, 2004
       #9

    Just to make sure that there is not some problem with the Arduino itself, have you tried to plug it into another PC (if you have one available), to make sure it shows up there? I'm a bit at a loss as to what might be happening.
      My Computers


  10. Posts : 9
    Windows 10
    Thread Starter
       #10

    The UNO shows up as the FTDI UART in another PC. I went back to basics- reinstalled the UNO bootloader, reinstalled the Arduino IDE, removed all drivers and started fresh. All is working but......the UNO still says its a UART but I can at least use it. Who knows! I'll mark this as closed.

    Thanks for your help @hsehestedt
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:45.
Find Us




Windows 10 Forums