1. Joined : Aug 2015
    Posts : 2
    Windows 10
       11 Aug 2015 #1

    HDMI Audio not working after upgrade to Windows 10


    Hi All,

    I've searched and found similar problems to mine, but none of those solutions worked so I'm reaching out here.

    I currently have an Asus Vivopc desktop that I use as an htpc and it is connected directly to my LG LB5800 tv. The PC has onboard speakers which sound terrible and when I connect the tv via HDMI, the video works fine but no sound comes from the tv. I still get sound from the PC but no matter what I can see, there is no option whatsoever to have the TV as a playback device. It isn't listed at all. I've reinstalled the intel and realtek drivers but that didn't work. I've opened up the playback devices, shown disabled devices and it didn't show up either.

    With Windows 8 it worked flawlessly. With Windows 8.1 it would only work when I rebooted the computer with the TV on, otherwise the device would disappear as soon as it was turned off. With Windows 10, it just isn't there at all.

    The computer is a celeron 1007u with intel hd graphics (which also takes care of the sound portion). Drivers are updated, I've tested the hdmi cable and it works....No where in my control panel does it list anything related to intel hdmi audio.

    Please help, this is super annoying!
      My System SpecsSystem Spec


  2. Joined : Jul 2015
    Posts : 6,890
    Windows 10 Pro
       11 Aug 2015 #2

    What do you have in Device Manager under Sound, video, and game controllers, especially with the TV plugged in and turned on?

    Are you trying to use this driver:
    http://dlcdnet.asus.com/pub/ASUS/mis...17525_WHQL.zip
      My System SpecsSystem Spec


  3. Joined : Aug 2015
    Posts : 2
    Windows 10
       16 Aug 2015 #3

    Under Sound, Video, and Game Controllers there are:
    Intel(R) Display Audio
    Realtek High Definition Audio

    Under Audio Input and outputs:
    Realtek Digital Output
    Speakers

    Digital Media Devices:
    TV LG LB5800

    Yes that is the driver I have installed.
      My System SpecsSystem Spec


  4. Joined : Sep 2014
    Posts : 2,923
    Windows 10 Pro
       16 Aug 2015 #4

    What is your video card? What video driver are you using?
      My System SpecsSystem Spec


  5. Joined : May 2015
    Posts : 1,380
    Win 10 14393.51
       16 Aug 2015 #5

    I see that Asus lists Windows 10 drivers for the Intel graphics:

    http://dlcdnet.asus.com/pub/ASUS/mis...1018154248.zip

    This isn't the same link as supplied in post #2. May be worth a try.
      My System SpecsSystem Spec


  6. Joined : Oct 2013
    Penns Forrest
    Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       16 Aug 2015 #6

    Kail said: View Post
    I've opened up the playback devices, shown disabled devices and it didn't show up either.

    Try enabling Disconnected devices view.

    Also please post screen shots of your Sound dialog windows. I'm not sure what to look for right now, but post the playback screens (some are property pages).

    There is another suggestion to try that I can't recall right now - I'll post that if I find it.
    Click image for larger version. 

Name:	sndPlayback.png 
Views:	881 
Size:	20.0 KB 
ID:	31860

    Post any screen shots of devices in Dev Mgr that flagged.

    Try running the Control Panel > Troubleshooting > Troubleshoot audio playback

    You can also try turning off both devices, power up the TV, set to HDMI, power up the PC. The TV has to be listening on the HDMI port before the PC is turned on.

    I used to have to do this in Win7, Win8 - similar to your comment With Windows 8.1 it would only work when I rebooted the computer with the TV on, otherwise the device would disappear as soon as it was turned off. ... but it sounds as though this doesn't work on your machine.
      My System SpecsSystem Spec


  7. Joined : Aug 2015
    Posts : 1
    Windows 10
       17 Aug 2015 #7

    HDMI sound not working


    :
    bobkn said: View Post
    I see that Asus lists Windows 10 drivers for the Intel graphics:

    http://dlcdnet.asus.com/pub/ASUS/mis...1018154248.zip

    This isn't the same link as supplied in post #2. May be worth a try.
    Thanks this worked for me
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
hdmi audio
Now i cant get the audio to work i have the realtek audio drivers and the CCC audio drivers. I am using a radeon hd7700 gpu.
Graphic Cards
Hdmi not working on windows 10 home
i upgraded from windows 7 home premium. i have amd radeon hd 5650 installed on my laptop and i use to connect my laptop to my L.G tv through hdmi for games and movies. now i have upgraded to windows 10 home. tried installing the newest windows 10...
Graphic Cards
Solved No audio after upgrade from 8.1 to 10 using HDMI cable
Per the title, I run my computer through my TV using an HDMI cable. Sound works brilliantly on Windows 8.1 but after upgrading to Windows 10, I'm left without audio, and in the sound settings it doesn't show HDMI as an available device. Ideas?
Installation and Setup
Recurring Update Problems - HDMI Audio & Start Menu
These issues have happened with each update and seem pretty significant that I'm worried it isn't being addressed. I'm not sure if it is AMD exclusive or not but whenever I update my Win10 build (this time to 10130) the audio to my monitor...
General Support
HDMI Audio Not Working After Any Restart or Shut Down
This happened on the previous build as well but I was hoping it would be fixed with the newer build. I have a AMD R9 280X GPU which I connect with an HDMI cable to my one monitor with built in speakers (ASUS). Any time I restart or shut down my...
Graphic Cards
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:53.
Find Us
Twitter Facebook Google+



Windows 10 Forums