Synaptics WBDI fingerprint driver not working on Lenovo Ideapad 520 ?

Page 2 of 2 FirstFirst 12

  1. Posts : 8
    Windows 10 Pro
    Thread Starter
       #11

    Thanks, but too late.
    Device was sent yesterday
      My Computer

  2. EdTittel's Avatar
    Posts : 4,098
    Windows 10
       #12

    No problem @Karine. Hope your replacement/alternative works without issues. Sorry for your troubles.
    --Ed--
      My Computers


  3. Posts : 8
    Windows 10 Pro
    Thread Starter
       #13

    Very poor support from Lenovo.
    Received laptop today, I'm booting up and the fingerprint scanner didn't work.
    Then went into device management and just the same as before I sent it.
    An exclamation point.
      My Computer

  4. Bastet's Avatar
    Posts : 1,714
    Windows 10 Pro 64bit
       #14

    I would uninstall the driver again & then install it from the link I posted.
    If the problem remains then we need to look further into it.
      My Computer


  5. Posts : 8
    Windows 10 Pro
    Thread Starter
       #15

    I applied EdTittel's method.
    So basically I reinstalled the driver and now everything works again.
    Wondering how long it takes.
    What I don't understand is why after a few days suddenly the driver doesn't work anymore.
      My Computer


  6. Posts : 8
    Windows 10 Pro
    Thread Starter
       #16

    Update, scanner still works.
      My Computer

  7. EdTittel's Avatar
    Posts : 4,098
    Windows 10
       #17

    Windows can be like a mysterious wilderness sometimes. I guess we should be grateful it's not out-and-out dangerous!
    --Ed--
      My Computers

  8. rseiler's Avatar
    Posts : 287
    Windows 10 Enterprise x64 (Insider)
       #18

    Have any of you seen the problem recur with 2004 (I have)? This is such a widely-reported problem across a spectrum of models, and covering varying versions of the driver, that it's hard to believe that it's Lenovo's problem. The common denominator is Windows.

    Ed, is your method meant to be a permanent fix or just a fix-up? It works, but I don't know if it stays that way (given the nature of the problem, I doubt that it will stay fixed).
      My Computer

  9. EdTittel's Avatar
    Posts : 4,098
    Windows 10
       #19

    @rseiler: as a Windows Insider, I went through a LONG period of 20H1 updates earlier this year when every time a new build appeared I had to visit Device Manager to repeat my "trick" to restore the fingerprint reader to operation. But I never had trouble within the same build after that with the fingerprint reader. If yours is failing repeatedly over time, I would be inclined to start thinking about hardware issues -- specifically, the probability of a loose lead in your case that is causing the device to connect/disconnect on its own. This plays hob with device detection and can cause the kind of situation you describe. That said, I'm flat-out guessing here, so you'll just need to keep an eye on it and see if it continues at the same pace (repeat the "trick" when that happens) or if the frequency increases. Should the latter condition prevail, you'll want to think about a shop visit for your PC (or possibly replacing the whole thing, if it's not a huge budgetary stretch for you).
    Sorry for your troubles,
    --Ed--
      My Computers


 
Page 2 of 2 FirstFirst 12

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 08:26.
Find Us




Windows 10 Forums