unable to see volume contents, unable to bring volumes online

  1. Posts : 4

    unable to see volume contents, unable to bring volumes online

    I am not sure if I have this in the correct forum - please let me know if it should be elsewhere.

    I have W7-64 installed on an MBR SATA SSD, and in use for several years. This disk has 2 partitions, one system & the other one is data.
    Now I have installed W10-64 1909 on a GPT NVMe SSD on the same system in a UEFI dual boot setup. (I unplugged all other disks while installing W10)
    This is functioning, it can boot cleanly into either one.
    (BTW there are two other GPT data mechanical drives in the system, no problem accessing them)

    At first, I could see both SSD disks from both systems. Now, I cannot see the W7 disk contents from W10 (the other way still works). W10 can see that the other disk is there, but it cannot see its contents. Drive letters are assigned. In windows explorer, the disk contents are blank (while I know they are not blank).

    Using diskpart on the W10 system, I noticed that the disks are all online, but the 2 volumes of the W7 SSD are offline. I tried to bring them online by selecting them and then applying the diskpart Online command, but diskpart responds:
    "diskpart could not online the selected volume"

    Why not? How do I fix this?

    Thank you in advance.
      My Computer

  2. Posts : 4
    Thread Starter

    Here is some more information:
    I installed Minitool Partition Wizard Home Edition Free 11.5 in the W10 system.
    In the partition management display, it shows the two W7 SSD's partitions' file systems as type NTFS.
    Then when I select a partition and say Check File System (which runs CHKDSK). It says the partition type is RAW, and it cannot apply a check to this type of file system. Hmmm

    I run Partition Wizard's Recover Partition tool. It finds the two NTFS partitions on the W7 SSD. But afterwards there is no change in their in-accessibility.

    Then I select one of the W7 SSD's partitions and select the command "Hide Partition". Then I select Apply. The partition is hidden.
    Then I select the same partition and select the command "Unhide Partition". Apply. The partition is unhidden.
    Then the partition becomes accessible, also in the File Explorer. I run a Check File System, and it comes out clean.

    So at that point I think that I have solved it. I reboot W10, and the partition is back to being inaccessible.
    So something is marking the W7 SSD partitions as Offline or RAW during every W10 boot.

    I went to startup, and disabled the 4 programs that I had installed & set to start at boot, so only windows 10 is starting.
    Same thing happens. So it is not something that I have installed.
    Something in W10 is marking these 2 W7 SSD partitions as RAW or Offline at every boot.
      My Computer

  3. Samuria's Avatar
    Posts : 6,664
    windows 10

    Normally this is down to a disk signature crash check that both have different signatures
      My Computer

  4. Posts : 4
    Thread Starter

    I guess that a disk signature crash is when two disks have the same signature? I have not done cloning, so it is quite unlikely that would happen.
    I guess that disk signatures do not change depending on which OS views the disk, right?
    (I am in W7 now, and it will be a few hours at least before I can shut down and log in to view things from within W10.)

    But anyway looking at diskpart in W7, the signatures are all different. The signature of the W7 [MBR] SSD is also quite different in format from the others [GPT]. The 3 GPT drives signatures all look like <XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX> while the signature of the W7 MBR SSD looks like XXXXXXXX.
    Is that normal, or could that be a problem?

    - - - Updated - - -

    Indeed, checking the signatures while in W10 shows that they are all different.

    - - - Updated - - -

    I might have discovered something.

    While in W7, running Partition Wizard 8, the Partition Type ID of one of the partitions (a data partition) which is going offline in W10 is "0x07 NTFS". That makes sense because both of the W7 SSD partitions which are marked as offline in the W10 environment are indeed NTFS partitions.

    However, the Partition Type ID of the other W7 SSD NTFS partition (Primary, Active - the one with the W7 OS on it) which is being marked offline in the W10 environment is "0x06 FAT 16, greater than 32MB." That appears to be incorrect.

    What happens if I change this to be the same as the other one - "0x07 NTFS" ? Partition wizard warns "Changing the partition ID might prevent some operating system from working with the partition." What is surprising is that W7 works now, with an incorrect Partition Type ID. Could it be that W7 pays no attention to the Partition Type ID, but W10 does?

    What do you think?
      My Computer

  5. Posts : 4
    Thread Starter

    I changed the Partition Type ID to "0x07 NTFS", and it unfortunately made no difference.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:07.
Find Us

Windows 10 Forums