Installed newer Asmedia USB drivers, pc now refuses to post


  1. Posts : 681
    Windows 10 x64 Pro
       #1

    Installed newer Asmedia USB drivers, pc now refuses to post


    Ugh.. Uuuuugh. I have a macrium image but it was from yesterday morning and i did a TON of work yesterday. I'm talking like.. 12+ hours worth.

    I ran DUMO and noticed there was an updated usb 3.0 extensible host controller driver for my ancient board (crosshair v formula z) so i scooped it up, right clicked the inf and installed.

    Said i needed to restart, which I did.

    On restart it wont go past the asus logo screen. No spinning wheel, just sits there.

    I tried safe mode, same exact thing. Startup repair, same exact thing.

    Theres an option in advanced startup to run cmd and wondering if I can remove those drivers via that means?

    - - - Updated - - -

    well, windows took it upon itself to roll back to a system restore from a few days ago. (love how it has a mind of its own on restore points, doesnt even make them daily)

    its vagueness (to an earlier point in time...) lol.

    So the end result is the macrium restore anyhow. A days worth of work lost and a lesson learned.
      My Computer

  2. Pejole2165's Avatar
    Posts : 747
    Windows 10 Pro 1909
       #2

    Yep, sorry to hear it went south for you...but as you said, lesson learned, before making any major system changes (drivers, WU's etc) make an image before pressing that "install button" just in case.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:04.
Find Us




Windows 10 Forums