Attn. SSD owners - Enabling AHCI mode AFTER Windows 10 installation. Solved

Page 8 of 8 FirstFirst ... 678
  1.    #71

    Your command for safe mode does not work for me. Is that the exact syntax?
      My ComputerSystem Spec

  2.    #72

    Worked a treat for me on Gigabyte GA78-LMT-USB 3 V 6 MB AMD FX-8320CPU and WD Blue 500 HDD!
    Now to try it on the Toshiba drive! (I use a drive tray and swap drives).

    Big thank you!!! Saved me a lot of trouble!

    Does anyone know if this method works for Win 7?
    Last edited by flhthemi; 15 Dec 2016 at 12:28.
      My ComputerSystem Spec

  3.    #73

    ya it works, did it a few months back on this PC,

    Thanks a bunch.......
      My ComputerSystem Spec

  4.    #74

    10x , worked just fine
      My ComputerSystem Spec

  5.    #75

    Thank You!

    I too just registered to say, THANK YOU! The process worked like a charm and I am now Windows 10 sees all my SATA drives.

    Toobad, thank you once again. I never would have figured this out on my own.
      My ComputerSystem Spec

  6.    #76

    Azphel said: View Post
    Your command for safe mode does not work for me. Is that the exact syntax?
    Somewhere on the Web I found a simpler alternative: Just use MSCONFIG to boot to Safe Mode (then change IDE or Compatibility to AHCI) then use MSCONFIG again to change boot back to normal (or Selective, if you prefer). It worked smoothly for me, when the command line did not, and I wasn't having fun entering Safe Mode with Function Keys during the POST, either.

    Here are more details if anybody needs them:
    In my Windows 10, typing MSCONFIG in the Windows search bar finds the System Configuration app (MSCONFIG to its old pals). Open it.
    Choosing the "Boot" tab at the top shows a section called "Boot options", including a check-box for "Safe boot". Check it. ("Minimal" seems to work fine. Probably several others are also fine.)
    Then Restart, which should go straight to Safe mode.
    At the very start of the reboot, right after Windows closes, I started hitting F1 & F2 & maybe F8, until I saw a symbol or text that said I was going into BIOS editing mode. (I think F1 is the key that actually works on my Thinkpad x120e.)
    In BIOS editing mode, I went to the right then down to something like SATA mode, then changed Compatibility to AHCI and chose Save & Exit. That rebooted -- now using MS's AHCI driver! -- but still in Safe Mode.
    I again opened MSCONFIG and UNchecked the "Safe boot" check-box and rebooted again, this time to W10 normal mode.

    I hope it works for you and others too -- and thanks to the mystery person who posted it somewhere for me to find!
    Last edited by normofthenorth; 17 Oct 2017 at 17:45. Reason: minor correction
      My ComputerSystem Spec

  7. Posts : 1
    Windows 10 Pro x64

    Thank you, the OP solution worked like a charm for me in Windows 10 Pro x64.
      My ComputerSystem Spec

  8. Clint's Avatar
    Posts : 429
    Windows 10 Pro 64 bit

    Toobad said: View Post
    Hello everybody. What started out as a request for guidance ended up with me solving my own problem. Thought I may as well pass on my findings anyway just in case it helps somebody else in the same situation.

    e ch 3 morSo over the weekend, through a series of upgrades, I successfully hopped from Vista to Windows 10 Professional 64-bit. But, as is not unusual, I again managed to snatch defeat from the jaws of victory. With my new SSD loaded with Win 10 goodness, I realised I was still operating it in IDE modaracters.e. A confident dip into the BIOS to enable AHCI mode resulted in Windows then failing to start because it no longer recognised the boot drive! I'm guessing the AHCI driver wasn't loaded during installation since the mode wasn't in use. So back to IDE mode and a surf around for solutions. Plenty around pertaining to Vista, Win 7 and Win 8 involving changing registry values but nothing tangible for Win 10. However I found this alternative Win 8 workaround which I can confirm works equally well in Windows 10. I realise I'm probably teaching my Grandmother to suck eggs with this post here but perhaps somebody as equally technophobic as me, may find it useful. This is what I did:

    1. Run Command Prompt as Admin
    2. Invoke a Safe Mode boot with the command: bcdedit /set {current} safeboot minimal
    3. Restart the PC and enter your BIOS during bootup.
    4. Change from IDE to AHCI mode then Save & Exit.
    5. Windows 10 will launch in Safe Mode.
    6. Right click the Window icon and select to run the Command Prompt in Admin mode from among the various options.
    7. Cancel Safe Mode booting with the command: bcdedit /deletevalue {current} safeboot
    8. Restart your PC once more and this time it will boot up normally but with AHCI mode activated.
    9. Bask in the reflected glory of being a total Windows 10 God

    Thanks Toobad for fixing my issue.
      My ComputersSystem Spec

  9.    #79

    Thanks Toobad, your instructions are still helping us out!! I had a crash on my Win10 with the SSD installed which was working fine at the time but when I got the computer running again, the Samsung SSD was in IDE mode and when I switched to ACHI mode in BIOS, it wouldn't boot. The suggested registry hacks looked like a nightmare - but then I found your post! It worked like a charm, thanks again!!!
      My ComputerSystem Spec

  10.    #80

    Thanks Toobad - worked for me today! AlienWare (7th gen core i7). Installing Ubuntu 18.04.1 for dual boot now recognizes the NVMe SSD drive.
      My ComputerSystem Spec

Page 8 of 8 FirstFirst ... 678

Related Threads
Hi All. I would appreciate some help on this one. I found a spare 160GB SATA Drive on which I have decided to install a trial of Win 10 to explore it further for now. The only way that I could get this HD to be seen in the BIOS would be to...
AHCI still not fixed??? in General Support
has anyone found any information about ms fixing ahci in win 10? i just can't believe after so many months that they STILL have not fixed this. any new information is appreciated. thanks!
Whenever I activate Cortana either by clicking the little microphone icon near Ask me anything bar or by WinKey + C, the sound level of my microphone changes to 62, so I several times went to Recording Devices -> Right click on Microphone ->...
Source: Game streaming now enabled for all Xbox One owners with a Windows 10 PC | Blogging Windows
Hello, My wife is currently using build 10130, and is trying to use her SATA HDD (which was her 2nd HDD) externally, with a SATA to USB adapter. However, on plugging the HDD in, all that shows as new in Devices and Printers is the following "USB...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:11.
Find Us