Windows 10: Attn. SSD owners - Enabling AHCI mode AFTER Windows 10 installation. Solved

Page 8 of 8 FirstFirst ... 678
  1.    01 Dec 2016 #71

    Your command for safe mode does not work for me. Is that the exact syntax?
      My ComputerSystem Spec

  2.    15 Dec 2016 #72

    Worked a treat for me on Gigabyte GA78-LMT-USB 3 V 6 MB AMD FX-8320CPU and WD Blue 500 HDD!
    Now to try it on the Toshiba drive! (I use a drive tray and swap drives).

    Big thank you!!! Saved me a lot of trouble!

    Does anyone know if this method works for Win 7?
    Last edited by flhthemi; 15 Dec 2016 at 13:28.
      My ComputerSystem Spec

  3.    17 Dec 2016 #73

    ya it works, did it a few months back on this PC,

    Thanks a bunch.......
      My ComputersSystem Spec

  4.    02 Jul 2017 #74

    10x , worked just fine
      My ComputerSystem Spec

  5.    19 Aug 2017 #75

    Thank You!


    I too just registered to say, THANK YOU! The process worked like a charm and I am now Windows 10 sees all my SATA drives.

    Toobad, thank you once again. I never would have figured this out on my own.
      My ComputerSystem Spec

  6.    17 Oct 2017 #76

    Azphel said: View Post
    Your command for safe mode does not work for me. Is that the exact syntax?
    Somewhere on the Web I found a simpler alternative: Just use MSCONFIG to boot to Safe Mode (then change IDE or Compatibility to AHCI) then use MSCONFIG again to change boot back to normal (or Selective, if you prefer). It worked smoothly for me, when the command line did not, and I wasn't having fun entering Safe Mode with Function Keys during the POST, either.

    Here are more details if anybody needs them:
    In my Windows 10, typing MSCONFIG in the Windows search bar finds the System Configuration app (MSCONFIG to its old pals). Open it.
    Choosing the "Boot" tab at the top shows a section called "Boot options", including a check-box for "Safe boot". Check it. ("Minimal" seems to work fine. Probably several others are also fine.)
    Then Restart, which should go straight to Safe mode.
    At the very start of the reboot, right after Windows closes, I started hitting F1 & F2 & maybe F8, until I saw a symbol or text that said I was going into BIOS editing mode. (I think F1 is the key that actually works on my Thinkpad x120e.)
    In BIOS editing mode, I went to the right then down to something like SATA mode, then changed Compatibility to AHCI and chose Save & Exit. That rebooted -- now using MS's AHCI driver! :-) -- but still in Safe Mode.
    I again opened MSCONFIG and UNchecked the "Safe boot" check-box and rebooted again, this time to W10 normal mode.
    Done!

    I hope it works for you and others too -- and thanks to the mystery person who posted it somewhere for me to find! :-)
    Last edited by normofthenorth; 17 Oct 2017 at 17:45. Reason: minor correction
      My ComputerSystem Spec


  7. Posts : 1
    Windows 10 Pro x64
       06 Dec 2017 #77

    Thank you, the OP solution worked like a charm for me in Windows 10 Pro x64.
      My ComputerSystem Spec


 
Page 8 of 8 FirstFirst ... 678

Related Threads
Hi All. I would appreciate some help on this one. I found a spare 160GB SATA Drive on which I have decided to install a trial of Win 10 to explore it further for now. The only way that I could get this HD to be seen in the BIOS would be to...
AHCI still not fixed??? in General Support
has anyone found any information about ms fixing ahci in win 10? i just can't believe after so many months that they STILL have not fixed this. any new information is appreciated. thanks!
Whenever I activate Cortana either by clicking the little microphone icon near Ask me anything bar or by WinKey + C, the sound level of my microphone changes to 62, so I several times went to Recording Devices -> Right click on Microphone ->...
Source: Game streaming now enabled for all Xbox One owners with a Windows 10 PC | Blogging Windows
Hello, My wife is currently using build 10130, and is trying to use her SATA HDD (which was her 2nd HDD) externally, with a SATA to USB adapter. However, on plugging the HDD in, all that shows as new in Devices and Printers is the following "USB...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:16.
Find Us