Device Driver updated a different MS package this time after reinstall  

  1. Posts : 145
    Windows 10 Home

    Device Driver updated a different MS package this time after reinstall

    I installed 1909 from 1903 and then my All in One printer stopped working. It's a non-compatible Lexmark Pro700 Series inkjet. I've used the printer in Windows 10 ever since the new desktop OOBE purchase. It's always been connected via a USB cable and worked fine. Lexmark got out of the inkjet business a long time ago so they don't support updated drivers.

    The first time that I actually ever had a problem with the printer not working occurred after installing version 1903. To get it working again on 1903 didn't take any real fiddling. I have to assume it became working again due to a Microsoft driver package automatically installed by Device Driver via Windows Update. I'll explain my reasoning.

    After installing 1909, Device driver updated the Driver Store with a different Microsoft printer driver package. How do I know this? From what I noted in the Driver Store while I was still on 1903. The Microsoft driver package had an "identification", for the lack of a better word, to describe the INF which was different than what the identification is that’s installed now.

    The Microsoft printer driver package in the Driver Store showed the package identified as prnms066.inf. After installing 1909, I removed the printer, uninstalled all drivers, and re-installed the Lexmark software and drivers. I attempted every method that can be followed in the book when trying to re-install the printer and get it working in 1909.

    I believe the Microsoft driver package - prnms066.inf is the correct one. The MS package that installed this time however is identified as prnms006.inf. Catch the difference? Look at the numbers. No, I did not make a mistake when I wrote down prnms066.inf while on version 1903.

    I spent time searching in Windows Update Catalog using every search phrase I could come up with for this MS driver package. Without knowing the version number makes it a little harder, and I have only been able to find the prnms006.inf file on the Update Catalog website.

    Yesterday, I uninstalled version 1909. The reasoning was that if Device Driver installed the working driver package in 1903, it might again. Incidentally, the printer began showing up in Control Panel -> Devices and Printers as "Unspecified" with a small generic looking icon after going to 1909. The same with my USB external HDD. I'm currently on 1903 now and nothing has changed in regard to this thing that others are experiencing too where USB connected devices show as 'Unspecified".

    I'd greatly appreciate some direction here. Sorry about the long post
      My Computer

  2. Posts : 1,198
    Windows 10

    A google search of prnms066 show nothing. Prnms006 is a standard printer module from Microsoft for windows 8.

    It seems like Microsoft finally killed support in 1909. Get a new printer.
      My Computer

  3. Posts : 4,453
    Win 11 Pro 22000.708

    Sounds like your USB drivers have been corrupted.

    I'm unaware of a simple fix. You could try sfc/scannow (from a command line window run with administrator privileges), or DISM /Online /Cleanup-Image /RestoreHealth. (I wouldn't bet much that either will help.) I doubt that you'd be enthusiastic about a clean install of Windows 10, but that may be surest way to advance.

    I don't know about drivers for the Lexmark. (According to Wikipedia, they exited the inkjet market in 2012.) I would expect the Windows 8 drivers (the latest official version) to work, but I don't own such a printer to confirm. (I like Brother printers because of their support for old hardware.)

    Best of luck.
      My Computers

  4. TV2
    Posts : 2,221
    W10 Pro 22H2

    Since you currently do not have a working printer in 1903 I'd suggest upgrading to 1909 again before attempting a fix.

    Then try this:

    Be sure you have on hand the last known good driver for Windows (8?) for the printer.
    Unplug the printer (USB).
    Go to Control Panel > Devices and Printers > and remove any instance of the printer (or unknown device you know is the printer)
    For good measure, then check Device Manager too.
    Now back in Control Panel > Devices and Printers >
    Select any printer > top of the window click on Print Server Properties >
    Go to the Drivers Tab > find any instance of the problem printer > select > and Remove
    Restart the PC
    (At this point I will usually do a registry cleaning, usually with CCLeaner, but sometimes manually, to remove any trace of the printer. But this may not be necessary)

    Now install the printer as directed by the manufacturer. Run the driver package in Compatibility Mode for Windows 8. Do not plug in the USB until told to do so.

    Hopefully this process will clear out any driver conflict. If the printer prints a test page then the hope is that any Windows 10 update to the driver will not cause another conflict.
      My Computers

  5. Posts : 1,198
    Windows 10

    There is a windows 10 testing driver in MUC.
      My Computer

  6. Posts : 145
    Windows 10 Home
    Thread Starter

    I'm wondering whether this issue could have to do with what's seen in Devices and Printers. Any USB device (albeit flash drive, USB HDD, etc) added to the computer becomes an Unspecified device...

    Thanks. You have a keen eye. That one passed right by me.

    I already tried those steps for Windows 8 in compatibility mode when I was in 1909.
    I had also tried previous Windows versions since Windows 7 comes up as the default when selecting “Try recommended settings” in the compatibility troubleshoot wizard. By selecting the other option “Troubleshoot program” … I was able to select Win 8 … 7, Vista, and also Win XP (SP 2) as other options for compatibility settings.

    I had pinned hopes on this method:

    Sandyt spotted a Windows 10 cab file for my Lexmark model. I’m going to give this a shot again. I had previously tried this procedure but chose a different cab file from the WUC. The only problem I ran into was the Wizard didn’t bring up the correct target file from the extracted files folder. It not even allow me to Browse to a target file. They apparently left an important piece out in the documentation.

    Thanks bobkn
    I’ll give sfc/scannow and DISM/Online/Cleanup-Image/Restore Health tools a try. It’s a bit of a stretch that any USB drivers are corrupted though. All Windows 10 drivers are signed and well tested and are therefore pretty stable. Status codes and red flags in device manager under various branches would have showed up.

    - - - Updated - - -

    So I installed the Lexmark Pro700 Series drivers for Windows 10 downloaded from WUC.
    No change in the printer status from when the Lexmark drivers for Windows 8 were installed.

    Every other USB device that's connected to my system will show a port number and hub number in accordance with Mass Storage Device under the branch for USB controllers in Device Manager . . . except for the Lexmark USB connected printer.

    I used the Add Printer wizard in Control Panel outlined in the steps of the MS documentation I included in my last thread. . .
    the wizard asks to choose a desired printer port where I selected the same port it had always been configured to be. I don't know if this could be a reason why there isn't a port or hub number in the location for the Mass Storage Device of this printer under Universal Serial Bus controllers. (attached are three screen shots).

    Anyone else have a USB connected printer that has Mass Storage Device look similar to what I'm seeing in Device Manager ?

    Attachment 262339
    Device Driver updated a different MS package this time after reinstall-device-manager_type_usb-controllers.jpg
    Device Driver updated a different MS package this time after reinstall-device-manager_type_usb-controllers_mass-storage-device.jpg
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:45.
Find Us

Windows 10 Forums