Boot drive from my old computer won't show up as external drive


  1. Posts : 36
    Windows 10
       #1

    Boot drive from my old computer won't show up as external drive


    Windows 10 version 1903

    I recently decided to finally upgrade my Windows 7 system to Windows 10. I bought a new SSD, removed my old SSD, and installed Windows 10 on the new one. This way I'd be able to go back to my old system if I forgot to back something up or just didn't like Windows 10. I wanted a backup plan.

    The Windows 10 upgrade went great and I have no problem with it. I'd like to wipe my old Windows 7 SSD and use it for something else, but I want to take a disc image of it first, just in case. I connected the SSD to an external enclosure, but the drive doesn't show up in the This PC window or in Disk Management. I suspect it might have something to do with it also be a C: drive, but I don't know how to change the drive letter if it won't show up in Disk Management. I also tried using EaseUS's software, but it didn't show up there either.

    Worst case scenario, I can install it back into my machine, load up Windows 7 and do a disc image there. But it kind of bugs me that this isn't working! Any ideas?

    Thanks in advance!

    TL;DR - The system drive for a Windows 7 install won't load as an external in my new Windows 10 system. Not appearing in Disk Management. Could this be a drive letter conflict?
      My Computer

  2. bro67's Avatar
    Posts : 8,395
    Mac OS Catalina
       #2

    Most likely Bios settings and possible enclosure issues.
      My Computers


  3. Posts : 36
    Windows 10
    Thread Starter
       #3

    Enclosure issues like it's damaged in some way? I was using it with a different SSD that works fine, so that's not it. Or do you mean the enclosure might not be compatible in some way? I doubt this one since I'm using another SSD in it that was manufactured around the same time.

    As for BIOS settings, can you be more specific about which types of settings? And is there a way I could set it to make this drive work, or could that cause other problems that make it not worth the trouble?

    Thanks!
      My Computer

  4. Bree's Avatar
    Posts : 20,053
    10 Home x64 (21H1) (10 Pro on 2nd pc)
       #4

    Ben789456 said:
    Enclosure issues like it's damaged in some way? I was using it with a different SSD that works fine...
    It's possible that it requires more power than the other SSD, the enclosure (or the USB port) may not be able deliver sufficient power. Does the HDD sound like it's spinning?


    Some enclosures have second USB lead that you can plug into a second port for more power. Have you tried it in another USB port?

    Edit: I now see from the original post that all your drives are SSD. The power comments are still valid though.
      My Computers


  5. Posts : 36
    Windows 10
    Thread Starter
       #5

    I see. I'll give it a try this evening with a plug-in enclosure.

    - - - Updated - - -

    You all nailed it. It was a power thing. I used another enclosure that plugs in rather than drawing all power from the USB connection and it worked. I'm doing the disc image thing right now. This is a bit of a bummer because I was hoping to save a USB plug by consolidating two external SSDs into one, but I'll just have to figure out another solution.

    Thank you for your help!
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:48.
Find Us




Windows 10 Forums