Dash Cam USB Puzzle


  1. Posts : 1,495
    Win10 Pro
       #1

    Dash Cam USB Puzzle


    I have a Vantrue X4 Dashcam that can download video files (mp4) through a USB Cable. This work fine on three of my PCs (2 desktops and a laptop, all Dell) but on the fourth desktop it shows up as a USB Mass Storage device, as it should, but disappears in a few seconds. A few seconds later it appears again only to go through the same cycle again. This message is displayed:
    Dash Cam USB Puzzle-capture.jpg
    If I restart the PC in safe mode the camera is shown as a USB Mass Storage device and I can copy the files. If I restart the PC in normal mode to continues to function fine. But then if I restart it again in normal mode the problem reappears.
    So, I looked in device manager and saw that there are not problems and I've checked that all of the USB entries have the latest drivers. There are a lot of hidden USB devices but as far as I can tell this is normal for this machine:
    Dash Cam USB Puzzle-capture3.jpg
    I looked under devices and printers and I see this for the Dashcam:
    Dash Cam USB Puzzle-capture1.jpg
    When I look under events tab under Information I see that this device needs further installation. I have no clue what the implies.
    Can anyone give me an advice for trouble shooting this and finding a fix? Could it be that some of the hidden USB devices are creating a conflict? Although it's not critical since I can access the files through one of my other PCs or I can always just eject the microSD card, I'd like to find out what's up with this.
      My Computers


  2. Posts : 1,495
    Win10 Pro
    Thread Starter
       #2

    Finally solved this. I was reading What would cause W10 to loose USB memory Stick Drive assignment ? so I followed the instructions in post #2 for deleting the hidden USB devices and then rebooting. Note that I didn't need to assign the variable described in the first part of the post. After rebooting and connecting the camera to a USB 2 post and not a USB 3 the PC recognized the camera as a mass storage device and I could copy the video files.
      My Computers


  3. Posts : 13,960
    Windows 10 Pro X64 21H1 19043.1503
       #3

    Setting the devmgr_show_nonpresent_devices variable to 1 often displays more devices.
      My Computers


  4. Posts : 1,495
    Win10 Pro
    Thread Starter
       #4

    Ztruker said:
    Setting the devmgr_show_nonpresent_devices variable to 1 often displays more devices.
    Thanks, I was wondering about that. I’ll definitely give that a try tomorrow morning. FYI, I’m reading the forum now on my iPad. Maybe that’s why the issue never occurred in Safe Mode. Maybe Safe Mode limits the loading of phantom USB devices by limiting the non-MS drivers?
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:32.
Find Us




Windows 10 Forums