Mouse - Device Descriptor Request Failed


  1. SHB
    Posts : 4
    Windows 10 x64
       #1

    Mouse - Device Descriptor Request Failed


    Every time I turn on my computer my mouse will not work / turn on and I get this problem: "Device Descriptor Request Failed".

    I've tried uninstalling the driver and restarting. Didn't work.

    I've tried updating the driver. Didn't work.

    I've tried changing my power options. Didn't work.

    I've tried switching USB ports. Didn't work.

    I've tried using a different computer but I get the same thing error.

    I can't update my Generic USB hub driver as there is no Generic USB hub shown.

    I can't do "Configure a device" via the Troubleshooting menu because I don't have that option.

    I've tried disabling fast startup. Didn't work.

    I know the mouse works as when I can fix this - which I've been able to do a few times but not sure on how - it works just fine. It's just when I startup my computer I get this problem. Every time.
      My Computer


  2. Posts : 35
    windows 10
       #2

    Not sure it's exactly the same, but simple to check. i had a similar problem because the mouse was usb 2 and the port was usb 3.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:25.
Find Us




Windows 10 Forums