Windows 10: Safely Remove Hardware icon with nothing plugged in, shows 3 dots(...) Solved

Page 2 of 3 FirstFirst 123 LastLast

  1. Posts : 8,349
    Windows 10 Professional
       05 Oct 2016 #11

    DavidsNeD88 said: View Post
    Hi,

    I have been having the same kind of 'safely remove hardware icon not going away' issue you used to have before. I have been struggling to fix the issue for a while but couldn't find the cause of the problem.
    Tried in device manager with the drivers of my card reader for example.

    Is there a way you could help me out with this?

    I would appreciate any help or advice.

    Thank you!
    Is it possible to hide it with 'Classic' Options?

    'Personalize (classic)' context menu - Add in Windows 10 - Windows 10 Forums

    Click image for larger version. 

Name:	000006.png 
Views:	1 
Size:	263.3 KB 
ID:	104485
      My ComputersSystem Spec


  2. Posts : 48
    Windows of various sorts
    Thread Starter
       05 Oct 2016 #12

    I'm sure that's possible but it's not a solution.
      My ComputerSystem Spec

  3.    05 Oct 2016 #13

    I tried with disabling it before but it did not solve it. At the moment however there is an option only for Uninstalling it and in its Properties-General tab says its not connected to the computer.

    Edit: At the normal Win10 settings 'Select which icons appear on the taskbar' it is greyed out and already turned off.
      My ComputerSystem Spec


  4. Posts : 48
    Windows of various sorts
    Thread Starter
       05 Oct 2016 #14

    Then I doubt the problem has anything to do with the card reader. It might your hard drive(s). Is your laptop running the default Microsoft AHCI/SATA drivers?
      My ComputerSystem Spec

  5.    05 Oct 2016 #15

    I assume yes. I have not installed it manually. Under 'IDE ATA/ATAPI controllers' there is 'Standard SATA AHCI Controller'.
    My SSD and HDD are working fine though and they don't show in the Safely Remove Hardware icon (only the 3 dots).
    I find it strange since I did not have this issue on Windows 7 before.
      My ComputerSystem Spec


  6. Posts : 48
    Windows of various sorts
    Thread Starter
       05 Oct 2016 #16

    Try installing the Intel SATA AHCI drivers. You might be able to find them on the appropriate web page for your Lenovo laptop model.
      My ComputerSystem Spec

  7.    05 Oct 2016 #17

    yogalD said: View Post
    Try installing the Intel SATA AHCI drivers. You might be able to find them on the appropriate web page for your Lenovo laptop model.
    Oh thank you So much for your help yogaID! Your guess was good! I was able to find a driver on the Intel Download Center for my Intel(R) 7 Series Chipset Family SATA AHCI Controller and, when I updated it in Device Manager and performed a restart, the icon FINALLY disappeared.
    I don't know why I only concentrated on the card reader.

    How can these little things be so frustrating.

    Anyway here is the link for the drivers for anyone's reference. I don't know why but for me the latest version that the Device Manager accepted was 12.9.0.1001. from 2013. :O

    Downloads for IntelĀ® Rapid Storage Technology (IntelĀ® RST)

      My ComputerSystem Spec

  8.    05 Oct 2016 #18

    Do you think I can update these drivers manually by just copying the .sys driver file to the 'windows/system32/drivers/' folder? (so i can try the latest version)
      My ComputerSystem Spec


  9. Posts : 48
    Windows of various sorts
    Thread Starter
       06 Oct 2016 #19

    I wouldn't risk replacing system files like that. Glad to have been of assistance
      My ComputerSystem Spec


  10. Posts : 8,349
    Windows 10 Professional
       06 Oct 2016 #20

    If all else fails, you could save the following as a .bat and put it in your Startup folder:

    reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\Applets\SysTray" /v "Services" /t reg_dword /d 29 /f
    systray


    (Not a solution either, but.......)
      My ComputersSystem Spec


 
Page 2 of 3 FirstFirst 123 LastLast

Related Threads
After upgrading to Windows 10, some desktop shortcuts have UAC shield icons. Is it possible to remove them? 26944 EDIT: Here's a solution... Launch the shortcuts via CMD: Right-click the shortcut to Properties Click Change Icon, then...
Cannot Safely Remove External Drives in Drivers and Hardware
Hello all, In recent weeks, it has become impossible for me to safely remove my external drives. (Mostly, I use Western Digital Passports, Passport Ultras, etc). I am using Windows 10. I close all of my programs and folders. I get the...
How to Hide or Show Search Box or Cortana Icon on Taskbar in Windows 10 The Search box on your taskbar makes it easier for you to search the web and Windows. It also allows you to be able to turn on or off to have Cortana give you suggestions,...
Safely Remove usb in General Support
Hi All All's good so far with Windows 10 upgrade, after coming here not been able to activate Windows but thanks to this site I was able to find a resolution, clicking like mad on the Activate button done the trick sounds weird but it worked :D...
How to safely remove W10? in Installation and Upgrade
I installed W10 in a E: partition and after trying it I prefer to remove it. I had boot problems lately in this laptop after formating and deleting the partition as I have always done to get rid of some testing OS. It didn't boot at all and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:35.
Find Us