"RPC server not available" - Computer Management/Disk Management

Page 1 of 2 12 LastLast

  1. Posts : 24
    Win 10 64-bit Build 1903
       #1

    "RPC server not available" - Computer Management/Disk Management


    For months now I have been unable to connect USB drives automatically in Win 10. When I go to Computer Management/Disk Management I often see the drive there, but with no drive letter, so I have to manually add the drive with a new drive letter.
    If I try to "Refresh" or "Rescan" the disks in Disk Management I get either a "Remote Procedure Call failed" message or "RPC server not available" message.

    Recently I upgraded my computer to a new everything, (mobo, USB ports, etc.) but cloned the system drive. That didn't help resolve the issue, so it's obviously not hardware but something in Windows. That being said, I am on a MSI Z390-A Pro mobo, i7-9700K, GTX 1660, 32GB Kingston

    I have AVG free virus and Malwarebytes Premium and Windows Defender Firewall

    Here are the things I have already tried to fix this:
    Checked to make sure of the following settings in "Services":
    DCOM Service Process Launcher Automatic
    Remote Procedure Call Automatic
    Remote Procedure Call Locator: Manual
    Did not help

    I have done CMD line sfc /scannow which reported some files were replaced. Did not help

    Went to ncpa.cpl and made sure File and Printer sharing was on; that Internet Protocol Version 6 checked. Did not help.

    Went to Windows Defender Firewall and added everything titled "Remote..." - Did not help
    Turned off Windows Firewall entirely - Did not help.
    Turned on Windows Firewall with the option of "Notify me when blocking a new app" - Did not help

    Checked registry entries for RpcSs, DcomLaunch, RpcEptMapper, and all were set correctly for Dword=2.
    Did not help.

    Flushed DNS. Did not help.

    I am at wit's end. I do not know what else to do. I did all these things by rote from advice from several sites, I don't have a deep knowledge of Windows. I just want to be able to get to my drives without a lot of hassle.

    Thanks in advance for any suggestions.
      My Computer


  2. Posts : 34,987
    Win 10 Pro (1903) (2nd PC is 21H2)
       #2

    Hi,suggest you try two possible sledgehammer approaches. The first is less dramatic and tries to fix your build as is.

    First, check this is not associated with your user profile.
    Create a new user for test purposes, log in as that user and see if the same thing happens.
    If it does, continue, else stop and post your findings.

    Before these two, I suggest you create a current disk image (tenforums recommends the routine use of disk imaging frequently) -e.g. Macrium reflect (free/paid).

    Then, download and install Tweaking.com's free cautious repair tool:
    Tweaking.com - Windows Repair Free/Pro

    Run that, following its recommendations carefully, and select e.g. only these repairs:
    1,2,3,4,10,22, 25, 26, 29

    See if there's any change. No guarantees whatsoever as to whether it will deal with your problem.

    If not, then try an in-place upgrade repair install which keeps all progs and data just like any upgrade.

    For this you will need an iso file of the same build as your current Windows.

    I don't believe you've stated your Windows build - your specs say Win 7. So...
    for 1903 use the
    - MS media creation tool
    for older builds
    - Heidoc iso downloader
    (Google e.g. to find these)

    Log in, rt click the iso, click Mount
    (Mount is not available if you have associated iso with something else)
    Open the new drive created, double click setup.exe
    For more detail say the in-place upgrade repair tutorial.
    Last edited by dalchina; 14 Sep 2019 at 11:32.
      My Computers


  3. Posts : 24
    Win 10 64-bit Build 1903
    Thread Starter
       #3

    Thanks, Dalchina, for the quick reply. I have appointments today so I'll try your solutions a bit later. I've updated my specs in my profile. My current OS is Win 10 Version 1903 Build 18362.356

    - - - Updated - - -

    Hi, Dalchina, that was frustrating. I tried the Tweaking app and all I got was broken file associations.

    Then I tried the Repair Install, following all the directions in the tutorials; Download ISO, mount, etc.. It took a very long time, which would have been worth it if it had worked. Alas, it, too, failed.

    I tested the 'Refresh' option in Disk Management and also the 'Disc Rescan'. The error messages are 'RPC server not available'

    Now I really am at wit's end. Any further suggestions? Do I take it in to a local shop? Voodoo curses? Molotov cocktail? thanks in advance.
      My Computer


  4. Posts : 34,987
    Win 10 Pro (1903) (2nd PC is 21H2)
       #4

    Hi, did you first check creating a new user as I suggested? if the problem is user profile specific the other repairs won't have any effect.

    I tried the Tweaking app and all I got was broken file associations.
    Odd- did you select only the repairs I suggested? Shouldn't have affected file associations at all.

    Assuming you followed the way it's meant to be used and used it as admin in Safe Mode, you should have been able to reverse that, as it tried to make sure you have a backup, System Restore point.
      My Computers


  5. Posts : 24
    Win 10 64-bit Build 1903
    Thread Starter
       #5

    I guess I really stepped in it. I did not create a new user account; I must have glossed over that in your post. I did select only the repairs you suggested.

    I tried to work from Safe Mode, but when Safe Mode appeared on my screen it was just a blank screen with a blurry wallpaper and three buttons at the lower right: Internet, which did not do anything at all, date and time. and shut down. There was no obvious way to do anything at all; none of the buttons did anything except for the shut down button. So I just ran it from my normal login.

    I would have liked a System Restore Point, but in my experience of the last ten years starting with Win7, I have never had a System Restore point actually created, I've only got error messages that it couldn't be created. But, in any case, the opportunity to create one wasn't presented, owing, undoubtedly, to my prior errors.
      My Computer


  6. Posts : 34,987
    Win 10 Pro (1903) (2nd PC is 21H2)
       #6

    Indeed an odd set of problems:
    - USB problem in normal mode
    - Safe Mode display abnormal
    - Unable to create SR points

    Just to confirm: did you do this to enter Safe Mode?
    Boot into Safe Mode on Windows 10

    Note: you can start that from the Power button on the login screen - SHIFT + left click restart.
    Perhaps you could post a photo of that screen.

    Are you over-clocking?

    SR - the usual problem is with restoring. Failure to create suggests a problem with services again.
    Do you get an error message if you try to create one manually? (E.g. Win key + s, search for 'restore')

    Have you ever disabled or modified any services? That said, now that you've done an in-place upgrade repair install, services should be reset to default.

    Meanwhile do try the new user approach.
      My Computers


  7. Posts : 24
    Win 10 64-bit Build 1903
    Thread Starter
       #7

    Thanks, Dalchina, glad you're still sticking around.

    I didn't follow the standard procedure to enter Safe Mode. When I started Tweaking it offered a button to start in Safe Mode which I pressed. That led to the weird screen I described.

    I am not overclocking.

    As for Restore, I have never been able to create a Restore Point at any time. This includes all the different programs that are supposed to create a Restore Point before they proceed. All I get is the message about not being able to create a Restore Point. I just shrugged and chalked it up to a belief that most software programs lie to you.

    Unfortunately, I am leaving town for a week and won't be able to try again until next weekend, and my wife wants no part of this process.

    When I get back I will try to do the following:
    Reset all services to default, because I have fiddled with services in the past.
    Set up a new user account to try to replicate the problem.
    Try to set a Restore Point using TenForums tutorial

    I do have a question about the new user account, never needing one before: will I have access to everything the old user account had or do I have to do a lot of hoop jumping to be functional?

    Thanks, again, for your help.
      My Computer


  8. Posts : 34,987
    Win 10 Pro (1903) (2nd PC is 21H2)
       #8

    Ok, could be problems have arisen because of non-default service settings. However, the in-place upgrade repair install should have fixed that.

    Check you can get to Safe Mode conventionally.

    The new user is, as I said, for test purposes only- and can then be deleted. It will look a bit different to what you're used to and some startups will be different. All we're interested in is whether you see the same symptom when logged in as that user.
      My Computers


  9. Posts : 24
    Win 10 64-bit Build 1903
    Thread Starter
       #9

    Dalchina - right after I got back I got hammered by a very nasty bug; just emerging now.

    I managed to enter Safe Mode successfully using msconfig. The RPC server error occurred again.

    I created a new User account and the RPC server error occurred there, too.

    I acceded to a Windows update so now my version is Win 10 Version 1903 Build 18362.239

    Amazingly enough I was able to create a Windows Restore point! There was already one in the system from the last Windows Update, but none from before that.

    I uninstalled AVG anti-virus and am now using Windows Defender. the RPC server error still happens.

    Do you have any advice on where to go from here? Thanks for your help and patience.
      My Computer


  10. Posts : 34,987
    Win 10 Pro (1903) (2nd PC is 21H2)
       #10

    Hi, given that you've upgraded, you'd expect services to be correct and default.

    Have a look at
    5 Ways to Fix "The RPC server is unavailable" Windows Backup Error
    from 'Way 1' and report results.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 09:47.
Find Us




Windows 10 Forums