Very frequent game crashes, occasional bluescreens in Dota 2 with new


  1. Posts : 1
    Windows 10
       #1

    Very frequent game crashes, occasional bluescreens in Dota 2 with new


    Sorry for long post, but I am desperate for a solution to an issue I know from experience to be very time-consuming.

    I replaced all but the case and GPU in my PC and made fresh Windows 10 installation on new SSD. The aforementioned crashes ONLY happen in Dota 2 (granted the only other game I've played on here is WoW Classic), and make the game unplayable, because it is an online competitive action-RTS game (also, I hate to admit, a huge part of my life), for those who aren't familiar. And time lost is game-losing. Anyway, I encountered my first problems when I installed the latest AMD driver and software. Halfway through the cursor disappeared, the screen froze, and the GPU fan went to max RPM, followed by black screen. Upon rebooting, all seemed well as Windows update appeared to fill in the blanks in drivers (I had not yet connected to my internet when I attempted to install video drivers), and I got the AMD software by running setup from the C:\AMD directory. The Dota 2 client recommended that I set it to use DX11, so that is what I still have it on. I encountered problems in my first game with a bit of strange stuttering, and then the first blue screen. In subsequent Dota matches I have had 1-4 game crashes per game where the process quits with no warning. As far as the Windows blue screens, I have had 3 of them so far (they occur while Dota 2 is running), and they are always a different stop code (I wish I had recorded them), but a couple remind me of video driver issues I've had before on other systems. I am quite hesitant to uninstall/reinstall the driver as doing so in past AMD driver issues on a certain other system has always led to me having to reinstall Windows with still at best a partial fix on the original issue (at worst the card becomes entirely unusable), so I would like to receive input from others before I try anything.

    Here is driver and software info from the application:
    Radeon Settings Version - 2019.0903.1407.25433
    View Release Notes - https://www.amd.com/en/support/kb/re...rad-win-19-9-1
    Driver Packaging Version - 19.30.01.50-190903a-346453E-RadeonSoftwareAdrenalin2019
    Provider - Advanced Micro Devices, Inc.
    2D Driver Version - 8.1.1.1634
    Direct3D® Version - 9.14.10.01410
    OpenGL® Version - 26.20.11000.13571
    AMD Audio Driver Version - 10.0.1.6
    Vulkan™ Driver Version - 2.0.106
    Vulkan™ API Version - 1.1.119

    And here is my system:
    MSI B450 Tomahawk motherboard
    AMD Ryzen 2600X
    Corsair Vengeance LPX 2x8GB 3466Mhz 16-18-18-36(?)
    AMD RX 470 4GB
    A good NVMe M.2 SSD

    Also please note I have the XMP memory profile on as well as "game boost" from BIOS (CPU multiplier up such that freq is 4.05Ghz). And temps have been fine, no more than 70C on anything under load. My PC otherwise runs flawlessly.

    Any suggestions that could help me at all are greatly appreciated! Thanks so so much for your time.
      My Computer


  2. Posts : 1,277
    Windows 10
       #2

    start by lowering your xmp to normal and see if the problem persist , also try removing and re-seating the gpu card maybe is not seated properly .
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 07:59.
Find Us




Windows 10 Forums