My Win 10 PC doesn't "see" my old Kindle device Solved


  1. Posts : 33
    Windows 10
       #1

    My Win 10 PC doesn't "see" my old Kindle device


    If I plug in my old Kindle in to my Win 10 PC, using the supplied USB cable, it can't "see" the Kindle's data storage area. My PC works fine, and all of the USB ports work fine. The cable works fine too, as the Kindle is able to recharge OK with this cable. But I can't access the Kindle's built in disk drive. I can do this fine on my older Win 7 netbook, but now that I have Win 10 on my main PC, I can't do this. Any ideas please? Thanks a lot for any comments.
      My ComputerSystem Spec

  2. dalchina's Avatar
    Posts : 19,816
    Win 10 Pro (1903)
       #2

    Hi, I'm guessing you're using USB3 ports. Please see this where the author found a way round it:
    USB3 ports cannot recognize USB2 Kindle - External Hardware
      My ComputersSystem Spec


  3. Posts : 33
    Windows 10
    Thread Starter
       #3

    Thanks a lot. Actually, there is another reason why, and I found out by trial and error. For some odd reason, the cable is at fault. Although it charges the device, it won't allow my PC to "see" the Kindle hard drive. I changed the cable, and lo and behold, it charges OK and also "sees" the Kindle now.
      My ComputerSystem Spec

  4. dalchina's Avatar
    Posts : 19,816
    Win 10 Pro (1903)
       #4

    Always worth trying swapping things... glad you've got it working.
      My ComputersSystem Spec


 

Related Threads
So, I've got a Computer with GT630. I've installed windows 10 and I tried installing the drivers for my Nvidia GT630, and it gave me an error that says I don't have an NVIDIA GPU. I've used DXDIAG to look at my specifications and it showed me...
Hi all, I just recently discovered this problem on my Win10Pro x64 PC. Location stopped working for some reason (I noticed because Night Light stopped functioning at the correct times - sunset / sunrise). In the Location area of Settings ->...
Recently, I noticed that when I click the "Uninstall or change a Program" button, "Apps and Features" in the Settings window opens rather than the "Programs and Features" window it always was. I preferred that window as it showed more programs and...
I had to buy a new (SSD) HD and had trouble booting from a disc until I enabled Legacy Mode and disabled Secure Boot in BIOS. Now whenever I boot up I get a "No Boot Device Found" message until I hit "Enter" at which point i'm allowed entry into my...
anyone seen this? build 10166, lenovo yoga 2. lots of missing devices, all driver packages for said devices bail out at install with the same message "Realtek bluetooth suite doesn't work on this PC", regardless of device. searched high and low via...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 06:48.
Find Us