M.2 Drive Not Found By Bios


  1. Posts : 555
    Windows 10 PRO 64Bit
       #1

    M.2 Drive Not Found By Bios


    I bought a Samsung 970 EVO Plus NVMe M.2 drive and when I install it into my system the bios does not find it. Windows 10 PRO finds it and I am able to format and use it. I think it is a motherboard bios issue because my old Samsung 950 PRO NVMe M.2 drive is found by the bios and I am able to boot from it. I don't expect Asus to provide a bios update for my old Maximus Hero VI.

    Time to go shopping for a new motherboard?

    Ak
      My Computer

  2. NavyLCDR's Avatar
    Posts : 13,363
    Windows 10 Pro
       #2

    I don't see an M.2 slot on the Maximus Hero VI.
      My Computer


  3. Posts : 555
    Windows 10 PRO 64Bit
    Thread Starter
       #3

    NavyLCDR said:
    I don't see an M.2 slot on the Maximus Hero VI.
    You are right but a PCIe M.2 adapter has worked for me with the Samsung 950 PRO as a boot drive and it still does.

    Ak
      My Computer


  4. Posts : 555
    Windows 10 PRO 64Bit
    Thread Starter
       #4

    I think I have found out why this 970 EVO Plus M.2 is so much slower than my older 950 PRO M.2, the PCIe slot that it is using is Gen 2.0. It is still way faster than a hard drive so I am sort of happy for now. I still don't know why the bios sees the 950 PRO and not the 970 EVO.

    Ak
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:37.
Find Us




Windows 10 Forums